15:01:08 <DaveBarach> #startmeeting fdio-vpp
15:01:08 <collabot> Meeting started Tue Mar 19 15:01:08 2019 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:08 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:08 <collabot> The meeting name has been set to 'fdio_vpp'
15:02:11 <DaveBarach> #topic csit Maciek reporting
15:02:26 <mackonstan> #info CSIT-1901.1 maintenance report to be published shortly
15:03:07 <mackonstan> #info Update on major work items:
15:03:29 <mackonstan> #info test suite auto-gen completed (any NIC variations, any throughput methodologies),
15:04:06 <mackonstan> #info VAT to PAPI migration in full swing, introduced "thin-VM" for all vhost tests.
15:04:38 <mackonstan> #info Tracking and verifying VPP API/PAPI changes - see gerrit link, discussion later led by Dave Wallace
15:04:44 <mackonstan> #link https://gerrit.fd.io/r/#/c/18356/
15:07:37 <DaveBarach> #topic host stack (Florin)
15:08:24 <DaveBarach> #info switch to cut-through transport vs. apps mapping multi-queues
15:08:36 <DaveBarach> #info lots of cleanup patches pushed
15:09:05 <DaveBarach> #info consolidate generation of tcp packets, setup work for a more generalized pacing scheme
15:09:53 <DaveBarach> #topic Docs
15:11:28 <DaveBarach> #info Paul V reports make test docs already in the tree
15:12:58 <DaveBarach> #action dbarach to chase down releasing test docs through usual "make docs" run
15:13:31 <DaveBarach> #topic Arm  (Sirshak reporting)
15:14:08 <DaveBarach> #info cache-line size 128 (thx2) packaging issue
15:20:34 <DaveBarach> #info build from source => host
15:21:33 <DaveBarach> #info Damjan suggest aligining thread structures to 128 to reduce the pain involved
15:22:15 <DaveBarach> #topic Releases (Dave Wallace reporting)
15:22:22 <DaveBarach> #info 19.01.1 released
15:22:41 <DaveBarach> #info request for 19.01.2 to add patches
15:23:12 <DaveBarach> #info csit cycles are a rate limiter. Once we get to 3/27, won't be able to spend csit resources on 19.01.X
15:24:14 <DaveBarach> #info need to track down who needs 19.01.2 and work with them offline
15:27:42 <DaveBarach> #info sounds like Yichen and company
15:28:08 <DaveBarach> #info we need to close this before next Weds.
15:28:18 <DaveBarach> #action dbarach to facilitate email offline
15:29:33 <DaveBarach> #topic 19.04 (Dave Wallace)
15:29:56 <DaveBarach> #info reminder of F0 (API freeze) date 4/3/2019
15:30:58 <DaveBarach> #topic Python3.0 transition (Dave Wallace)
15:31:25 <DaveBarach> #info leave 2.7 support in place until 3.0 hardening done
15:31:53 <DaveBarach> #info Paul V: 2.7 not removed except in Makefiles
15:32:23 <DaveBarach> #info planning to switch in the 19.08 time frame
15:32:35 <DaveBarach> #info documentation runs (only) in 3.0
15:32:49 <DaveBarach> #info vppapigen runs over Py v3
15:33:30 <DaveBarach> #info requirements.txt controls the Py version
15:36:05 <DaveBarach> #info Py 2 => 2.7 only. Py 3 => 3.5...3.8 or similar
15:36:46 <DaveBarach> #info easier to go to 3.6 or above
15:54:26 <DaveBarach> #topic API Flag Day (Dave Wallace)
15:54:51 <DaveBarach> #info try to avoid having csit-incompatible API patches merged
15:55:07 <DaveBarach> #info identify / notify vpp API changes
16:03:55 <DaveBarach> #endmeeting