14:59:28 <DaveBarach> #startmeeting fdio-vpp
14:59:28 <collabot> Meeting started Tue Apr 16 14:59:28 2019 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:28 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:28 <collabot> The meeting name has been set to 'fdio_vpp'
15:01:12 <DaveBarach> #topic CSIT (Maciek reporting)
15:02:25 <mackonstan> #info CSIT rls1904 branch pulled, dry runs of vpp-19.04 starting
15:02:41 <mackonstan> #info Content of CSIT-1904 in wiki
15:02:46 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit1904_plan
15:02:56 <mackonstan> #info Two issues in trending:
15:03:03 <mackonstan> #info i) IPsec tunnel-interface test failures, VPP fix https://gerrit.fd.io/r/#/c/18834/ to be verified
15:03:49 <mackonstan> #info ii) VPP with DPDK driving physical interfaces: packets not passing in VPP configs with large number of rx queues and workers (over 16rxq/multi-queues) that require high values of buffers-per-numa, resolution in progress. The same tests with native VPP AVF driver work fine.
15:05:00 <DaveBarach> #topic Honeycomb (Michal C reporting)
15:05:07 <DaveBarach> #info tomorrow code freeze for 19.04
15:05:26 <DaveBarach> #topic Host Stack (florin c reporting)
15:05:38 <DaveBarach> #info 19.04 host stack stable
15:06:14 <DaveBarach> #info 19.08 development: refactor svm infra to support dynamic fifo sizing
15:06:34 <DaveBarach> #info autotuning algorithm not currently in-scope
15:07:18 <DaveBarach> #info fifos need to change. Thanks Sirshak for help
15:07:28 <DaveBarach> #info added a basic rb-tree implementation to vppinfra
15:08:43 <DaveBarach> #topic aarch64 (Sirshak)
15:08:56 <DaveBarach> #info removing 2**n fifo size restriction in patch
15:09:28 <DaveBarach> #info packaging change patch ready for review 19.08 delivery
15:10:02 <DaveBarach> #topic 19.01 (Dave Wallace)
15:10:27 <DaveBarach> #info require 19.01.2, to start after 19.04 formal release, first week of May
15:10:43 <DaveBarach> #topic 19.04 (Dave Wallace)
15:10:47 <DaveBarach> #info RC1 last week
15:11:02 <DaveBarach> #info a number of issues found + fixed, will update document / cookbook
15:11:22 <DaveBarach> #info freezing master [we don't really need to]
15:11:40 <DaveBarach> #info label position requirements will be documented
15:12:35 <DaveBarach> #info next time, we should need to freeze master for about ten minutes
15:14:55 <DaveBarach> #info issue w/ centos validation, thanks to tom/billy for help straightening it out
15:15:34 <DaveBarach> #info we don't have a patch validation requirement for centos. Workaround: hand-install packages
15:16:08 <DaveBarach> #info a hole when we install new features
15:16:23 <DaveBarach> #info Tom H has a patch ready for the spec file
15:20:12 <DaveBarach> #info minor issues: csit midly confused by labels, initial merge jobs failing because packagcloud repo had nothing in the "bionic" section
15:21:23 <DaveBarach> #info merge job failing because base pkg repo add uses master for dependencies, need to uninstall before trying to make 19.04 version
15:22:17 <DaveBarach> #info name of the next release discussion, cadence
15:22:38 <DaveBarach> #info any issue w/ revising the release cadence to 3/yr, aka 4 months
15:28:35 <DaveBarach> #info Considering a 12/18 formal release date
15:32:33 <DaveBarach> #agreed release cadence going forward will be xx.1 xx.5 xx.9, with 19.08 as planned
15:33:36 <DaveBarach> #info RC2 tomorrow, please get fixes in ASAP, must have JIRA ticket numbers
15:34:49 <DaveBarach> #topic Infra Status (Ed Kern reporting)
15:34:58 <DaveBarach> #info minor latency spike this morning
15:35:11 <DaveBarach> #info will release old arm nodes shortly
15:35:39 <DaveBarach> #info will update servers which have been up for > 300 days
15:38:38 <DaveBarach> #endmeeting