14:59:53 <DaveBarach> #startmeeting fdio-vpp
14:59:53 <collabot`> Meeting started Tue Jul  9 14:59:53 2019 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:53 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:53 <collabot`> The meeting name has been set to 'fdio_vpp'
15:00:17 <DaveBarach> #topic CSIT (Maciek reporting)
15:00:18 <mackonstan> #info Maciek
15:02:13 <mackonstan> #info Lots of infra work
15:02:51 <mackonstan> #info Continuing work on VAT to PAPI migration, going OKay (~70% complete)
15:03:13 <mackonstan> #info Unfortunately PAPI not fit-for-purpose for scale tests, so have to stick to VAT for time being
15:03:58 <mackonstan> #info Moving to remote PAPI (PAPI over remote socket) next week (needed for performance: avoiding json and other "wordy" serialization)
15:04:31 <mackonstan> #info Aligning performance and functional-device python libraries for seamless test portability, needed for VIRL turn-off
15:05:13 <mackonstan> #info VPP-CSIT CI alignment on master: CSIT VPP API gating (aka "VPP API flag day") job should be coming alive in next couple of weeks
15:05:31 <mackonstan> #info Re vpp-csit-verify-device-master jobs voting status: need stable PAPI before this can be entertained
15:05:47 <mackonstan> #info Trending tests back in working
15:05:59 <mackonstan> #info Performance tests:
15:06:13 <mackonstan> #info baremetal IPsec up to 60k tunnels (almost working), same for VPP-in-containers with scale-out
15:06:27 <mackonstan> #info dotq+vxlan+vhost+manyVMs NF density tests
15:06:46 <mackonstan> #info arm and denverton performance tests are going production
15:06:52 <mackonstan> #info other great news, we finally got TRex code with HDRhistogram for granular per-packet latency measurements
15:07:26 <mackonstan> #info CSIT-1908 plan wiki updated
15:07:32 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit1908_plan
15:08:32 <DaveBarach> #topic Sweetcomb (Yohan Pipereau reporting)
15:08:43 <DaveBarach> #info trying to leverage vom
15:09:13 <DaveBarach> #info support srv6 in VOM -> land support in sweetcomb
15:09:56 <DaveBarach> #info open question openconfig vs or in addition to IETF yang models
15:10:07 <DaveBarach> #topic Host Stack (Florin reporting)
15:10:19 <DaveBarach> #info good number of commits
15:10:24 <DaveBarach> #info TCP corner-case fixes
15:10:37 <DaveBarach> #info new congestion control APIs
15:11:02 <DaveBarach> #info multiple chunk SVM fifo support improved, including new tests
15:11:18 <DaveBarach> #info SCTP moved to a plugin, disabled by default
15:11:29 <DaveBarach> #info SCTP not maintained
15:12:17 <DaveBarach> #info could consider moving other transports to plugins
15:13:00 <DaveBarach> #topic Documentation / main website (John DeNisco reporting)
15:13:12 <DaveBarach> #info trying to involve LFN / LF marketing
15:13:26 <DaveBarach> #info would like to start a biweekly meeting to gain momentum
15:14:02 <DaveBarach> #info need to point DNS names at the new site
15:16:18 <DaveBarach> #topic AARCH64 (Hoppapa reporting)
15:16:32 <DaveBarach> #info lock tuneup benchmarks in progress
15:16:54 <DaveBarach> #info working on l3fwd path dual-looping
15:17:15 <DaveBarach> #topic 19.04 release (Dave Wallace)
15:18:29 <DaveBarach> #info 19.01 final maintenance release in progress
15:18:52 <DaveBarach> #info 7/17 close-date for 19.01.3
15:19:10 <DaveBarach> #info several patches since 19.04.1
15:19:32 <DaveBarach> #info shall we try to do a 19.04.2 in July?
15:19:43 <DaveBarach> #info 7/24 suggested date
15:20:00 <DaveBarach> #agreed 19.04.2 to be frozen on 7/24
15:20:39 <DaveBarach> #topic 19.08 (Andrew Y reporting)
15:22:32 <DaveBarach> #info in 20.01 commit msg metadata will help cross-reference release notes
15:23:17 <DaveBarach> #topic Upcoming API changes (Dave W)
15:28:44 <DaveBarach> #topic Infra (Ed Kern reporting)
15:28:57 <DaveBarach> #info one hard drive failure
15:29:27 <DaveBarach> #info no feedback from LF w.r.t. debug logs, memory leaks making Jenkins slow
15:31:51 <DaveBarach> #info discussion about parallel pcap file creation
15:35:35 <DaveBarach> #topic libmemif most likely moved to "extras" package in 19.04
15:36:36 <DaveBarach> #topic Zoom meeting security issues
15:36:53 <DaveBarach> #action ping the LF after some google searching
15:37:26 <DaveBarach> #endmeeting