#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:01:34 UTC (full logs).

Meeting summary

    1. Daily perf tests - failures: (mackonstan, 15:03:36)
    2. daily perf runs throttled back due to 19.08 CSIT report generation / testbed capacity (DaveBarach, 15:03:53)
    3. - papi dump calls, remote socket connection not opening, intermittent, affects ~3% of tests (mackonstan, 15:03:59)
    4. - memif activation failures, intermittent (mackonstan, 15:04:12)
    5. - avf activation failures, intermittent (mackonstan, 15:04:23)
    6. CSIT-1908 release status (mackonstan, 15:04:34)
    7. Draft version of CSIT-1908 test and benchmarking report is available on the CSIT master report link (mackonstan, 15:04:45)
    8. https://docs.fd.io/csit/master/report/index.html (mackonstan, 15:04:58)
    9. Most tests on Xeon, Atom and Arm testbed are completed, some are finishing tomorrow (mackonstan, 15:05:19)
    10. Some VPP throughput regressions and progressions spotted - see my email to vpp-dev and csit-dev yesterday (mackonstan, 15:05:32)
    11. Some are CSIT, some look like VPP, see latest analysis in CSIT gerrit commits: (mackonstan, 15:05:54)
    12. - csit1908_perf_analysis_2n_skx.md: https://gerrit.fd.io/r/c/csit/+/21637/ (mackonstan, 15:06:01)
    13. - csit1908_perf_analysis_3n_skx.md: https://gerrit.fd.io/r/c/csit/+/21641/ (mackonstan, 15:06:09)
    14. "Official" CSIT-1908 report will be published tomorrow, on schedule :) (mackonstan, 15:06:16)
    15. https://docs.fd.io/csit/rls1908/report/index.html (mackonstan, 15:06:21)
    16. Will send announce email per usual (mackonstan, 15:06:27)

  1. Host Stack (Florin reporting) (DaveBarach, 15:07:15)
    1. moving control API calls from binary API to the host stack message queue (DaveBarach, 15:07:32)
    2. old APIs are still operational, planning to remove them post 20.01 (DaveBarach, 15:08:00)
    3. async / non-blocking connect added for Envoy (DaveBarach, 15:08:22)
    4. TCP improved mss handling for v4, v6 (DaveBarach, 15:08:34)
    5. if anyone is interested in host-stack crypto, Nathan has been working on it for TLS (DaveBarach, 15:09:05)
    6. simon @ intel has a TSO patch in progress -major vector rate reduction for TX side (DaveBarach, 15:09:58)

  2. Documentation (John, Ray) (DaveBarach, 15:13:36)
    1. RX marketing section feeback from Ray (DaveBarach, 15:13:50)
    2. ACTION: jdenisco to try to pick a cut-over date (DaveBarach, 15:16:17)

  3. aarch64 (Honnapa reporting) (DaveBarach, 15:17:23)
    1. dual-loop optimization, bihash optimization in progress (DaveBarach, 15:17:41)

  4. 19.04 (Dave Wallace) (DaveBarach, 15:18:04)
    1. few patches no formal release planned at this time (DaveBarach, 15:18:25)

  5. 19.08 (Andrew reporting) (DaveBarach, 15:18:46)
    1. 8 commits merged since formal release (DaveBarach, 15:18:56)
    2. possible change to api string type (DaveBarach, 15:20:04)
    3. question: can we merge it (DaveBarach, 15:20:09)
    4. ACTION: ole hook up with ray to discuss the vppapigen VLA issue (DaveBarach, 15:26:48)
    5. "while we're at it" a couple of memif API issues could be resolved (DaveBarach, 15:27:48)
    6. zero-copy control disappeared, could fix it (DaveBarach, 15:28:29)

  6. API changes (DaveBarach, 15:33:35)
    1. jerome: about to release vpp 19.08 openstack (DaveBarach, 15:34:00)
    2. acl add/replace had a CRC change - name of type of acl rule type caused the change (DaveBarach, 15:35:39)
    3. https://gerrit.fd.io/r/q/project:vpp+is:open+path:%5E.*/.api (dwallacelf, 15:46:26)
    4. Please ignore previous link -- it doesn't work with latest gerrit version. (dwallacelf, 15:47:37)

  7. infra (Ed K) (DaveBarach, 15:49:50)
    1. "runtest" = "recheck," (DaveBarach, 15:50:01)


Meeting ended at 15:52:16 UTC (full logs).

Action items

  1. jdenisco to try to pick a cut-over date
  2. ole hook up with ray to discuss the vppapigen VLA issue


People present (lines said)

  1. DaveBarach (30)
  2. mackonstan (16)
  3. collabot` (3)
  4. dwallacelf (2)
  5. mortderire (1)


Generated by MeetBot 0.1.4.