#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:00:06 UTC (full logs).

Meeting summary

    1. mackonstan (mackonstan, 15:01:06)

  1. CSIT (Maciek reporting) (DaveBarach, 15:01:40)
    1. daily performance tests: two failures. papi dump, memif (DaveBarach, 15:02:14)
    2. AVF activation failures fixed (DaveBarach, 15:02:23)
    3. thanks Damjan (DaveBarach, 15:02:27)
    4. 19.08 release published on 9/12 (DaveBarach, 15:02:39)
    5. final maintenance CSIT report for 1908 published tomorrow (mackonstan, 15:03:19)
    6. final maintenance report for 19.08 to be published tomorrow (DaveBarach, 15:03:20)
    7. packet loss test during vhost add/del ops (DaveBarach, 15:04:02)
    8. Nexus infra issue continue (DaveBarach, 15:04:40)
    9. plan-b if Nexus can't be cleaned up: use our own data backend (DaveBarach, 15:05:06)
    10. ticket open, will talk about problem at TSC on Thursday (DaveBarach, 15:05:37)

  2. Host Stack (Florin) (DaveBarach, 15:05:52)
    1. nothing major, a number of stack hardening small patches (DaveBarach, 15:06:10)
    2. start using SACKs during timer-based recovery in addition to fast recovery (DaveBarach, 15:06:29)
    3. improving RTT estimates (DaveBarach, 15:06:40)

  3. Documentation / main sites (John D) (DaveBarach, 15:07:24)
    1. main site ready to go, hope to flip switch in next 24 hours (DaveBarach, 15:07:43)

  4. Infra (Ed Kern) (DaveBarach, 15:09:02)
    1. timeout issues: calls w/ LF sysadmin, vexxhost (DaveBarach, 15:09:21)
    2. not clear what the problem is, will roll out open daylight style workarounds (DaveBarach, 15:09:45)
    3. will need a bit of downtime to turn on workarounds (DaveBarach, 15:10:17)
    4. ACTION: ejk will tune up failure analysis list to cover MAINTAINER file fails in commit logs, C and PEP8 checkstyle failures (DaveBarach, 15:13:09)

  5. 19.04 (Dave Wallace) (DaveBarach, 15:15:29)
    1. waiting for critical mass to do another point release (DaveBarach, 15:15:39)

  6. 19.08 (Andrew) (DaveBarach, 15:15:48)
    1. prefix-length 2x types issue affecting our ability to release 19.08.1 (DaveBarach, 15:16:26)
    2. will release 19.08.1 on Weds (DaveBarach, 15:16:39)
    3. not pushing people for cherry-picks until we tag and build 19.08.1 (DaveBarach, 15:17:29)

  7. API changes (Dave Wallace) (DaveBarach, 15:22:31)
    1. nothing queued up at the moment (DaveBarach, 15:22:43)
    2. ole will add script support to give a heads-up when APIs change (DaveBarach, 15:23:39)

  8. LTS branch performance testing (DaveBarach, 15:28:36)
    1. cherry-pick rate is much higher than it has been in the past (DaveBarach, 15:28:50)
    2. Maciek: need to repeat tests to keep an eye on LTS branch perf (DaveBarach, 15:29:28)


Meeting ended at 15:33:25 UTC (full logs).

Action items

  1. ejk will tune up failure analysis list to cover MAINTAINER file fails in commit logs, C and PEP8 checkstyle failures


People present (lines said)

  1. DaveBarach (35)
  2. collabot` (3)
  3. mackonstan (2)


Generated by MeetBot 0.1.4.