#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:01:12 UTC (full logs).

Meeting summary

  1. CSIT (Dave Wallace) (DaveBarach, 15:02:29)
    1. 19.08.1 report generation almost done (DaveBarach, 15:02:54)

  2. Host stack deferred (DaveBarach, 15:03:36)
  3. Docs (DaveBarach, 15:03:50)
    1. fd.io new site ALIVE!!! (DaveBarach, 15:03:57)
    2. Sphinx doc auto-update next on the list (DaveBarach, 15:04:57)
    3. it would be nice to update events page (DaveBarach, 15:08:48)
    4. have had a lot of doc-related Nexus issues (DaveBarach, 15:09:35)
    5. ACTION: Dave W / John / Andrew to look at tuning doxygen / sphinx build trigger(s) (DaveBarach, 15:10:20)

  4. aarch64 (DaveBarach, 15:14:49)
    1. cross-compilation patch is somewhat critical (DaveBarach, 15:15:11)
    2. suggested to ping damjan (DaveBarach, 15:15:18)

  5. Release mgmt (Dave W) (DaveBarach, 15:15:52)
    1. 19.08.1 released (DaveBarach, 15:15:58)
    2. https://packagecloud.io/fdio/deferred (dwallacelf, 15:17:35)
    3. cherrypick philosophy: take anything that's not an API change, after reasonable soak time (DaveBarach, 15:20:14)
    4. andrew uses tooling to pick patches to cherrypick, Dave W sanity-checks (DaveBarach, 15:20:55)
    5. 20.01 release plan (DaveBarach, 15:22:37)
    6. api freeze 1/7, +1 week cadence on milestones (DaveBarach, 15:22:53)
    7. release date on 1/28 (DaveBarach, 15:23:01)
    8. ACTION: dave w / andrew to send heads-up to mailing lists w/ 20.01 dates (DaveBarach, 15:23:57)
    9. discussion about meeting cadence - probably about right as-is (DaveBarach, 15:25:08)
    10. api change process seems to be working more-or-less as advertized (DaveBarach, 15:25:45)

  6. infra (Ed Kern) (DaveBarach, 15:27:10)
    1. discussion about deprecating Xenial (Ubuntu 16.04) (DaveBarach, 15:30:36)
    2. ACTION: Ed K to send email to multiple lists warning of Xenial deprecation (DaveBarach, 15:31:04)
    3. to reconvene in 2 weeks on 116.04 deprecation (DaveBarach, 15:31:21)
    4. "morning merges" cause the build queue to increase. Such is life (DaveBarach, 15:31:48)
    5. hope that converting to newer LF log mechanics will mitigate build timeouts (DaveBarach, 15:32:21)
    6. automated coverity nagger works, but emails currently aren't qorking (DaveBarach, 15:33:44)


Meeting ended at 15:38:17 UTC (full logs).

Action items

  1. Dave W / John / Andrew to look at tuning doxygen / sphinx build trigger(s)
  2. dave w / andrew to send heads-up to mailing lists w/ 20.01 dates
  3. Ed K to send email to multiple lists warning of Xenial deprecation


People present (lines said)

  1. DaveBarach (31)
  2. collabot` (3)
  3. dwallacelf (1)


Generated by MeetBot 0.1.4.