#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 16:04:45 UTC (full logs).

Meeting summary

  1. CSIT (Maciek) (DaveBarach, 16:04:59)
    1. move to Python 3.x completed (mackonstan, 16:05:16)
    2. VAT still used for fib scale tests and will be fixed in PAPI with Python3.x after CSIT-2001 (mackonstan, 16:06:47)
    3. removed stale test code: HoneyComb, NSH_SFC, DMM, TLDK (mackonstan, 16:07:10)
    4. some highlights of work done and in CSIT production (mackonstan, 16:07:23)
    5. added per packet latency measurements resolution using TRex plus HDRhistogram (mackonstan, 16:07:32)
    6. added IPv4 and IPv6 FIB scale tests with random flows (mackonstan, 16:07:59)
    7. added 100GE MLX5 NICs tests using suite generator so all tests are now supported, waiting for performance optimized rdma-core driver from Benoit, no pressure, to properly benchmark 100GE (mackonstan, 16:08:10)
    8. number of other items progressed towards closure and ship for CSIT-2001 release (mackonstan, 16:08:31)
    9. CSIT-2001 plan tracked on wiki, will be updated with the latest status before CSIT call tomorrow (mackonstan, 16:08:39)
    10. https://wiki.fd.io/view/CSIT/csit2001_plan (mackonstan, 16:08:47)
    11. tomorrow pulling CSIT-2001 branch from master, per rc1 milestone (aligned with VPP project timetable) (mackonstan, 16:08:56)

  2. release management (DaveBarach, 16:10:24)
    1. 20.01 on schedule, RC1 throttle pull tomorrow (DaveBarach, 16:10:42)
    2. 19.08.2 planned after 20.01 release (DaveBarach, 16:11:26)
    3. planning to put csit trending job in place (DaveBarach, 16:11:40)
    4. ACTION: remove 19.04 from agenda (DaveBarach, 16:12:02)
    5. one more update from CSIT (mackonstan, 16:16:58)
    6. Upgrade from from Ubuntu 18.04 LTS kernel 4.15.0-66 to Ubuntu 18.04 LTS kernel 4.15.0-72, introduced Xeon Processors’ ucode update increasing coverage to known (but not all announced) meltdown-spectre vulnerabilities (CSIT code is tracking those by executing spectre-meltdown-checker as part of the test suite). Skylake impact at 2-3%, Cascadelake impact at >30% ! (mackonstan, 16:17:32)
    7. Note that FEATURE.yaml files are published through fd.io, so please look at spelling, etc. (DaveBarach, 16:20:22)

  3. Host Stack (Florin) (DaveBarach, 16:23:26)
    1. TCP port reuse supported for connections in TIMEDWAIT state (DaveBarach, 16:24:03)
    2. a bunch of small fixes (DaveBarach, 16:24:27)
    3. Coming Soon: major refactor of shared-memory FIFOs. (DaveBarach, 16:24:51)
    4. will not ship in 20.01 (DaveBarach, 16:25:41)
    5. goal: to improve memory-scaling (DaveBarach, 16:27:23)

  4. Documentation (John D) (DaveBarach, 16:28:17)
    1. whitepaper page (DaveBarach, 16:28:24)


Meeting ended at 16:31:24 UTC (full logs).

Action items

  1. remove 19.04 from agenda


People present (lines said)

  1. DaveBarach (18)
  2. mackonstan (14)
  3. collabot` (3)


Generated by MeetBot 0.1.4.