#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:00:57 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 15:03:33)
    1. CSIT-2001 tests and report done, except Skylake. (mackonstan, 15:03:52)
    2. VPP v20.01 / CSIT-2001 Skylake NDR and PDR performance data to be published this week (mackonstan, 15:04:04)
    3. Poor NDR (zero drop) performance root caused to mgmt interface Linux en0 interrupts disturbing TRex operation on SuperMicro boards with Skylake processors. (mackonstan, 15:04:40)
    4. Was not happening before environment upgrades (BIOS, CPU ucode). (mackonstan, 15:04:55)
    5. Those same interrupts are not present on the same SuperMicro motherboards equipped with Cascadelake processors. (mackonstan, 15:05:04)
    6. In progress: Number of CSIT infrastructure and framework enhancements, gearing up to regular weekly NDR and PDR performance comparisons. (mackonstan, 15:05:58)
    7. CSIT in the cloud - added AWS c5n instances as another testbed topology, completed ip4 and ipsec performance dry run tests. (mackonstan, 15:08:05)
    8. Mellanox tests - we are in the process of calibrating the MLX5 setup on both TRex side and SUT/VPP side, so pls take the current trending results with a pinch of salt. (mackonstan, 15:08:49)

  2. host stack (Florin) (DaveBarach, 15:09:41)
    1. tcp supports connection scheduling, Improves high scale efficiency when sessions can't send (DaveBarach, 15:10:21)
    2. Same treatment applied to TLS (DaveBarach, 15:10:37)
    3. iperf + tls + ld_preload works (albeit not perfectly) one connectio > 12gb/sec (DaveBarach, 15:11:28)
    4. udp session pinning to workers, similar to TCP (DaveBarach, 15:12:02)
    5. no longer supporting udp-c (connected) sessions (DaveBarach, 15:12:33)
    6. vcl udp iperf test added to "make test" (DaveBarach, 15:12:54)
    7. iperf w/ 9K datagrams fills a 40g pipe (DaveBarach, 15:13:12)
    8. 1500 MTU -> fragmentation -> less than 20gbit (DaveBarach, 15:13:42)
    9. "spring cleaning" effort - tcp features moved to separate files (DaveBarach, 15:14:15)
    10. session api errors switched to session layer errors (DaveBarach, 15:14:32)
    11. binary APIs now deprecated, as promised two releases ago (DaveBarach, 15:14:56)
    12. all api messages use session queues, not binary api queues (DaveBarach, 15:15:12)

  3. Documentation (John, Ray) (DaveBarach, 15:17:42)
    1. multiple requests to add blog posts (DaveBarach, 15:18:17)
    2. adding csit / perf content, ask Maciek et al for review (DaveBarach, 15:18:18)

  4. Release Management (Andrew, Dave) (DaveBarach, 15:18:19)
    1. 20.05 about 4 weeks prior to api freeze (DaveBarach, 15:18:19)
    2. 20.01 planning 20.01.1 planned for after 19.08.X (DaveBarach, 15:18:20)
    3. thanks Dave! a few clarifications 1) we now support tcp descheduling 2) udp + fragmentation reaches less than 25Gbps (florinc, 15:18:40)

  5. infra status (Dave W) (DaveBarach, 15:20:49)
    1. an issue last Friday due to CentOS timestamp issue (DaveBarach, 15:21:11)
    2. no obvious reason, "went away by itself" (DaveBarach, 15:21:23)

  6. planning / hoping to add 2x features to 20.05 (Ray K) (DaveBarach, 15:27:43)
    1. async crypto / crypto-dev work (DaveBarach, 15:27:52)
    2. DDP (dynamic device personalization) to be added (DaveBarach, 15:28:22)
    3. ACTION: Damjan to take a look at async crypto when he can (DaveBarach, 15:29:04)
    4. DDP flow API to direct pkts to specific workers (DaveBarach, 15:29:55)
    5. adding L2tpv3, ipsec (DaveBarach, 15:30:06)
    6. direct specific ipsec tunnels to specific cores (DaveBarach, 15:30:24)
    7. direct specific l2tpv3 tunnels to specific cores (DaveBarach, 15:30:39)
    8. will be a work in progress for a while (DaveBarach, 15:31:07)
    9. involves dpdk feature backport to dpdkd 20.02 (DaveBarach, 15:31:58)
    10. dpdk blast radius only in AVF driver (DaveBarach, 15:33:18)
    11. misc improvements, multiarch support, classifer perf tunes (DaveBarach, 15:34:56)
    12. multiarch (damjan) 18.04 gnu assembler bug backport (DaveBarach, 15:35:54)
    13. avx512 causes cpu power management glitches (DaveBarach, 15:36:19)
    14. on Skylake, Cascade lake (DaveBarach, 15:37:04)


Meeting ended at 15:48:59 UTC (full logs).

Action items

  1. Damjan to take a look at async crypto when he can


People present (lines said)

  1. DaveBarach (40)
  2. mackonstan (8)
  3. collabot` (3)
  4. florinc (1)


Generated by MeetBot 0.1.4.