14:58:38 <DaveBarach> #startmeeting fd-io-vpp
14:58:38 <collab-meetbot> Meeting started Tue May 12 14:58:38 2020 UTC and is due to finish in 60 minutes.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:38 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:58:38 <collab-meetbot> The meeting name has been set to 'fd_io_vpp'
15:01:53 <DaveBarach> #topic Host Stack (Florin reporting)
15:02:24 <DaveBarach> #info bunch of fixes committed to host stack components
15:02:33 <DaveBarach> #info improved tracking of half-open sessions
15:02:48 <DaveBarach> #info tcp switched to cubic as the default congestion control algorithm
15:03:04 <DaveBarach> #info tcp improved tracking of half-open sessions
15:03:19 <DaveBarach> #info vcl improved handling of select vis a vis half-opened sessions
15:03:36 <DaveBarach> #info better select notifications when sessions encounter read/write errors
15:04:01 <DaveBarach> #info fixed svm fifo alignment issues thanks to the change to clang
15:05:24 <DaveBarach> #info udp now supports sending of multiple datagrams per dispatch cycle
15:05:37 <DaveBarach> #info improves quic performance
15:06:13 <DaveBarach> #topic CSIT (Maciek reporting)
15:06:51 <mackonstan> #info CSIT (Maciek et al) covering following topics per agenda
15:06:57 <mackonstan> #info 1. Spectre-Meltdown (S-M): "pandemic" recovery in CSIT
15:07:03 <mackonstan> #info 2. Xeon Skylake: updated CSIT-2001 report with S-M RCAs
15:07:10 <mackonstan> #info 3. Improved trending: daily MRR, weekly NDR/PDR, analytics
15:07:16 <mackonstan> #info announce email
15:07:22 <mackonstan> #link https://lists.fd.io/g/vpp-dev/message/16343
15:07:34 <mackonstan> #info slides for the meeting
15:07:39 <mackonstan> #link https://wiki.fd.io/view/Presentations
15:11:10 <mackonstan> #link https://docs.fd.io/csit/master/report/_static/vpp/performance-rca-2n-skx-2t1c-pdr.txt
15:20:26 <mackonstan> #link https://docs.fd.io/csit/rls2001/report/test_operational_data/vpp_performance_operational_data/index.html
15:22:21 <DaveBarach> #info Quick Q: status of failed SSD replacement activity?
15:25:05 <DaveBarach> #info note that folks have made zero progress on root-causing the SSD failures
15:26:09 <DaveBarach> #topic Documentation (John D)
15:26:34 <DaveBarach> #info 20.05 release note info pls send to john D
15:26:57 <DaveBarach> #topic Release Management (Andrew, Dave W )
15:27:28 <DaveBarach> #info 20.05 RC1 tag exercise tomorrow
15:27:55 <DaveBarach> #info please let andrew / dave know about patches which must be merged before RC1
15:28:31 <DaveBarach> #info Jerome asks about API changes from last release. Andrew will generate listing after RC1
15:29:35 <DaveBarach> #info Confirmed that we should not see any further (master/lates) API changes until release branch pulled
15:29:57 <DaveBarach> #info working on automatic cherry-pick scripts
15:30:45 <DaveBarach> #info O(200) cherry-picks needed for previous releases, maybe 70% can be automatically applied
15:31:59 <DaveBarach> #info 20.01 will have cherry-picks for the next month or so
15:32:19 <DaveBarach> #info will schedule 20.01.2 once the 20.05 release is published
15:32:39 <DaveBarach> #info 19.08 cherry pick catchup activity thereafter
15:33:58 <DaveBarach> #info 19.08 current LTS, 20.09 next LTS. May need some level of overlapping support
15:35:09 <DaveBarach> #topic Infra (Dave W, Andrew)
15:35:27 <DaveBarach> #info from last Thursday, verify jobs became erratic
15:35:40 <DaveBarach> #info something is killing jobs for no obvious reason
15:36:11 <DaveBarach> #info may be a job placement issue.
15:36:36 <DaveBarach> #info made Jenkins nomad plugin config changes
15:36:50 <DaveBarach> #info as of this AM, the Jenkins server seems to be misbehaving
15:37:24 <DaveBarach> #info we may have to do a Jenkins emergency shutdown and revert the last set of Jenkins updates
15:38:04 <DaveBarach> #info first "funny" thing noticed on May 2
15:40:49 <DaveBarach> #topic please let Dave W and Andrew know if there are patches which must make RC1
15:54:31 <DaveBarach> #info Benoit mentioned a vlib process stack overflow related to switching to clang-9
15:55:08 <DaveBarach> #agreed Fix that specific process, consider bumping default stack allocation to 64k from 32k if it becomes a widespread issue
15:55:45 <DaveBarach> #info the stack overflow was properly detected by running into the per-process guard page, so at least it wasn't horribly hard to work out what had happened
15:55:47 <DaveBarach> #endmeeting