#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:01:43 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 15:03:40)
    1. 20.01 skylake update should make it into report shortly (DaveBarach, 15:04:04)
    2. https://docs.fd.io/csit/rls2001/report/vpp_performance_tests/comparisons/current_vs_previous_release.html#n-skx (mackonstan, 15:04:06)
    3. csit 20.05 slow progress due to Vexxhost connectivity issues (DaveBarach, 15:04:35)
    4. tests restarted this morning (DaveBarach, 15:05:00)
    5. Vexxhost has apparently root-caused the problem (DaveBarach, 15:05:23)
    6. csit 20.05 report won't be issued this week (DaveBarach, 15:06:05)
    7. thanks to Dave W et al. for cranking up ping monitor (DaveBarach, 15:06:33)
    8. now have csit test which runs in Amazon EC2 et al. to benchmark vpp cloud workloads (DaveBarach, 15:07:25)
    9. testing NAT up to 60M sessions (DaveBarach, 15:07:44)

  2. Host Stack (Florin) (DaveBarach, 15:08:13)
    1. quiet over the last month (DaveBarach, 15:08:19)
    2. VCL removed udp-connected transport (DaveBarach, 15:08:31)
    3. can achieve same result w/ flags on normal sessions (DaveBarach, 15:08:50)
    4. simple implementation in LDP of sndmsg, recvmsg (DaveBarach, 15:09:01)
    5. fixed fcntl64 wrapper (DaveBarach, 15:09:15)
    6. TCP improved rtt estimation w/ SACKs (DaveBarach, 15:09:36)
    7. improved tracking of buffer allocations (DaveBarach, 15:09:49)
    8. fixed a sequence wrapping bug introduced by merged patch (DaveBarach, 15:10:20)
    9. fixed some clang-discovered issues (DaveBarach, 15:10:34)

  3. Documentation (John D) (DaveBarach, 15:11:07)
    1. 20.05 release note sent to Jerome, will send to vpp-dev (DaveBarach, 15:11:36)

  4. 20.05 release managment (DaveBarach, 15:13:05)
    1. 20.05 already a few fixes after release, need to add time to the release schedule next time (DaveBarach, 15:13:32)
    2. add a week between RC2 and formal release (DaveBarach, 15:13:58)
    3. AGREED: add 1 week between RC2 and formal release - everyone likes the idea (DaveBarach, 15:15:08)
    4. 20.01 per usual cadence, will continue to cherrypick due to customer demand (DaveBarach, 15:16:20)
    5. will limit all-inclusive cherrypicking to LTS releases moving forward (DaveBarach, 15:16:54)
    6. API compatibility (crc checking) during checkstyle to catch as early as possible (DaveBarach, 15:20:52)

  5. Infra Status (DaveBarach, 15:21:53)
    1. working to improve nomad cluster (DaveBarach, 15:22:06)
    2. many outages in the last month (DaveBarach, 15:22:17)
    3. Peter Mikus making all servers PXE / Ansible installed (DaveBarach, 15:22:56)
    4. to improve uniformity (DaveBarach, 15:23:04)
    5. revamping Nomad arch, where we're deploying servers / clients (DaveBarach, 15:23:27)
    6. spec for docker images now in CI repo (DaveBarach, 15:23:40)
    7. allows us to use Jenkins sandbox to test (DaveBarach, 15:23:59)
    8. Dave W weekly meeting w/ Vanessa, pls ping dave W unicast with LF issues (DaveBarach, 15:25:51)
    9. LF upgrading all of their infrastructure, which will give us better visibility into Jenkins machines (DaveBarach, 15:26:31)
    10. Jerome's link: https://medium.com/fd-io-vpp/getting-to-40g-encrypted-container-networking-with-calico-vpp-on-commodity-hardware-d7144e52659a (florinc, 15:40:38)

  6. VPP/Calico (Jerome T) (DaveBarach, 15:41:06)
    1. https://medium.com/fd-io-vpp/getting-to-40g-encrypted-container-networking-with-calico-vpp-on-commodity-hardware-d7144e52659a (DaveBarach, 15:41:35)
    2. vpp roughly 40x faster than Linux IPSec. 40gbit container-to-container encrypted comms (DaveBarach, 15:42:14)
    3. alpha-quality at the moment (DaveBarach, 15:43:05)


Meeting ended at 15:44:30 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. DaveBarach (44)
  2. collab-meetbot (3)
  3. mackonstan (1)
  4. florinc (1)


Generated by MeetBot 0.1.4.