15:59:36 <dmarion> #startmeeting fdio-vpp
15:59:36 <collab-meetbot> Meeting started Tue Feb  9 15:59:36 2021 UTC and is due to finish in 60 minutes.  The chair is dmarion. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:36 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:36 <collab-meetbot> The meeting name has been set to 'fdio_vpp'
16:00:25 <collab-meetbot> DaveBarach: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:03:46 <DaveBarach> #topic CSIT (Maciek reporting)
16:04:02 <mackonstan> #info csit-2101 rls status: most benchmark testing for report completed, no major issues
16:04:16 <mackonstan> #info draft version of csit-2101 report already online, incl. comparison tables to v20.09
16:04:22 <mackonstan> #link https://docs.fd.io/csit/master/report/
16:04:30 <mackonstan> #link https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-2n-clx-xxv710-2t1c-pdr.txt
16:04:47 <mackonstan> #info report publish target date 10-Feb, tomorrow, and we should be on time
16:04:58 <mackonstan> #info some more updates going into rls notes and other static content e.g. methodology sections
16:05:25 <mackonstan> #info After CSIT release is done, we will be moving to Ubuntu 20.04 as the main stack for benchmarking
16:06:01 <mackonstan> #info There is also quite some work on the infra side, putting backend monitors in place, so that we can detect any issues early, thanks to Dave and Peter
16:06:14 <mackonstan> #info Will come handy during the LFN/Vexxhost DC consolidation expected in end of Feb, Mar
16:07:19 <DaveBarach> #topic Host Stack (Florin reporting)
16:08:15 <DaveBarach> #info svm area, custom queue implementation non-blocking when possible
16:08:39 <DaveBarach> #info slight performance-at-scale improvement: 10% for NGINX tested w/ WRK
16:09:10 <DaveBarach> #info next step: security improvements, private message queues for multiple applications
16:10:01 <DaveBarach> #info DTLS patch, hard to test with iperf
16:10:47 <DaveBarach> #info slightly less performant than tls.
16:11:02 <DaveBarach> #info don't have support for retries w/ timeout
16:11:27 <DaveBarach> #info SRTP trying to add support. Test difficulties adding RTP payloads
16:11:35 <DaveBarach> #topic Documentation (Ole)
16:11:56 <DaveBarach> #info no updates beyond fixing links on the main website
16:13:54 <DaveBarach> #info Ray asks how we're planning to police doc / wiki bit-rot
16:14:29 <DaveBarach> #info wiki is really hard to keep straight, should invest in the docset
16:14:54 <DaveBarach> #topic Release Managment (Andrew, DaveW)
16:15:02 <DaveBarach> #info 21.01 shipped on schedule
16:15:21 <DaveBarach> #info RC1 / RC2 timing worked out pretty well
16:16:00 <DaveBarach> #info some last-minute churn, probably need to be more strict about avoiding churn post-RC2 for 21.06
16:16:49 <DaveBarach> #info data center move; unless someone insists on point releases, let's wait
16:18:41 <DaveBarach> #info folks interested in Centos7 need to figure out where to go since Red Hat is moving away from Centos
16:19:41 <DaveBarach> #info DaveW: Centos7 is too old to add to our CI
16:20:58 <DaveBarach> #info Damjan: really need a list of package dependencies, vs. distro versions
16:21:53 <DaveBarach> #info same issue occurred with Debian9 vs Debian-10
16:22:29 <DaveBarach> #action DaveW and Andrew to investigate making minimum version listing
16:22:43 <DaveBarach> #info discuss again next time
16:23:06 <DaveBarach> #topic Infra / Auto Abandon (Dave W)
16:23:39 <DaveBarach> #info infra breakages over the last month, dealt with, ping DaveW directly with ongoing infra issues
16:24:09 <DaveBarach> #info auto-abandon proposal / RFC. We have 600+ patches in the gerrit queue
16:24:24 <DaveBarach> #info costs cycles to have the queue that large
16:24:47 <DaveBarach> #info auto-abandon would address that aspect of the problem
16:26:19 <DaveBarach> #info Seems like most folks happy to enable auto-abandon, except for Paul V, Ole
16:26:52 <DaveBarach> #info of the outstanding patches, 477 are waiting for author actions (address comments, rebase, etc.)
16:26:58 <DaveBarach> #info 42 awaiting review
16:27:53 <DaveBarach> #info doing a reasonable review job
16:36:48 <DaveBarach> #action send out list of patches to clean up
16:39:13 <DaveBarach> #action Dave W to see if converting patches to work-in-progress will fix the problem
16:39:55 <DaveBarach> #topic Multicore make-test (Andrew)
16:40:36 <DaveBarach> #info interesting exercise to run tests w/ 2 workers
16:41:04 <DaveBarach> #info patch to run this way by environment variable pushed
16:41:58 <DaveBarach> #info another patch in the works which tags tests which don't work multicore
16:42:25 <DaveBarach> #info one reason: tests which assume only one set of counters, blow up due to split counts
16:46:00 <DaveBarach> #info shout-out to Dave W for CI failure cause enhancements
16:46:45 <DaveBarach> #topic ARM SVE discussion
16:46:59 <DaveBarach> #info aarch64 scalable vector enhancements
16:47:25 <DaveBarach> #info discuss changes in vpp to support / use these instruction-set changes
16:49:53 <DaveBarach> #info instrs are vector-length agnostic
16:53:36 <DaveBarach> #info coding style involves looping
16:55:55 <DaveBarach> #info topic really needs a full hour
16:58:18 <DaveBarach> #action meet tomorrow same time slot to continue
16:58:31 <DaveBarach> #endmeeting
16:58:46 <dmarion> #endmeeting