14:58:04 <DaveBarach> #startmeeting fdio-vpp
14:58:04 <collab-meetbot> Meeting started Tue Jun  8 14:58:04 2021 UTC and is due to finish in 60 minutes.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:04 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:58:04 <collab-meetbot> The meeting name has been set to 'fdio_vpp'
14:58:18 <DaveBarach> #chair dmarion
14:58:18 <collab-meetbot> Warning: Nick not in channel: dmarion
14:58:18 <collab-meetbot> Current chairs: DaveBarach dmarion
15:03:01 <DaveBarach> #topic Agenda Additions?
15:03:26 <DaveBarach> #topic CSIT (Vratko reporting)
15:03:43 <DaveBarach> #info finishing prep work for 21.06
15:03:58 <DaveBarach> #info still some issues, e.g. w/ memif tests
15:04:14 <DaveBarach> #info Damjan aware of one issue, will look into it
15:04:55 <DaveBarach> #info some minor issues with fixes in pipeline
15:05:12 <DaveBarach> #info occasional failures (1 in 100) without any clear pattern
15:06:17 <DaveBarach> #info one annoying scenario: PAPI unresponsive, vpp not crashing hence no core file
15:07:32 <DaveBarach> #info DaveW and Florin got one corefile from iperf + LDP
15:09:01 <DaveBarach> #info suspect binary API mmap address conflict with iperf process
15:11:20 <DaveBarach> #info changed number of RX queues - one queue per worker. Needed to increase number of mbufs
15:13:26 <DaveBarach> #topic Host Stack (Florin)
15:13:51 <DaveBarach> #info close to release, doing cleanup/bugfixes
15:14:19 <DaveBarach> #info session layer polling on main thread to improve active-open performance
15:14:45 <DaveBarach> #info don't keep polling indefinitely
15:14:57 <DaveBarach> #info better tracking of half-open sessions
15:15:12 <DaveBarach> #info quic needs a bit of work to clean up half-open sessions
15:15:47 <DaveBarach> #info fixed and arm-specific memory ordering issue. Specific to our CI infra: ThunderX2
15:16:21 <DaveBarach> #info affected tests: iperf cut-throughy
15:16:41 <DaveBarach> #info vcl cut-through performance improvements, e.g. with libev
15:17:17 <DaveBarach> #info TLS, DTLS memory pressure hardening
15:17:42 <DaveBarach> #topic Documentation
15:17:55 <DaveBarach> #info dave W did some doc cleanups
15:18:13 <DaveBarach> #info struggling to put together a cleanup plan
15:18:29 <DaveBarach> #info need to move docs to readthedocs (Nexus retirement)
15:19:11 <DaveBarach> #topic Release Managment (Andrew, DaveW)
15:19:44 <DaveBarach> #info new requirement to do 21.01.1, to generate artifacts
15:19:50 <DaveBarach> #info to update csit report
15:20:16 <DaveBarach> #info As people cherry-pick for 21.06, consider also cherry-picking for 21.01.1
15:21:09 <DaveBarach> #info please get cherry-picks in... Now...
15:22:00 <DaveBarach> #info RC2 next Weds, no need to hold for memif fix...
15:25:03 <DaveBarach> #topic Infra Status (DaveW)
15:25:17 <DaveBarach> #info lots of work / improvements
15:25:41 <DaveBarach> #info vexxhost data center move: thanks to Peter Mikus / Barret @ vexxhost
15:25:54 <DaveBarach> #info no outages at all..!
15:26:19 <DaveBarach> #info all of the hosts now run Ubuntu 20.04
15:26:53 <DaveBarach> #info plan in 21.06 to retire old hardware (Haswell)
15:27:21 <DaveBarach> #info addressed "glt clone" / related failures
15:27:44 <DaveBarach> #info simplified the communications between components.
15:28:03 <DaveBarach> #info git clone failures reduced to O(3/week), removed Naginator (again)
15:28:45 <DaveBarach> #info additional change after 21.06: move ingress / Jenkins openstack instances from old data center to new data center
15:29:30 <DaveBarach> #info series of CI job failures not related to patch, e.g. vcl vpp cut-through tests
15:30:12 <DaveBarach> #info root cause of i40e issues: using old drivers...
15:31:07 <DaveBarach> #info chasing a couple of patch-unrelated issues w/ stats segment
15:31:46 <DaveBarach> #info continuing to work on using Amazon S3 logging to reduce costs
15:32:35 <DaveBarach> #info damjan: kudos to the team for huge improvements in CI infra stability
15:33:16 <DaveBarach> #info continuing to update docker images to eliminate repeated package downloads
15:33:37 <DaveBarach> #info using ccache to improve build times
15:34:02 <DaveBarach> #info Centos-8 is very old, propose to remove jobs from CI from master
15:35:05 <DaveBarach> #info unless someone steps up to fix RPM builds, lets remove them. No support on the horizon from Red Hat. CentOS 8 is EOL at the end of the year, etc.
15:35:55 <DaveBarach> #info Matt Smith: Netgate currently uses CentOS-8, in the process of switching to Ubuntu
15:36:47 <DaveBarach> #info dwallace: no need to remove build infra, but the verify jobs need to go
15:38:23 <DaveBarach> #action Matt Smith to discuss removal w/ colleagues
15:38:54 <DaveBarach> #info Matt to advise by email
15:41:11 <DaveBarach> #info async crypto w/ worker threads seems to be completely broken
15:41:52 <DaveBarach> #info patches coming soon. Fan is the right person to work with.
15:42:47 <DaveBarach> #endmeeting