13:03:13 <gwu> #startmeeting Integration Weekly
13:03:13 <collabot`> Meeting started Wed Jun 26 13:03:13 2019 UTC.  The chair is gwu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:13 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:03:13 <collabot`> The meeting name has been set to 'integration_weekly'
13:04:12 <gwu> #info thanks to everyone for hard work and dedication; integration is done with Dublin release
13:04:24 <gwu> #info expect TSC to approve the release tomorrow
13:06:01 <gwu> #info s3p test results were good; most issues were environmental stability
13:06:55 <gwu> #info will request TSC to add more resources to the wind river lab: more RAM and CPUs
13:07:20 <gwu> #topic any remaining dublin issues
13:08:39 <gwu> #info issues with SDNC UEB listener on oom master branch
13:11:36 <gwu> #topic wiki page on CI testing
13:11:51 <gwu> #info 3 follow up items from last week:
13:12:06 <gwu> #info Brian has a video on testing
13:12:31 <gwu> #info Morgan release notes or wiki on the CI testing chain
13:12:59 <morgan_orange> #info Yang already well referenced the postman collection, it is enough for the release
13:13:05 <gwu> #info CI/CD "don't break the build" priority for El Alto
13:13:26 <gwu> #topic lab capacity planning
13:14:00 <morgan_orange> #info some rules are needed to garantee resources for integration team (and avoid being stuck few days before the release)
13:15:05 <morgan_orange> #info a cap shall be defined per project (50 Go? too small...) to motivate using shared resources when possible..
13:15:12 <gwu> #info proposed 50 GB RAM limit per project tenant; teams to share ONAP instances where full ONAP is required
13:18:46 <gwu> #info afenner: maybe there could be a way to tell if an ONAP instance is still being used, so we don't have unused ONAP instances taking up space
13:22:23 <gwu> #info wind river currently has about 5 TB of RAM, each instance of ONAP takes about 250 GB of RAM
13:26:32 <gwu> #info morgan: ONAP at 250 GB seems to take too much RAM for the functionality it provides; maybe TSC can consider this as well
13:30:04 <gwu> #info are all ONAP components required?  we should identify exact list of components required for each use case
13:30:45 <gwu> #info ONAP CPU usage is also something to review; ONAP idle CPU consumption is too high; some pods are at 100% CPU all the time
13:31:43 <morgan_orange> #info Brian started to establish a link between the tests / use cases and pods. There are more than 250 pods and 61 robot healthcheck + use cases. It seems that some pods are simply not used.
13:32:20 <morgan_orange> #action yang create a story to follow-up on real resource usage in ONAP and see if it can be reduced
13:37:33 <morgan_orange> #info cost for Orange Lab RAM upgrade: 36K$ for 52x32 Go (Dell and Huawei)
13:43:34 <morgan_orange> #info probably one of the main issue: people start VMs and just forget to clean them
13:43:59 <morgan_orange> #info better visibility and garbarge collector mechanism could be useful
13:44:55 <gwu> #topic El Alto priorities
13:52:33 <gwu> #info the variety of CI systems for ONAP is hard for newbies to understand
13:54:19 <morgan_orange> #info Jim Baker sharing El Alto roadmap
13:54:24 <morgan_orange> #link https://wiki.onap.org/display/DW/Release+Planning
13:54:26 <gwu> #info Jim reminds us of Aug 12 early drop (full component release) date for El Alto
13:56:50 <morgan_orange> #info Lasse has a question on jenkins job for CIST
13:57:25 <morgan_orange> #info who is responsible for the jenkins sandbox? see question on rocketchat
14:00:13 <gwu> #info new LF ticketing system at support.linuxfoundation.org
14:04:15 <gwu> #endmeeting