13:06:23 <morgan_orange> #startmeeting integration weekly meeting 10/07/2019
13:06:23 <collabot`> Meeting started Wed Jul 10 13:06:23 2019 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:06:23 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:06:23 <collabot`> The meeting name has been set to 'integration_weekly_meeting_10_07_2019'
13:06:28 <morgan_orange> #topic participants
13:06:35 <morgan_orange> #info Yang
13:06:37 <morgan_orange> #info Brian
13:06:41 <morgan_orange> #info Daniel Rose
13:06:46 <morgan_orange> #info Gary
13:06:51 <morgan_orange> #info joey Zhou
13:07:08 <morgan_orange> #info Kezystof Kuzmicki
13:07:13 <morgan_orange> #info Lei Shi
13:07:16 <morgan_orange> #info Marco
13:07:22 <morgan_orange> #info Paul Ionu Vaduva
13:07:30 <morgan_orange> #topic Quick update
13:08:12 <morgan_orange> #info release officially announced
13:08:27 <morgan_orange> #info still some issues tracked in the daily "war room" meeting
13:09:02 <morgan_orange> #info different behavior detected on Orange lab (Dublin daily chain)
13:09:23 <morgan_orange> #info probelm at startup components are waiting other components, it seems that there are some race conditions
13:11:28 <morgan_orange> #info investigation on installation shall be done, helm charts shall be reviewed and components shall manage more properly their dependency
13:13:04 <morgan_orange> #info orchestration at installation is needed - timers are not enough
13:16:52 <morgan_orange> #info helm is maybe not enough for the the job
13:17:02 <morgan_orange> #topic El Alto integration tasks
13:17:22 <morgan_orange> #info priority 1 don't break the build (sanity daily run)
13:18:24 <morgan_orange> #info extending gating to component
13:23:01 <morgan_orange> #info risk reported to TSC and PTL ..everybody agree during DDF, no decisions taken so far
13:23:39 <morgan_orange> #info discussions on the gating on SO
13:24:23 <morgan_orange> #info Brian suggest we could give a try on one tenant of the windriver lab. SO shall be deployed on an ONAP using fixed versions for the other components
13:24:49 <morgan_orange> #info a subset of the components is needed (not all the modules)
13:27:52 <morgan_orange> #action Yang evaluate SO gating in windriver lab
13:28:30 <morgan_orange> #action morgan_orange xcheck with Sylvain on creating a chain for SO to windriver lab
13:29:35 <morgan_orange> #info SB00 installed with latest Dublin
13:31:42 <morgan_orange> #info last run of Dublin on Orange lab => healthcheck almost all OK but impossible to onboard/instantiate, investigation in progress
13:32:02 <morgan_orange> #info ONAP deployment with smaller footprint
13:32:25 <morgan_orange> #info Bell Canada tried to divide by 2 the resource usages => aciton on OOM team
13:33:04 <morgan_orange> #info on windriver lab, Yang suggest to setup quotas to avoid resources starvation few eeks before the release as already experienced
13:33:56 <morgan_orange> #info Yang suggests also to deploy a sharable ONAP to save resources
13:37:44 <morgan_orange> #info several projects could use shared components e.g. 1 AAF for N tenants
13:39:07 <morgan_orange> #info lab improvement => question raised to TSC - 50 K to upgrade lab capabilities
13:39:34 <morgan_orange> #info lab is already under constraints (no more Memory slot / free ports on switches,..)
13:40:06 <morgan_orange> #info ~ 3 servers + 1 switch should be compatible with the budget
13:40:32 <morgan_orange> #info other option would be to use another lab
13:41:12 <morgan_orange> #info Marco indicates that an upgrade of the lab could be a temp victory as, it is constantly growing, we risk to reach new resources frontiers in 2 or 3 releases
13:44:20 <morgan_orange> #info morgan_orange mentions that some resources had been purchased by LF for OPNFV - they had to support 5 Openstack installers in //, there are only 1 or 2 and muche less projects. It should be possible to recover resources if they are not used
13:50:47 <morgan_orange> #info Marco shares ecomp experience. system was smaller and simpler.
13:51:40 <morgan_orange> #info help deploy everything in the same namespace => could multi namespaces avoid that a component change breaks the whole cluster
13:52:46 <morgan_orange> #info other El Alto topic testsuite code improvement, CSIT code improvement, Use case Automation, Performance benchmark ...  to be discussed offline
13:53:37 <morgan_orange> #topic Integration lab resource (put quota on tenants after we can provide  shared infrastructure for project teams to test module deployment)
13:53:44 <morgan_orange> #info discussed in the previous section
13:54:04 <morgan_orange> #topic Benchmark planninBenchmark planning for EI Alto (China Telecom)
13:54:27 <morgan_orange> #info China Telecom performed performance tests on Beijing
13:55:10 <morgan_orange> #info Brian and integration team provided support
13:55:33 <morgan_orange> #info suggestion to move to Dublin
13:59:50 <morgan_orange> #info they use the vFW use case to assess performance
14:00:22 <morgan_orange> #action Lei Shi create a wiki page for performance tests (referenced from integration page)
14:00:43 <morgan_orange> #topic AoB
14:03:34 <morgan_orange> #info OOM stagging branch => no more manifest
14:04:48 <morgan_orange> #info tooling: https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk idea is to replace https://gitlab.com/Orange-OpenSource/lfn/onap/onap-tests
14:05:39 <morgan_orange> #endmeeting