13:01:31 <morgan_orange> #startmeeting integration weekly meeting 6/11/2019
13:01:31 <collabot> Meeting started Wed Nov  6 13:01:31 2019 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:31 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:31 <collabot> The meeting name has been set to 'integration_weekly_meeting_6_11_2019'
13:04:26 <morgan_orange> #topic Action points follow-up from previous meeting
13:04:35 <morgan_orange> #info AP1: morgan_orange verify SO version on daily El Alto
13:04:45 <morgan_orange> #info answer sent, it was still 1.5.2, Introduction of 1.5.3 lead to a regression in SO tests, see elatlo discussion
13:05:23 <morgan_orange> #info AP2: morgan_orange christophe consider A&AI gating for frankfurt
13:05:45 <morgan_orange> #info first exchange with Sylvain, need to put Christophe in the loop and get a better idea of the A&AI docker build process
13:06:59 <morgan_orange> #info AP3: all review the page on category
13:07:11 <morgan_orange> #info see discussion on category and test priorization for automation
13:07:21 <morgan_orange> #info AP4: morgan_orange share the gating slide deck by mail and consolidate the list of dockers / tests
13:07:42 <morgan_orange> #info done, slide deck in the wiki + wiki page created to get feedback
13:07:58 <morgan_orange> #topic Admin
13:17:00 <morgan_orange> #info Frankfurt Admin JIRA managed
13:17:07 <morgan_orange> #link https://wiki.onap.org/display/DW/Frankfurt+Milestone+Status
13:17:11 <morgan_orange> #info everything is done
13:17:19 <morgan_orange> #info committer cleaning done, maybe time to start promoting committers now
13:20:39 <morgan_orange> #info request to get new repo pending - more than 1 week
13:20:46 <morgan_orange> #info discussion on repositories to host use case code
13:22:46 <morgan_orange> #info marco reports concerns due to LF , very slow
13:23:31 <morgan_orange> #info oparent update
13:24:19 <morgan_orange> #action Brian sync with Pam to finalize oparent / policy team (test)
13:25:08 <morgan_orange> #info regarding small repo => morgan suggests we give a try with a volunteer project => evaluate the overhead / manage 2 systems
13:25:26 <morgan_orange> #topic El Alto status
13:25:34 <morgan_orange> #info bug SO: #link https://jira.onap.org/browse/OOM-2163
13:26:18 <morgan_orange> #info Brian created a patch to adapt the robot test to the SO regression (http/https entry point declaration)
13:27:32 <morgan_orange> #info bug NBI: no patch seen so far (also a Http/https issue)
13:27:50 <morgan_orange> #action Morgan get status
13:28:21 <morgan_orange> #topic Frankfurt
13:29:06 <morgan_orange> #info demo Monitoring and resource optimization with kube-eagle
13:31:16 <morgan_orange> #info Sylvain is showing grafana dashboard using kube eagle. The goal was to have a deep look at the real consumption of resources and compare with the declarative limits & requests
13:31:51 <morgan_orange> #link https://github.com/cloudworkz/kube-eagle
13:32:12 <morgan_orange> #info connected to the prometheus installaed to monitor the ONAP solution
13:33:01 <morgan_orange> #info on our openlab CPU (8%) and RAM (32%)  usage is very low compared to what is requested
13:33:21 <morgan_orange> #info we are using 14 CPU (request 88)
13:35:33 <morgan_orange> #info question from Brian: does it represent installation of idle state => we have both, we can see the consumtion during installation (see some CPU pikes: 1 at the very beginning but not after)
13:36:42 <morgan_orange> #info request should be the average usage, limit the "reasonable" max
13:44:41 <morgan_orange> #info discussion Andrew/brian => could make sense to create a helm chart for this tooling
13:45:44 <morgan_orange> #info sylvain insists on the fact that we should keep external tool => nothing specific
13:48:31 <morgan_orange> #info category review
13:48:35 <morgan_orange> #link https://wiki.onap.org/pages/viewpage.action?pageId=71835330
13:52:11 <morgan_orange> #info OSJI team is doing security related tests
13:56:01 <morgan_orange> #info CSIT follow-up
13:56:06 <morgan_orange> #link https://jenkins.onap.org/view/CSIT/
13:56:14 <morgan_orange> #info jenkins page has been updated to exclude verify jjb
13:56:19 <morgan_orange> #info deadline indicated to PTL during PTL meeting + by mail. Clean-up of the CSIT tests planned beginning of December => grey jjb will be cleaned if no objection
13:57:38 <morgan_orange> #info new use cases for Frankfurt
13:57:49 <morgan_orange> #info 5G SON, a meeting is planned on the 8th of November 2 PM UTC
13:57:56 <morgan_orange> #link https://zoom.us/j/225581627
13:58:08 <morgan_orange> #info other use cases known?
13:58:45 <morgan_orange> #info are all the El Alto reference use case automatically included for Frankfurt?
13:59:02 <morgan_orange> #info for El Alto, copy/paste Dublin list, clean a little bit
14:00:15 <morgan_orange> #info use case automation priorization, as it will not possible to automate everything, wich use cases are the easiest ones to start
14:00:19 <morgan_orange> #info unformal discussion with brian on ete-k8s-sh robot tags
14:00:22 <morgan_orange> #info lots of tags
14:00:28 <morgan_orange> #info best candidates:  health, core, small, medium, healthdist (already the case) + ete, pnf_registrate, stability72h,instantiateVFWCL, cds, HVVES
14:00:54 <morgan_orange> #info some timeout issue in Selenium processing => same preload data, VNF and GR API can be used, seems to work fine
14:01:11 <morgan_orange> #info to be checked with vCPE (not using VID)
14:01:38 <morgan_orange> #info at the moment we have to wait a lottle (camunda cleaning)
14:01:46 <morgan_orange> #topic Lab status
14:02:48 <morgan_orange> #info new results pushed from DT labs
14:03:39 <morgan_orange> #info refactory of Daily master/staging in windriver lab to be refactored
14:04:59 <morgan_orange> #topic AoB
14:05:26 <morgan_orange> #action morgan_orange sync with Dan for the python3 migration status, what is missing => we coudl already remove the python2.7 target of python-test-utils
14:05:28 <morgan_orange> #endmeeting