14:05:30 <morgan_orange> #startmeeting Integration weekly meeting 20/11/2019
14:05:30 <collabot> Meeting started Wed Nov 20 14:05:30 2019 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:30 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:05:30 <collabot> The meeting name has been set to 'integration_weekly_meeting_20_11_2019'
14:06:23 <morgan_orange> #topic action point follow-up
14:06:32 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/onap-int/2019/onap-int.2019-11-13-14.00.html
14:06:36 <morgan_orange> #info AP1: morgan_orange brian create a list to submit to the committers
14:06:41 <morgan_orange> #info first list done and shared with existing committer (see admin section)
14:06:46 <morgan_orange> #info AP2: all review ElAlto retro page
14:06:51 <morgan_orange> #link https://wiki.onap.org/display/DW/El-Alto+Retrospective
14:06:56 <morgan_orange> #info Brian and myself did, do not hesitate to review especially all the aspects dealing with integration/tests
14:07:33 <morgan_orange> #info AP3 morgan_orange brian lukasz prepare a slide deck for PTL meeting to ask for healthcheck better quality with better coverage
14:07:47 <morgan_orange> #info topic mentioned in the el alto retrospective. A column has also be added in pari wise follow-up page https://wiki.onap.org/display/DW/0%3A+Integration+Weather+Board+for+Frankfurt+Release (healthcheck rating)
14:08:58 <morgan_orange> #info AP4: morgan_orange create a stable daily in windriver
14:09:07 <morgan_orange> #info windriver lab network issues since yesterday (gitlab-runner created but no more joinable) but additionnal work needed (see next section on lab)
14:09:16 <morgan_orange> #info AP5: all: complete etherpad to prepare Prague
14:09:23 <morgan_orange> #link https://etherpad.opnfv.org/p/onap_integration_prague
14:09:30 <morgan_orange> #info action point still open
14:09:41 <morgan_orange> #info AP6: morgan reinstall daily CI time series adapter to visualize test evolution = f(time)
14:09:50 <morgan_orange> #info work started, ingress point added on azure cloud hosting the conversion pod but still some issues (traffic not properly routed to the target pod)
14:10:16 <morgan_orange> #topic admin
14:10:22 <morgan_orange> #info Lab status
14:10:33 <morgan_orange> #info windriver lab critical issues. OpenStack compute-03 is in error state. It hosted more than 30 VMs from different projects. These VMs have not been properly evacuated. Impossible to join the VM on 10.12.6.*
14:12:29 <morgan_orange> #info Jira raised Yesteday. Stephen was able to restart some of the components (access to Horizon)
14:12:58 <morgan_orange> #info but several if not all ONAP platform may be impacted by the hardware probelm on compute-03.
14:13:05 <morgan_orange> #info tickets have been raised on Intel Ops dealing with this DC
14:13:31 <morgan_orange> #info a move was also planned beginning of January
14:15:13 <morgan_orange> #info Ericsson lab no update
14:16:05 <morgan_orange> #info Orange: Daily chains (El Alto and Master) pretty stable since 1 week
14:16:37 <morgan_orange> #info E2E deployements are OK but longer (~ +5' per use case) due to modification in onap-tests python framework to manage multicloud. A patch has been submitted to configure this part
14:17:20 <morgan_orange> #info if issues continue on windriver, possible to grant access to the daily master if needed (but it is a daily...so it is reinstalled every day, the tests must be automated)
14:18:41 <morgan_orange> #info committer promotion
14:18:51 <morgan_orange> #info as mentioned in previous meeting, a new campaign for integration committer promotion started
14:19:54 <morgan_orange> #info first list is based on contributions to use cases: Bartek Grzybowski (vCPE) and E.Multanen (HPA vFW/vDNS), quorum of existing committers voted +1 for both
14:19:59 <morgan_orange> #action morgan report committer vote to the TSC and update INFO.yaml
14:20:45 <morgan_orange> #info El Alto retrospective
14:23:34 <morgan_orange> #link https://wiki.onap.org/display/DW/El-Alto+Retrospective
14:24:16 <morgan_orange> #info RAN simulator repository (for 5G SON use case) created
14:24:24 <morgan_orange> #link https://git.onap.org/integration/simulators/ran/simulator/tree
14:25:02 <morgan_orange> #info CSIT mail notification finalized
14:25:08 <morgan_orange> #info CSIT cleanning still planned beginning of Decemeber
14:25:15 <morgan_orange> #info new script to build robot docker locally
14:26:23 <morgan_orange> #topic El Alto Status
14:26:33 <morgan_orange> #info (src Brian) still pending issue in 1.7.6 SDNC DG’s. Final package left a bad version reference in the DG so the version loaded is not set as Active by default.
14:27:00 <morgan_orange> #info (src Brian) Need to change the version tag in the dg to ${project.version} or something instead of the hard coded 201904xx . Got missed in making the final container build and not seen till the last step of vCPE flow.c
14:29:54 <morgan_orange> #info SDNC-961 partly tested but does not fix everything
14:30:08 <morgan_orange> #info Frankfurt
14:30:43 <morgan_orange> #info oparent
14:30:51 <morgan_orange> #info (src Brian) oparent 3.0.0 not release yet (check with projects / Amy)
14:32:09 <morgan_orange> #info 2 tests already tested the new version, looking for a new team for testing
14:32:20 <morgan_orange> #info first results with oparent30.0.-snapshot OK
14:32:34 <morgan_orange> #info Policy and NBI has used this snapshot version => Ok
14:32:55 <morgan_orange> #info CI chains
14:32:59 <morgan_orange> #info Daily Master pretty stable (E2E tests run and OK)
14:33:49 <morgan_orange> #info AAI pod issue stil opened, JIRA assignement changed to AAI PTL + priority from low to high
14:33:57 <morgan_orange> #link https://jira.onap.org/browse/AAI-2707?filter=-2
14:34:51 <morgan_orange> #action morgan_orange see last dmaap errors on daily Master and create a Jira if needed
14:35:37 <morgan_orange> #info tests
14:35:46 <morgan_orange> #info (src Brian) GRA-API for generic VNFs seems to be working
14:35:51 <morgan_orange> #info (src Brian) GRA-API for infrastructe vCPE is complete.
14:36:10 <morgan_orange> #info (src Brian) - Waiting for tunnel-xcon DG’s to be modified by SDNC team to get vGMUX data from GRA-API instead of VNF-API side
14:36:33 <morgan_orange> #info (src Brian) - SO is planning to modify their customer vCPE serfvice workflow to be building block based so that will be a regression work load for Frankfurt. A good change but de-stabilizing
14:37:24 <morgan_orange> #info still remaining work to be automated on vCPE => use its own lab (not impacted by windriver issue)
14:38:23 <morgan_orange> #info (src Brian) Trying to understand ONAP – O-RAN-SC A1 and O1 interface work in Frankfurt.
14:42:25 <morgan_orange> #info xtestingization of the test in progress: dockers are available (infra-health (k8s, helm), health (core, small, medium, health, healthdist, postinstall, sdc-sdnc-d), smoke-usecases-pythonsdk (basic_vm, freeradius_nbi, clearwater_vims), smoke-usecases-robot (pnf_registrate, ...)
14:42:40 <morgan_orange> #info WIP on pnf_registrate
14:44:41 <morgan_orange> #info smoke-usecases-robot full python3
14:45:09 <morgan_orange> #action morgan migrate healthcheck in python3...
14:45:10 <morgan_orange> #info Python3 migration
14:55:34 <morgan_orange> #info robot RWO/RWX: today we use RWX => not cloud ready
14:55:51 <morgan_orange> #info if we keep our archi, we could easily move RWX => RWO
14:58:29 <morgan_orange> #if we want to split web server / robot processing (will become a job)
15:02:00 <morgan_orange> #info discussions to build base image => could be done by integration
15:03:45 <morgan_orange> #info question how to convince team to use referenced images...
15:04:31 <morgan_orange> #info OSJI: testing scripts about to be submitted
15:07:20 <morgan_orange> #action Krystof send a mail of OSJI vulnerabilities
15:10:08 <morgan_orange> #actino morgan_orange send info on integration-xtesting to Krystof to see how to integrate some security tests on Daily chains
15:10:11 <morgan_orange> #undo
15:10:11 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x22a4090>
15:10:19 <morgan_orange> #action morgan_orange send info on integration-xtesting to Krystof to see how to integrate some security tests on Daily chains
15:10:29 <morgan_orange> #endmeeting