14:27:03 <morgan_orange> #startmeeting Integration weekly meeting 02/09/2020
14:27:03 <collab-meetbot> Meeting started Wed Sep  2 14:27:03 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:27:03 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:27:03 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_02_09_2020'
14:27:12 <morgan_orange> #topic action point follow-up
14:27:30 <morgan_orange> #link https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/integration_weekly_meeting_26_08_2020/onap-int-integration_weekly_meeting_26_08_2020.2020-08-27-08.34.html
14:27:39 <morgan_orange> #info AP1: morgan_orange redo some tests then conctact Intel/Windriver lab team to report results and see how to proceed to improve
14:27:48 <morgan_orange> #info done see next topic
14:27:56 <morgan_orange> #info AP2: morgan_orange send mail to use case onwers + PTL to report infra test status
14:28:31 <morgan_orange> #info status shared with PTL, answers also provided to release management and to some test suite owners
14:28:41 <morgan_orange> #info AP3 pawel morgan_orange move all the waiver/xfail lists in integration/seccom + adapt the Dockerfile accordingly
14:28:42 <morgan_orange> #info done
14:28:52 <morgan_orange> #info AP4 Thierry andreas find the best way to cover both options
14:28:55 <morgan_orange> #info in progress
14:29:03 <morgan_orange> #info AP5 andreas create a JIRA on SO/AAI data change problem in master
14:29:43 <morgan_orange> #info a jira has been created for OOF issue but not yet for SO/AAI (wait for confirmation but regression on master last night (oom/AAI patch reverted)
14:29:47 <morgan_orange> #topic admin
14:30:14 <morgan_orange> #info Infrastructure Audit performed on Intel/Windriver lab levering OPNFV functest benchmark tools
14:30:19 <morgan_orange> #info results are not good
14:30:50 <morgan_orange> #info one big compute was in down state (but enabled), RAM capability of some compute is above 98%,
14:31:22 <morgan_orange> #info VMTP tests showed bad results with compute 5 and no results with compute 9 (98,7 RAM consumption)
14:31:35 <morgan_orange> #info the overall RAM consumption is above 75%
14:31:55 <morgan_orange> #info several compute services are done (controler 0 + compute 20 and 21)
14:32:19 <morgan_orange> #info some errors reported by shaker mentioned VIF issues which seem to indicate that there are some undelays issues
14:32:34 <morgan_orange> #info mail shared with lab owner + integration committer + release management
14:32:56 <morgan_orange> #info currently it is impossible to guarantee some support for pair wise testing and use cases
14:34:17 <morgan_orange> #info possible options: 1) fix Intel/windriver issues 2) extend Azure to deploy instances for ONAP users 3) ask for community members to offers computing resources 4) get Vexhost capabilities (used by LF)
14:34:28 <morgan_orange> #info high risk on the release reported to release management
14:34:43 <morgan_orange> #info support requested to Intel/Windriver team but no feedback so far
14:35:30 <morgan_orange> #info new repo follow-up: we are up to date the 3 last new repos have been created, still some issues of sync ldap/committers
14:35:47 <morgan_orange> #info open question on Bell CDS team on any visibility to get the CDS tests
14:36:08 <morgan_orange> #action Mike Eliott provide some date on the contribution in testsuite/cds repo
14:36:26 <morgan_orange> #info Santosh is participating to Integration meeting and involved in CDS testing
14:36:34 <morgan_orange> #info committer review
14:36:41 <morgan_orange> #link https://git.onap.org/integration/tree/INFO.yaml
14:37:03 <morgan_orange> #info several committers are no more active, the critical mass of committers is decreasing, which can be a problem
14:37:31 <morgan_orange> #action morgan_orange contact recent inactive committers to get their plans
14:37:50 <morgan_orange> #action all think to 2 or 3 new committers to replace inactive committers
14:38:23 <morgan_orange> #info backend moved from Orange azure to LF IT backend end
14:38:52 <morgan_orange> all the results can be found in https://logs.onap.org/onap-integration/daily/ or https://logs.onap.org/onap-integration/gating
14:39:01 <morgan_orange> #info all the results can be found in https://logs.onap.org/onap-integration/daily/ or https://logs.onap.org/onap-integration/gating
14:39:24 <morgan_orange> #action morgan create a LF IT ticket to clean first attempts on onap-integration
14:40:00 <morgan_orange> #action morgan send a mail to notify the new location of the daily and gating results and optionnaly configure a redirection from the previous place
14:41:23 <morgan_orange> #info gating extension
14:41:36 <morgan_orange> #info DCAE would be interested => possible in H version but requires resources
14:41:45 <morgan_orange> #info Clamp included in Guilin
14:41:55 <morgan_orange> #info coudl be interested to get feedback from clamp team
14:42:05 <morgan_orange> #action morgan ask some feedback on clamp gating to clamp team
14:42:56 <morgan_orange> #info discussion with Pratik: wait for answer, Integration project would like to know the motivation of the patches (that got -1 in linting) any optimization must not degrade the quality imposed by the linters
14:43:03 <morgan_orange> #topic Guilin
14:43:09 <morgan_orange> #info status on daily master
14:43:22 <morgan_orange> #info regression on OOM/AAI detected leading to a revert
14:43:34 <morgan_orange> #link https://gerrit.onap.org/r/c/aai/oom/+/111997
14:44:13 <morgan_orange> #info K mentions that a very big patch in in progress to improve the kubernetes version, this has impact
14:44:44 <morgan_orange> #info SO &AAI issue also reported by K, seems similar to what ANdreas reported - to be retested and confirmed
14:45:03 <morgan_orange> #info K also reported an issue with VID/AAI => not detected a priori on DT and Orange Frnakfurt chain
14:45:07 <morgan_orange> #info K shall recheck
14:45:27 <morgan_orange> #info still Frankfurt SO version in Master (blocking point found by OOM)
14:45:36 <morgan_orange> #info also no news on an update for ccsdk
14:45:53 <morgan_orange> #info still no regular "small" version, water falling system still in action
14:46:34 <morgan_orange> #action morgan_orange retrieve master versions, compare with frankfurt and ask the PTL during the PTL meeting on their options (M4=code freeze supposed to be mid of September..)
14:47:05 <morgan_orange> #info CI chain evolution
14:47:25 <morgan_orange> #info morgan indicates the current daily/gating chain and proposed the evolution for Guilin
14:47:35 <morgan_orange> #action morgan shared the evolution on onap-discuss and wait for feedback
14:47:49 <morgan_orange> #action all give feedback on CI evolution for Guilin
14:48:00 <morgan_orange> #info K asks whether a test on CMPv2 has to be planned
14:48:35 <morgan_orange> #info any new feature shall come with test..in theory so CMPv2 should provide a way to test it (possible with  pnf registrate but test is complex..)
14:49:03 <morgan_orange> #info andreas indicates that he was able to onboard/instanciate the vFW with SO macroflow/CDS
14:50:09 <morgan_orange> #info he asks CDS team if they could work on HTTPS support otherwise manual steps are needed
14:50:11 <morgan_orange> #link https://jira.onap.org/browse/CCSDK-2665?jql=reporter%20%3D%20andreasgeissler%20AND%20resolution%20%3D%20Unresolved%20ORDER%20BY%20priority%20DESC%2C%20updated%20DESC
14:50:40 <morgan_orange> #info Jira open since several versions but still not finalized
14:51:51 <morgan_orange> #info vCPE update merged => to be tested
14:51:59 <morgan_orange> #info nodeport cert check under integration
14:52:13 <morgan_orange> #info versions under CI integration, weekly chain needed (for longer tests)
14:52:37 <morgan_orange> #info refactoring on master chains daily from monday to saturday, weekly on sunday with longer tests
14:52:46 <morgan_orange> #topic AoB
14:53:22 <morgan_orange> #info quiestion from Biswajit on the robot testuite refactoring delaing with the AAF flag to be supported by SO
14:53:43 <morgan_orange> #info morgan indicates that a refactoring of the robot pod was planned but not a full rewritting of the existing robot tests
14:54:27 <morgan_orange> #action bisjwajit initiate a thread offline integration / So / AAF flag / robot tests
14:54:29 <morgan_orange> #endmeeting