15:50:18 <morgan_orange> #startmeeting Integration weekly meeting 05/08/2020
15:50:18 <collab-meetbot> Meeting started Wed Aug  5 15:50:18 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:50:18 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:50:18 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_05_08_2020'
15:51:28 <morgan_orange> #topic Action point follow-up
15:52:15 <morgan_orange> #info AP1 Kryszstof evaluate the possibility to create non regression test on k8s plugin
15:52:32 <morgan_orange> #info Jack Lucas had bunch of blueprints for k8s plugin tests but - manual approach ...
15:53:14 <morgan_orange> #info would make sense to automate such regression tests (requires k8s tests) and include in weekly/daily
15:53:57 <morgan_orange> #action kryzstof start a mail thread to evaluate the load/difficulty
15:54:12 <morgan_orange> #topic Admin
15:54:16 <morgan_orange> #info Windriver lab
15:54:23 <morgan_orange> #info SB-00 reinstalled yesterday
15:54:36 <morgan_orange> #info SB-00 and daily run => issue with clamp due to maria
15:55:16 <morgan_orange> #info
15:55:25 <morgan_orange> #info  error: database is uninitialized and password option is not specified    You need to specify one of MYSQL_ROOT_PASSWORD, MYSQL_ALLOW_EMPTY_PASSWORD and MYSQL_RANDOM_ROOT_PASSWORD
15:55:32 <morgan_orange> #info this error seems specific to windriver
15:56:24 <morgan_orange> #info comparison windriver / orange env => seems that the windriver kubernetes server version is too old 1.5.3 (expected 1.5.11), no big difference detected otherwise
15:56:40 <morgan_orange> #action morgan_orange update teh version and give a new try
15:57:23 <morgan_orange> #undo
15:57:23 <collab-meetbot> Removing item from minutes: #action morgan_orange update teh version and give a new try
15:58:11 <morgan_orange> #action morgan_orange update the k8s version to 1.5.11 on windriver (patch needed in master/frankfurt)  and give a new try..
15:58:26 <morgan_orange> #info presentation how to reinstall SB-00
15:58:47 <morgan_orange> #info all the integration committers have the procedure (login/password needed to launch the jenkins job)
15:59:17 <morgan_orange> #info WIP to reuse the CI chains sued for gating and orange dailys => advantage it is maintained by OOM => no risk of version mis alignement
16:00:27 <morgan_orange> #info this ci chain is based on gitlab-ci (runner installed in windriver lab), troubleshooting in progress
16:00:45 <morgan_orange> #topic Status on ElAlto and Frankfurt Maintenance release
16:01:48 <morgan_orange> #info Orange dailys not running between 1/08 => 04/08 due to hardware issue (disk) , VM were in RAM, but no more disk was seen from the physical server hosting VM hosting k8s nodes
16:02:11 <morgan_orange> #info server power down, new daily today
16:02:25 <morgan_orange> #link https://gating-results.onap.eu/results/onap_daily_pod4_frankfurt-671281880-08-05-2020_01-08/
16:02:52 <morgan_orange> #info frankfurt good results => confirm the GO for maintenance release given by OOM (the clamp issue on windriver is not reproducible)
16:03:05 <morgan_orange> #link https://gating-results.onap.eu/results/onap_daily_pod4_elalto-671454952/
16:03:36 <morgan_orange> #info El Alto, results are not significative - as tests docker are frankfurt
16:04:21 <morgan_orange> #info only frankfurt dockers available on ONAP Nexus 3 (chain introduced in frankfurt and history not transfered from gitlab.com)
16:04:52 <morgan_orange> #info a solution would consist in pushing gitlab.com elalto dockers to the nexus but it is not allowed - LF policy imposed that the artifacts are built on LF servers
16:05:19 <morgan_orange> #info ugly workaround may be possible IF < frankfurt use gitlab.com docker else use ONAP dockers..
16:05:32 <morgan_orange> #info it is still possible to run the test manually
16:06:00 <morgan_orange> #info regarding the onap-k8s results (cluster status), results are not so bad, OOF issue reported and tracked in JIRA
16:06:08 <morgan_orange> #undo
16:06:08 <collab-meetbot> Removing item from minutes: #info regarding the onap-k8s results (cluster status), results are not so bad, OOF issue reported and tracked in JIRA
16:06:36 <morgan_orange> #info regarding the onap-k8s results (cluster status), results are not so bad - issues tracked in JIRA
16:07:07 <morgan_orange> #link https://jira.onap.org/browse/SDNC-1308
16:07:12 <morgan_orange> #link https://jira.onap.org/browse/SDNC-1309
16:07:52 <morgan_orange> #issue on SO adaptor sent to SO team
16:08:12 <morgan_orange> #info issue on SO adaptor sent to SO team
16:08:25 <morgan_orange> #info SDC issue reported to SDC team
16:08:49 <morgan_orange> #topic python SDK
16:09:41 <morgan_orange> #info new features introduced - CDS onboarding almost ready, CLAMP
16:10:03 <morgan_orange> #info scenario => first patch introduced by Amine including clamp and the beginning of closed loop scenario
16:10:22 <morgan_orange> #info the patch includes the structure and the work specific to clamp
16:10:55 <morgan_orange> #action morgan_orange split Amine patch into 2 patches: structure (Thierry proposal) / clamp (Amine)
16:11:11 <morgan_orange> #topic CDS tests
16:11:49 <morgan_orange> #info Bell CDS tests are more functional tests than integration tests => they can be run independently from ONAP, they require Mock obecjts + a kafka server (dmaap not used)
16:13:01 <morgan_orange> #info possible to create a dedicated repository - not even if the repository is in ONAP, it does not means that the CI will require jenkins dev. Lots of tests are in ONAp but run through gitlab-ci. So it dependsq on what is needed (docker build for the mock object?)
16:13:30 <morgan_orange> #info Andreas indicates that the CDS test with python-sdk requires today manual operation tyo expose the blueprint-processor-http
16:13:48 <morgan_orange> #info work in progress to move to HTTPS (Yurik + marek) to avoid this manual step
16:14:21 <morgan_orange> #info Bell tests = Bash scripts running set of request to mocked CDS
16:14:40 <morgan_orange> #action Sebastien : provide code + procedure to give a first try ...
16:16:17 <morgan_orange> #action Trevor: tell if OK with a dedicated repository. As it is functional testing, it is usually hosted in the project...cds/cds/tests (under Dan responsibility) testuise/cds (under integration responsability)
16:16:28 <morgan_orange> #undo
16:16:28 <collab-meetbot> Removing item from minutes: #action Trevor: tell if OK with a dedicated repository. As it is functional testing, it is usually hosted in the project...cds/cds/tests (under Dan responsibility) testuise/cds (under integration responsability)
16:16:39 <morgan_orange> #action Trevor: tell if OK with a dedicated repository. As it is functional testing, it is usually hosted in the project...cds/cds/tests (under Dan responsibility)
16:17:02 <morgan_orange> #info other possibility  testsuite/cds (under integration responsability)
16:17:15 <morgan_orange> #topic AoB
16:17:39 <morgan_orange> #info question from Kuldeep: Test API availability
16:17:50 <morgan_orange> #action Kuldeep initiate a mail thread
16:18:17 <morgan_orange> #info question from Kuldeep on OOF error on his Frankfurt deployment => suggest to run onap-k8s to get more logs
16:18:34 <morgan_orange> #action morgan_orange send a mail with the procedure to run onap-k8s tests on any ONAP solution
16:18:56 <morgan_orange> #info question from nagindar on how to include new healthcheck tests
16:19:05 <morgan_orange> #info som Q&A are available on the main integration page
16:19:20 <morgan_orange> #link https://wiki.onap.org/display/DW/Integration+Project
16:21:09 <morgan_orange> #info tests can be done directly in the robot pod....(change inside the robot script, then run using the right tag from the controller) then to be run in xtesting (and in CI) a new image shall be built and referenced in the k8s job
16:21:41 <morgan_orange> #action morgan_orange send the windriver CI SB-00 jenkins script to Sandeep
16:21:45 <morgan_orange> #endmeeting