16:28:18 <morgan_orange> #startmeeting Integration weekly meeting 08/07/2020
16:28:18 <collab-meetbot`> Meeting started Wed Jul  8 16:28:18 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:28:18 <collab-meetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:28:18 <collab-meetbot`> The meeting name has been set to 'integration_weekly_meeting_08_07_2020'
16:28:26 <morgan_orange> #topic action point follow up
16:28:38 <morgan_orange> #info AP1: morgan_orange krzysztof integrate preonboarding  use case in CI Master
16:29:24 <morgan_orange> #info not done yet, Krzysztof in PTO, I will be in PTO next weeks. But Still in mind...test prerequisite closed to hv-ves
16:29:46 <morgan_orange> #info AP2 & AP8 morgan_orange Pawel W confirm we can swich from http endpoint to nonsslendpoint use case
16:30:33 <morgan_orange> #info Pawel confirms, filtering feature to be completed,. nonsslendpoint will be the reference test
16:30:43 <morgan_orange> #info AP3: morgan_orange ask Yuriy to get notified when patches are all in (needed  for closed loop stuff out of the box) to self release testsuite 1.6.4
16:30:51 <morgan_orange> #info done, 1.6.4 created yesterday
16:31:02 <morgan_orange> #info AP4 morgan_orange intiate a wiki page to track the status of Robot rests  (runnable from inside/outside) and get the reason cause when it is not  runnable from outside
16:31:04 <morgan_orange> #info done
16:31:12 <morgan_orange> #link https://wiki.onap.org/display/DW/Robot+Pod+Refactoring
16:31:35 <morgan_orange> #info AP5: morgan_orange give a try to CDS test for next week
16:32:34 <morgan_orange> #info done, several prerequisites needed (user creation, maria db patch, curl to internal CDS)
16:32:44 <morgan_orange> #link https://wiki.onap.org/pages/viewpage.action?pageId=71838892
16:32:51 <morgan_orange> #link https://wiki.onap.org/pages/viewpage.action?pageId=71838945#E2ERunTime-655515897
16:33:53 <morgan_orange> #info CDS test still FAIL , test redo with testsuite 1.6.4 (new test to be done on fresh installation, not sure replay on error is possible)
16:34:09 <morgan_orange> #info AP6 morgan_orange contact SECCOM to see if we can reset the xfail list now or if we should wait a milestone
16:34:15 <morgan_orange> #info done,
16:34:28 <morgan_orange> #action morgan_orange reset xfail list of security tests
16:34:51 <morgan_orange> #info AP8  morgan_orange integrate the cert test in CI
16:34:59 <morgan_orange> #info work in progress
16:35:08 <morgan_orange> #topic Admin
16:35:19 <morgan_orange> #info Windriver cleaning step 1 done
16:35:32 <morgan_orange> #link https://wiki.onap.org/pages/viewpage.action?pageId=6593670&preview=/6593670/84657430/windriver_status_after_cleaning_campaign.pdf
16:36:11 <morgan_orange> #info in short saving CPU 15%, RAM 19% Disk 8%, nb of projects 128 > 43
16:36:44 <morgan_orange> #info still possible to clean additional resources (projects and Integration)
16:37:12 <morgan_orange> #info no feedback received from some projects but projects kept for the moment
16:37:35 <morgan_orange> #info release daily reconfigure to use frankfurt by default
16:38:00 <morgan_orange> #info replacement of 1 node planned on Intel/Winder lab https://jira.opnfv.org/browse/INFRA-443 (no place left on the switch but possibility to replace an existing compute node with a better one)
16:38:17 <morgan_orange> #info integration/seccom shall be available => 1 file with recommended versions
16:38:43 <morgan_orange> #info baseline images: FAQ on python3 to see how to use the image
16:38:58 <morgan_orange> #action morgan_orange create FAQ on how to use the python baseline image
16:39:27 <morgan_orange> #info discussion with Amy (SECCOM) on the need to build more images  (debian|ubuntu|centos|alpine + java11|python3)
16:40:19 <morgan_orange> #info wait for TSC discussion regrading the license topic. The less base image we have, the easiest to maintain/check CVE (e.g. with Harbor)
16:40:30 <morgan_orange> #info June CI logs saved on Nexus
16:40:46 <morgan_orange> #link https://logs.onap.org/onap-integration/
16:41:16 <morgan_orange> #info summer time organization => need to find somebody to manage integration weekly meetings
16:41:34 <morgan_orange> #action morgan_orange find committer to manage the meeting
16:41:59 <morgan_orange> #topic stable branches
16:42:46 <morgan_orange> #info frankfurt status: onap-aaf-cert-service error => internal cert expired
16:43:06 <morgan_orange> #info few consequences as this feature is not used by lots of use cases
16:43:39 <morgan_orange> #info for the maintenance release, some certificates (detected on nodeports) are expired or about to expired
16:44:07 <morgan_orange> #action morgan_orange send a mail to ptl/release to ask what is the plan for the expired cert or the too long cert for the maintenance release
16:44:40 <morgan_orange> #action morgan_orange update the release note for the frankfurt maintenance release (1.6.4)
16:45:03 <morgan_orange> #info maintenance release for El Alto
16:45:37 <morgan_orange> #info diffuclties to reset El Alto CI chain, OOM is investigating. Needed to check the last patch (mainly certificates update)
16:46:18 <morgan_orange> #topic Guilin
16:47:12 <morgan_orange> #info new page on robot tests. few can be run from outside the cluster as they call internal ports.
16:47:40 <morgan_orange> #info sometimes it is normal/logical as some components are not exposed
16:47:56 <morgan_orange> #info but sometimes it is just a shortcut to simplify the tests
16:48:18 <morgan_orange> #info test done on nodeport, could be redone on ingress but it should be the same results..
16:48:47 <morgan_orange> #info shall we create a special tag for the use case runnable from outside the cluster? enduser?
16:49:58 <morgan_orange> #info question from Krzysztof, no End to End test => there are at least 3 tests (basic_vm, freeradius_nbi, clearwater_ims) leveraging onap-test framework
16:50:22 <morgan_orange> #info this framework will be deprecated in Guilin and replaced by scenario leveraging python_onapsdk
16:50:31 <morgan_orange> #info presentation of the status on the scenarios
16:50:49 <morgan_orange> #action thierry push prototype to ONAp repository
16:51:14 <morgan_orange> #info it shall be easy to switch from nodeport to ingress thanks to the config
16:51:48 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk/-/blob/develop/src/onapsdk/configuration/global_settings.py
16:52:08 <morgan_orange> #action morgan_orange create a global setting for ingress configuration
16:52:24 <morgan_orange> #info the goal is to replace the existing E2E tests by new scenarios
16:52:35 <morgan_orange> #info Thierry presents the prototype
16:52:45 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/lfn/onap/pythonsdk-tests/-/blob/master/run_e2e.py
16:53:00 <morgan_orange> #info basic _vm can be replaced by this file (20 lines)
16:53:17 <morgan_orange> #info service is based on a yaml file
16:53:40 <morgan_orange> #info additional tests expected: basic_network, basic_cnf, ...
16:53:49 <morgan_orange> #info scenarios to be integrated during summer
16:54:16 <morgan_orange> #info discussion on REQ-399
16:54:25 <morgan_orange> #link https://jira.onap.org/browse/REQ-399
16:54:34 <morgan_orange> #info statement from Andreas
16:55:32 <morgan_orange> #info Mandatory GUI-Tests have to be provided to verify:
16:55:42 <morgan_orange> #info - Standalone GUI startup without failures
16:55:51 <morgan_orange> #info - User Login (if applicable)
16:56:04 <morgan_orange> #info - GUI startup within Portal (if applicable)  - For each user role
16:56:10 <morgan_orange> #info Addon Tests
16:56:17 <morgan_orange> #info Page functionality (e.g. dialog, search,…)
16:56:36 <morgan_orange> #undo
16:56:36 <collab-meetbot`> Removing item from minutes: #info Page functionality (e.g. dialog, search,…)
16:56:39 <morgan_orange> #info - Complete GUI workflow execution
16:56:51 <morgan_orange> #info - Page functionality (e.g. dialog, search,…)
16:56:59 <morgan_orange> #info - GUI accessibility test
16:57:10 <morgan_orange> #info - Internationalization
16:57:20 <morgan_orange> #info The tests have to run without any user interaction and have to be integratable into the Integration CI chains.
16:57:30 <morgan_orange> #info Existing frameworks (e.g. robot testsuite) include the Selenium test framework and might be an option to be used.
16:57:44 <morgan_orange> #info Ashish working on SDC
16:57:54 <morgan_orange> #info a test had been initiated on SDC
16:59:00 <morgan_orange> #link https://git.onap.org/testsuite/tree/robot/testsuites/portalApp.robot
16:59:09 <morgan_orange> #info but lots of tests not maintained
16:59:29 <morgan_orange> #info right place to commit is testsuite repo
16:59:48 <morgan_orange> #topic AoB
16:59:53 <morgan_orange> #endmeeting