14:29:32 <morgan_orange> #startmeeting Integration weekly meeting 16/09/2020
14:29:32 <collab-meetbot> Meeting started Wed Sep 16 14:29:32 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:32 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:32 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_16_09_2020'
14:29:40 <morgan_orange> #topic action point follow up
14:29:52 <morgan_orange> #info AP1 morgan_orange initiate committer promotion (xcheck with them first then initiate the procedure)
14:30:11 <morgan_orange> #info AP2 morgan_orange contact new committers and initiate the procedure
14:30:30 <morgan_orange> #info AP1 and AP2 done, candidates OK, survey sent to existing committers
14:30:51 <morgan_orange> #info results of the survey 3 candidates got a majority of Yes
14:31:02 <morgan_orange> #action morgan_orange finalize official procedure for new committers
14:31:10 <morgan_orange> #info Krysztof create a jira to track cloudify/DCAE bootstrap race condition issue
14:31:13 <morgan_orange> #info no update
14:31:21 <morgan_orange> #infp AP4 morgan_orange initiate Jira to the projects for the different tests
14:31:32 <morgan_orange> #info done see Guilin Section
14:31:40 <morgan_orange> #info AP5 morgan_orange create bunch of JIRAs
14:32:02 <morgan_orange> #info JIRAs created, available on Integration Guilin Page or Release management page
14:32:07 <morgan_orange> #topic admin
14:32:29 <morgan_orange> #info no news from windriver (neither lab, windriver TSC member, TSC,..)
14:32:48 <morgan_orange> #info Action item taken 10 days ago in TSC, but no feedback during last TSC
14:33:07 <morgan_orange> #info Kenny took the action in PTL to escalade
14:33:19 <morgan_orange> #info new committers, process on track
14:33:34 <morgan_orange> #info repo: last repo available 5g-core-ns
14:33:41 <morgan_orange> #info first commit in terraform seen
14:33:46 <morgan_orange> #info no update on cds repo
14:33:53 <morgan_orange> #topic Guilin
14:34:13 <morgan_orange> #info CI status: Master unbroken by a revert
14:34:26 <morgan_orange> #info issue was on SDNC with a mix of 2 entry points
14:34:39 <morgan_orange> #info since sdnrb is disabled it is possible to onboard/instantiate
14:34:57 <morgan_orange> #info good thing is that we are able to properly revert (more than 2 weeks)
14:35:21 <morgan_orange> #info hope we will detect earlier next time - we detected it but not reported it strongly enough to OOM..
14:35:38 <morgan_orange> #link https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/09-13-2020_06-09/
14:35:45 <morgan_orange> #info new weekly master (every sunday)
14:35:53 <morgan_orange> #info include versions test -python/java)
14:36:12 <morgan_orange> #info issue last time, but manual run was OK and used to trigger a bunch of Jiras
14:36:33 <morgan_orange> #link https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-16-2020_06-09/
14:36:44 <morgan_orange> #info last daily master: small/medium HC have been removed
14:36:51 <morgan_orange> #info new version of onap-helm
14:37:03 <morgan_orange> #link https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-16-2020_06-09/infrastructure-healthcheck/k8s/onap-helm/helm.html
14:37:27 <morgan_orange> #info nodeport certificate test also integrated
14:37:32 <morgan_orange> https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-16-2020_06-09/infrastructure-healthcheck/k8s/nodeport_check_certs/certificates.html
14:37:35 <morgan_orange> #link https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-16-2020_06-09/infrastructure-healthcheck/k8s/nodeport_check_certs/certificates.html
14:37:49 <morgan_orange> #info jiras also created for certificate issues
14:38:01 <morgan_orange> #info onap-tests basic_vm is back
14:38:24 <morgan_orange> #info blocking points (integration + security) summarized in https://wiki.onap.org/display/DW/Guilin+Integration+blocking+points
14:38:31 <morgan_orange> #info Release management created also a table
15:18:14 <morgan_orange> #link https://wiki.onap.org/display/DW/Correlation+of+Guilin+Issues+to+Release+Requirements+and+Component+Commitments
15:18:29 <morgan_orange> #info demo pythonsdk-tests
15:18:53 <morgan_orange> #info pythonsdk-tests is a little abstraction framework leveraging onapsdk
15:19:02 <morgan_orange> #inof pythonsdk-tests is hotsted in ONAp repo
15:19:08 <morgan_orange> #info onapsdk in gitlab
15:19:16 <morgan_orange> #info a pypi repo is available
15:19:28 <morgan_orange> #link https://pypi.org/project/onapsdk/
15:19:41 <morgan_orange> #info a version 1.0.0 had been created in August
15:19:51 <morgan_orange> a 7.0.0 (to follow ONAP release naming) is planned
15:20:00 <morgan_orange> #info a 7.0.0 (to follow ONAP release naming) is planned
15:20:16 <morgan_orange> #info the code is currently in freeze mode to be able to publish a 7.0.0 next week
15:20:33 <morgan_orange> #info pythonsdk-tests is using the develop branch for the moment, the idea is to use the 7.0.0
15:20:44 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk
15:20:56 <morgan_orange> #link https://git.onap.org/testsuite/pythonsdk-tests/tree/
15:21:07 <morgan_orange> #info a dshbaord for the migration onap-tests to pythonsdk-tests has been created
15:21:32 <morgan_orange> #link https://wiki.onap.org/display/DW/Onap_tests+to+pythonsdk-tests+migration
15:22:10 <morgan_orange> #info illustration provided to explain the way pythonsd-test is structure ~ matroyshka mode with lot of heritage corresponding to steps
15:22:20 <morgan_orange> #info demo done with a simple Vm and a clearwater IMS
15:24:50 <morgan_orange> #info discussion with Amy on the table proposed by release management
15:24:54 <morgan_orange> #info first waivers granted
15:25:19 <morgan_orange> #action morgan_orange pawel update security tests to include the waivers alredy given (seem mail from Krysztof) e.g. all the filebeats
15:25:56 <morgan_orange> #info lots of projects asked for waivers...the goal is not to hide the problems but find a way to address them...
15:26:09 <morgan_orange> #info the question of maintenance project has been raised during PTL meeting..
15:26:18 <morgan_orange> #info and shall be addressed by TSC
15:26:47 <morgan_orange> #info recommendation, ,non mandatory components under maintenance must be excluded from the deployment and documented for a manual installation
15:27:05 <morgan_orange> #info unfortunately some maintenance components are needed (e.g. AAF)
15:28:53 <morgan_orange> #info stability test: morgan_orange shared the 3 weeks monitoring view of the Orange Openlab (Frankfurt maintenance release SR1) - community lab with manual operation + daily instantiation of 3 VNFs - RAM is increasing continuously over the 3 weeks. cassandra is consuming lots of resources, we can see some cleaning but globally it is increasing. The requirement on stability tests and metrics has been postponed (no resource) but we will
15:28:53 <morgan_orange> keep on monitoring and initiate some tests for Honolulu.
15:29:09 <morgan_orange> #topic AoB
15:30:25 <morgan_orange> #info Amy indicates that too many pods (including our robot) are based on full distros and including lots of useless components. Typically the python 2.7 interpreter is present but not used in many cases. It is probably not the only component offering a broader surface of attack...tracked by the Jira but few resources to address them.
15:30:28 <morgan_orange> #endmeeting