14:43:05 <morgan_orange> #startmeeting Integration weekly meeting 16/12/2020
14:43:05 <collab-meetbot> Meeting started Wed Dec 16 14:43:05 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:43:05 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:43:05 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_16_12_2020'
14:43:13 <morgan_orange> #topic action point follow-up
14:43:34 <morgan_orange> #link https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/integration_weekly_meeting_9_12_2020/onap-int-integration_weekly_meeting_9_12_2020.2020-12-09-14.26.html
14:43:48 <morgan_orange> #info AP1 morgan alexander contact Jessica to see if it would be possible to add the script when building the dockers
14:44:12 <morgan_orange> #info mail thread initiated, PoC on vagrant to be done first then see how to insert the test within the build chain
14:44:24 <morgan_orange> #info AP2 morgan_orange create a page to list possible new tests => team will vote for the priorities...
14:44:26 <morgan_orange> #info done
14:44:54 <morgan_orange> #link https://wiki.onap.org/display/DW/Honolulu+Integration+Test+priorities
14:45:51 <morgan_orange> #info AP3 morgan_orange contact China mobile to see the status of the test
14:45:58 <morgan_orange> #info done, comments added in JIRA
14:48:43 <morgan_orange> #link https://jira.onap.org/browse/INT-1356
14:49:00 <morgan_orange> #info AP4 morgan_orange Krzysztof fix build chain
14:49:03 <morgan_orange> #info not done yet
14:49:13 <morgan_orange> #info 1.7.3 expected for guilin maintenance release...
14:49:20 <morgan_orange> #action  morgan_orange Krzysztof fix build chain
14:49:25 <morgan_orange> #undo
14:49:25 <collab-meetbot> Removing item from minutes: #action morgan_orange Krzysztof fix build chain
14:49:35 <morgan_orange> : #action  morgan_orange Krzysztof fix testsuite build chain
14:49:56 <morgan_orange> #info AP5 morgan_orange create a ticket to track the fact that the duration=f(t) seems to increase in average
14:49:59 <morgan_orange> #info done
14:50:23 <morgan_orange> #link https://jira.onap.org/browse/SO-3419?filter=-2
14:51:12 <morgan_orange> #topic demo
14:51:17 <morgan_orange> #info demo of basic_cds
14:51:32 <morgan_orange> #info shall be available in master daily CI ..still minor config issue to be fixed...
14:51:40 <morgan_orange> #action morgan_orange have a look at xtesting_onap configuration
14:51:46 <morgan_orange> #info demo OK done on daily master
14:51:58 <morgan_orange> #info |     basic_cds     |     integration     |      00:16       |      PASS      |
14:52:16 <morgan_orange> #info it verifies the possibility to contact the CDS (open nodeport) + enrich CBA
14:52:26 <morgan_orange> #info it is part of healthcheck as it deals onlys with CDS
14:52:46 <morgan_orange> #info the rule => 1 component = healthcheck, multiple components = smoke
14:52:54 <morgan_orange> #info video available soon..
14:53:00 <morgan_orange> #info demo basic_clamp
14:53:07 <morgan_orange> #info viedo also available soon...
14:54:55 <morgan_orange> #info test creates a VF in SDC, includes  a TCA blueprint in the service, certifies the services, distributes the services, wait for distribution. Then contact Clamp (using old certificate based method), then check the policies, creates a loops and deploys the loop in Policy Engine and triggers the creation of a pod through DCAE
14:55:01 <morgan_orange> #info demo was OK
14:55:16 <morgan_orange> #info still in patch, several fixes needed before going to CI
14:55:49 <morgan_orange> #info settings refactoring => workaround needed as pythonsdk-test and onap-sdk path shall be in python path, copy of the onapsdk config file done in pythonsdk-tests
14:56:16 <morgan_orange> #info functional test shall be amended (currently failing in python-onapsdk) ..some difficulties to re run it on local env
14:56:41 <morgan_orange> #info the option to use the basic auth shall be also implemented in python-onapsdk (better that the certificate based authentication to clamp)
14:56:51 <morgan_orange> #topic Honolulu
14:57:10 <morgan_orange> #info simu wrapper proposal presented by Eli
14:57:21 <morgan_orange> #link https://wiki.onap.org/display/DW/Pythonsdk-test+wrapper+for+simulators
14:57:27 <morgan_orange> #agreed
14:57:55 <morgan_orange> #info discussion on stability test evolution
14:57:58 <morgan_orange> #link https://wiki.onap.org/display/DW/Honolulu+stability+test+evolution
14:58:14 <morgan_orange> #info looking forward to your feedback on the acurate KPIs to define the stability
14:58:25 <morgan_orange> #info what kind of tests, which figures
14:58:46 <morgan_orange> #info natacha will help me to build testsuite to be run as part of stability stage in weekly deployments
14:58:58 <morgan_orange> #info testsuite back to OOM in progress
14:59:06 <morgan_orange> #info topic still open..
15:03:09 <morgan_orange> #info any volunteer welcome
15:03:40 <morgan_orange> #info CI/CD evolution
15:04:06 <morgan_orange> #info no resource on Nokia side to fully manage the CI/CD part of windriver (for the use cases and eventually some diversity testing)
15:04:16 <morgan_orange> #topic AoB
15:04:38 <morgan_orange> #info Andreas reporting some issues on helm3 installation (Maria DB + pb Clamp failing)
15:05:08 <morgan_orange> #info PNF use case (macro) available but blocked by an issue on SDC (Jira created)
15:05:17 <morgan_orange> #endmeeting