16:38:47 <morgan_orange> #startmeeting Integration weekly meeting 1/07/2020
16:38:47 <collab-meetbot> Meeting started Wed Jul  1 16:38:47 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:38:47 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:38:47 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_1_07_2020'
16:38:55 <morgan_orange> #topic action point follow up
16:39:03 <morgan_orange> #link https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/onap-int.2020-06-18-05.26.html
16:39:14 <morgan_orange> #info AP1: morgan_orange krzysztof integrate preonboarding  use case in CI Master
16:39:23 <morgan_orange> #info not done yet but still in mind...
16:39:50 <morgan_orange> #action morgan_orange krzysztof integrate preonboarding  use case in CI Master
16:40:01 <morgan_orange> #info AP2 morgan_orange contact Marco & Brian to get their feedback on Windriver/Intel Integration resources
16:40:13 <morgan_orange> #info done mail exchange, green light for integration tenant refactoring
16:40:25 <morgan_orange> #info AP3 morgan_orange create new project Integration-Terraform
16:40:26 <morgan_orange> #info done
16:40:35 <morgan_orange> #info AP4 all complete the etherpad to list possible scenarios
16:40:39 <morgan_orange> #info see next section
16:40:50 <morgan_orange> #info AP5 trevor provide the Bell upstream suite (need to select the place and check legal issues first)
16:40:57 <morgan_orange> #info AP6 Pawel W confirm we can swich from http endpoint to nonsslendpoint use case
16:40:59 <morgan_orange> #info not done
16:41:04 <morgan_orange> #action morgan_orange Pawel W confirm we can swich from http endpoint to nonsslendpoint use case
16:41:11 <morgan_orange> #info AP7 thierry/Andreas discuss onapsdk scenario structure and push first scenario in ONAP repo
16:41:24 <morgan_orange> #info done first protoype available see next section
16:41:31 <morgan_orange> #info AP8 morgan_orange contacts OOM to precise that it would be great to keep last 2 stable versions in CI
16:42:18 <morgan_orange> #info everybody agrees on the principle, we are lacking resources (people and hardware) for the moment, but it would fully make sense, maybe a question to raise to TSC/PTL
16:43:44 <morgan_orange> #topic stable branches
16:44:00 <morgan_orange> #info frankfurt status stable over the last week
16:44:13 <morgan_orange> #link https://docs.google.com/spreadsheets/d/1i3hPEqWwqggURXArrpum6I7j1Doao8HKWt-WBIG9gMg/edit?usp=sharing
16:45:09 <morgan_orange> #info issues are known issues (due to parallelization for vnf_) and due to hieratic behavior at AAI level for pnf-registrate => but globally it is fine
16:45:27 <morgan_orange> #info use case: maintenance release will be needed for some use cases..
16:45:41 <morgan_orange> #info few patches seen on CDS
16:46:28 <morgan_orange> #action morgan_orange ask Yuriy to get notified when patches are all in (needed for closed loop stuff out of the box) to self release testsuite 1.6.4
16:46:41 <morgan_orange> #info agreed by Yuriy at the end of the session
16:47:03 <morgan_orange> #info regarding the request for support on frankfurt => most of the questions dealing with frankfurt issues are related to the installation( maria-galera resinstallation)
16:47:23 <morgan_orange> #info OOm patch on upgrade has been reverted => reported to Guilin (need more testing...)
16:47:35 <morgan_orange> #info El Alto maintenance release
16:47:44 <morgan_orange> #info CI run until beginning of May (switch to daily Frankfurt) on orange DC
16:47:51 <morgan_orange> #info Results wer OK and fixes (end of branches mainly deal with certificate  issues) => no need to launch a full regression campaign all the more  as, as all the use case owners are no more involved in ONAP it would be  impossible to deal with the use cases.
16:48:12 <morgan_orange> #info Release manager asked if regression campaign was needed (expected according to our status)
16:48:34 <morgan_orange> #info answer was now: CI was fine until beginning of May, the only changes since this date deals with cert fixes
16:49:16 <morgan_orange> #info moreover impossible to ge El Alto use case owner (some moved to other projects). As the tests were poorly automated, almost all should be done manually
16:49:54 <morgan_orange> #info so no resources (neither humane nor hardware) to setup such regression campaign
16:49:58 <morgan_orange> #topic admin
16:50:12 <morgan_orange> #info Windriver/Intel cleaning operation about to start
16:50:18 <morgan_orange> #link https://wiki.onap.org/display/DW/Windriver+lab+Frankfurt+cleaning+campaign
16:50:35 <morgan_orange> #info info resaid during PTL meeting, cleaning shall start before the end of the week
16:50:52 <morgan_orange> #info resources for terraform based installation created
16:51:02 <morgan_orange> #info robot-utils: repository is available => we could set a robot linter  (not done on testsuite due to lots of errors but could be applied here)
16:51:33 <morgan_orange> #topic Guilin
16:51:40 <morgan_orange> #info New JIRA board available
16:51:46 <morgan_orange> #link https://jira.onap.org/secure/RapidBoard.jspa?rapidView=221&selectedIssue=INT-1268
16:52:03 <morgan_orange> #info cleaning also probably needed here as some JIRA were transfered from El Alto and did not move
16:52:12 <morgan_orange> #info new robot pod archi
16:52:19 <morgan_orange> #info testsuite/oom helm chart to be moved back to OOM (proposal to have both in // during transition phase)
16:52:26 <morgan_orange> #info leveraging on new architecture proposed by Daniel Rose (3 pods: 1 robot, 1 DB, 1 web server)
16:52:31 <morgan_orange> #info shall follow OOM recommendations (cloud native, security,..)
16:52:37 <morgan_orange> #info run the tests from inside the cluster/outside )> consequences
16:53:03 <morgan_orange> #info lucian already started working on this topic, should take the lead as some work already done to extract robot tests for ingress
16:53:09 <morgan_orange> #info but so far only AAI tests seem OK
16:53:31 <morgan_orange> #info other tests are calling internal components directly preventing the tests to be run as an end user (target)
16:54:11 <morgan_orange> #info Kzrysztof K indicates that it could be OK for some projects but clearly not all (pnf-registrate is directly calling the SO DB)
16:54:37 <morgan_orange> #info Kzrysztof O would like to see mark/label to know which tests are runnable from outside
16:55:10 <morgan_orange> #action morgan_orange intiate a wiki page to track the status of Robot rests (runnable from inside/outside) and get the reason cause when it is not runnable from outside
16:56:16 <morgan_orange> #info some tests calling DCAE through HTTP Internal VES collector pod  will not work (certificates need)
16:56:41 <morgan_orange> #info some exceptions are understandable but the rule shall be end user approach first, to be discussed case by case
16:57:01 <morgan_orange> #info Guilin Requirements dealing with VNF automation submitted by Lei (China Mobile)
16:57:09 <morgan_orange> #link https://jira.onap.org/browse/REQ-335
16:57:13 <morgan_orange> #link https://jira.onap.org/browse/REQ-336
16:57:17 <morgan_orange> #link https://jira.onap.org/browse/REQ-337
16:57:20 <morgan_orange> #link https://jira.onap.org/browse/REQ-338
16:57:40 <morgan_orange> #info need for automatio is shared, syncho session with CCMC this morning
16:57:58 <morgan_orange> #info they plan to update the tools they are used too (VTP / oclip / )
16:58:31 <morgan_orange> #info in Integration we do not use these tools (yet) - the use case vCPE Tosca we tried to integrated in frankfurt is using these tools, so it could be integrated in CI
16:58:50 <morgan_orange> #info I shared the CI view including xtesting and existing tests
16:59:22 <morgan_orange> #info I suggest also that we could maybe create an Integration slot for Asian contributor at a more convenient timer if needed
16:59:50 <morgan_orange> #info REQ-338 is a bit different, it deals with certification, which is out of scope of Integration mission
17:00:27 <morgan_orange> #info regarding REQ-335, 336 and 337, Integration support them all the more as work has been already initiated in El Alto in this area with the introduction of CI chains
17:01:03 <morgan_orange> #info it is also not a problem to have 2 tooling chains (xtesting/python-sdk or robot versus VTP/oclip)
17:01:17 <morgan_orange> #info Jira had been created for the integratin of VTP in frankfurt
17:01:39 <morgan_orange> #info next goal, integrate vCPE Tosca and see if help is needed on their tooling chain
17:01:44 <morgan_orange> #info pythonsdk
17:01:51 <morgan_orange> #info First release available on pypi
17:01:59 <morgan_orange> #link https://pypi.org/project/onapsdk/
17:02:11 <morgan_orange> #info thank to Michal and Sylvain for the first version
17:02:28 <morgan_orange> #info discussion on the possible scenarios to be created in https://git.onap.org/testsuite/pythonsdk-tests/
17:02:50 <morgan_orange> #info First PoC proposed for scenario by Thierry https://gitlab.com/Orange-OpenSource/lfn/onap/pythonsdk-tests
17:03:42 <morgan_orange> #info morgan_orange created an issue to review the scenario datamodel - avoid using the same approach than in onap-tests (mix between sdk / scenario, with too many hardcoded things)
17:04:22 <morgan_orange> #info pythonsdk has been developed by developers, onap-tests by integrators => good moment to improve the sceanrio part based on dev best practices (unit test, coverage, object moedlization,..)
17:04:43 <morgan_orange> #action michal sync with thierry/Andreas/Morgan to converge to the best scenario moedlization
17:05:14 <morgan_orange> #info Thierry implemented a scenario object as suggested in the Issue, onboarding/instantiation OK
17:07:54 <morgan_orange> #info to be reviewed by people interested in pythonsdk before we move the scenario to ONAP repo
17:07:55 <morgan_orange> #info new use cases
17:08:04 <morgan_orange> #info first try on check certificates: dealing with nodport/internal/ingress => to be integrated in CI
17:08:04 <morgan_orange> #link https://gerrit.onap.org/r/c/integration/+/109207
17:08:47 <morgan_orange> #info please committer review and merge => I will add it it CI
17:08:48 <morgan_orange> #info preonboarding, vcpe_tosca still in the loop
17:08:48 <morgan_orange> #info Upstream cds tests are coming
17:08:48 <morgan_orange> #info legacy tests could also be tested ..from the cluster, use the tag..
17:08:48 <morgan_orange> #action morgan_orange give a try to CDS test for next week
17:08:48 <morgan_orange> #info security test:
17:08:48 <morgan_orange> #info cleaning of the xfail lists on master?
17:08:50 <morgan_orange> #action morgan_orange contact SECCOM to see if we can reset the xfail list now or if we should wait a milestone
17:08:51 <morgan_orange> #info http enpoint => update: switch to nonssl? (Paweł Wieczorek )
17:08:51 <morgan_orange> #action morgan_orange contact Pawel W to see if we are OK to switch
17:08:51 <morgan_orange> #info which threshold fro limits?
17:08:51 <morgan_orange> #info add the question for SECCOM
17:08:51 <morgan_orange> #info check version according to SECCOM recommentations => ask SECCOm to  move their list through a file in their repo to get a gerrit reference  rather than a wiki page?
17:08:52 <morgan_orange> #info a usecase is ready, pawel should submit it next week
17:08:59 <morgan_orange> #action morgan_orange integrate the test in CI
17:09:03 <morgan_orange> #topic AoB
17:09:42 <morgan_orange> #info windriver ci from gitlab.com: I was able to install the full Openstack resources + launch the kubespray installation but still facing some issues...to be continued
17:09:54 <morgan_orange> #info question from Ali on the v2F2 video
17:11:33 <morgan_orange> #link https://wiki.lfnetworking.org/display/LN/2020+June+Virtual+Recordings
17:11:55 <morgan_orange> #info python SDK video is here
17:11:57 <morgan_orange> #link https://wiki.lfnetworking.org/download/attachments/40370243/Python%20ONAP%20SDK.mp4?api=v2
17:13:55 <morgan_orange> #info and documentation can be found in
17:13:55 <morgan_orange> #link https://python-onapsdk.readthedocs.io/en/latest/description.html#
17:13:55 <morgan_orange> #endmeeting