14:56:29 <morgan_orange> #startmeeting Integration weekly meeting 23/09/2020
14:56:29 <collab-meetbot> Meeting started Wed Sep 23 14:56:29 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:56:29 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:56:29 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_23_09_2020'
14:56:42 <morgan_orange> #topic Action point follow-up
14:56:52 <morgan_orange> #info AP1 morgan_orange finalize official procedure for new committers
14:56:55 <morgan_orange> #info done
14:57:01 <morgan_orange> #info AP2 morgan_orange pawel update security tests to include the waivers alredy given (seem mail from Krysztof) e.g. all the filebeats
14:57:05 <morgan_orange> #info work started
14:57:15 <morgan_orange> #topic admin
14:58:56 <morgan_orange> #info windriver status
14:59:23 <morgan_orange> #info after PTL meeting decision was to reinstall SB-00 and install a backup azure version
14:59:43 <morgan_orange> #info on windriver, all the jenkins CI chains have been disabled, all Integration tenants cleand
14:59:50 <morgan_orange> #info and SB-00 ha sbeen reinstalled
15:00:00 <morgan_orange> #info cluster test done 24 after installation provided good results
15:00:19 <morgan_orange> #link https://logs.onap.org/onap-integration/windriver-SB00/2020-09-22/
15:00:28 <morgan_orange> #info robot HC run this morning (+48) still OK
15:00:38 <morgan_orange> #info hope it will last longer than usual
15:01:01 <morgan_orange> #info the cleaning saved 5 labs so save RAM/Disk/Compute resources
15:01:18 <morgan_orange> #info installation of azure in the pipe But way to access to this lab to be setup
15:01:54 <morgan_orange> #info committers: congratulations to Lukasz, Michal and Thierry, they are now officially committers
15:02:11 <morgan_orange> #info all committers merge the INFO.yaml update on all the repositories
15:03:41 <morgan_orange> #info Note: Integration today is dealing with 22 active repositories
15:04:03 <morgan_orange> 5G-core-nf-simulator  cds   dc-simulator  heatbridge   mdons        onap-python  pnf-simulator    python-testing-utils  robot-utils  terraform  xtesting
15:04:03 <morgan_orange> bbs                   csit  demo          integration  onap-java11  oom          pythonsdk-tests  ran-simulator         seccom       testsuite
15:04:27 <morgan_orange> #info 5G-core-nf-simulator  cds   dc-simulator  heatbridge   mdons        onap-python  pnf-simulator    python-testing-utils  robot-utils  terraform  xtesting bbs csit  demo integration  onap-java11  oom pythonsdk-tests  ran-simulator seccom testsuite
15:04:47 <morgan_orange> #topic Guilin
15:05:19 <morgan_orange> #link https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-23-2020_10-09/
15:06:10 <morgan_orange> #info strange status on smoke tests, wait for next iteration..if so JIRA may be needeed (5G, pnf, hvves => issues with ves collector, basic_ => issue with SDC)
15:06:23 <morgan_orange> #info It was 83% yesterday so wait and see..
15:06:38 <morgan_orange> #info Blocking points follow UP
15:06:46 <morgan_orange> #link https://wiki.onap.org/display/DW/Guilin+Integration+blocking+points
15:15:36 <morgan_orange> #info review of the different categories
15:16:28 <morgan_orange> #action all review your JIRA and update, for M4 we should not have High priority Jira opened for more then 36 hours, fix, or move them to Honolulu
15:57:59 <morgan_orange> #info no more code dev for Guilin (M4 rules apply also to integration/testsuite)
15:58:14 <morgan_orange> #info but adaptation/integration obviously still accepted
15:58:54 <morgan_orange> #info pythonsdk-tests: Andreas, thierry and myself were able to re-run successfully the demo showed last week + scenario on basic network
15:59:03 <morgan_orange> #info it is now time to see how to integrate it in CI
15:59:16 <morgan_orange> #action morgan_orange package pythonsdk-tests in CI
15:59:27 <morgan_orange> #info maybe some help needed, please review the patch
15:59:36 <morgan_orange> #link https://gerrit.onap.org/r/c/testsuite/pythonsdk-tests/+/113002
16:00:10 <morgan_orange> #info pythonsdk to be released this week
16:00:31 <morgan_orange> #info last topic to be finalised the k8s plugin in pythonsdk => to keep coverage at 98%
16:01:59 <morgan_orange> #action michal see with Sylvain how to release the new version
16:02:08 <morgan_orange> #info discussions on future evolution started
16:02:16 <morgan_orange> #info use the etherpad to list what you would like to see
16:02:27 <morgan_orange> #link https://etherpad.opnfv.org/p/onap_integration_pythonsdk
16:02:31 <morgan_orange> #actin all complete this page
16:02:45 <morgan_orange> #action all complete the pythonsdk evolution etherpad
16:03:02 <morgan_orange> #info note no sessions planned during ONES summit => keep the usual slot
16:03:20 <morgan_orange> #info xfail lists for security tests
16:03:39 <morgan_orange> #agreed waiver related patches must be +2/merged by SECCOM (not by integration)
16:04:58 <morgan_orange> #info open question on the current patch => Fabian set -1 / Amy +1 => exceptions are valid only during the release scope, and will be reste for Honolulu..so exceptions shall be seen as "will not be fixed for this released", the exception list should be used in the documentation to identify the weakness
16:05:08 <morgan_orange> #info presentation of tern results
16:05:15 <morgan_orange> #info tern is a docker inspectin tool for licenses
16:10:31 <morgan_orange> #info so far => static analysis of the repository
16:10:41 <morgan_orange> #info tern performs a dynamic analysis on the dockers
16:11:10 <morgan_orange> #link https://github.com/tern-tools/tern
16:11:33 <morgan_orange> #info tests done on 29 dockers (among the 165 deployed in master) => 70% contains GPLv3
16:11:37 <morgan_orange> #link https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/09-20-2020_08-09/security/licenses/
16:11:54 <morgan_orange> #info problem reported to TSC (as a requirement was not GPLv3 in the dockers we are building)
16:12:02 <morgan_orange> #action morgan_orangecreate JIRA on HPLv3
16:12:26 <morgan_orange> #info note that some fixes can be quick..if projects are using the alpine baseline image (java or python) it is GPLv3 free
16:12:38 <morgan_orange> #info bash recent version is in GPMv3 => use sh
16:12:42 <morgan_orange> #undo
16:12:42 <collab-meetbot> Removing item from minutes: #info bash recent version is in GPMv3 => use sh
16:13:00 <morgan_orange> #info bash recent version is in GPLv3 => use sh
16:13:22 <morgan_orange> #info it is a legal issues more than a security issues => see what TSC suggests
16:13:46 <morgan_orange> #topic AoB
16:14:03 <morgan_orange> #info quesiton on CSIT tests, Lasse reported so issues (still dublin images referenced in some tests)
16:14:11 <morgan_orange> #info morgan sugest to clean/disable some tests
16:14:37 <morgan_orange> #info it would be good to initiate a guideline in order to help the project to bring back their functionnal tests in their repo and archive csit
16:14:48 <morgan_orange> #info some projects already did (SDC)
16:15:14 <morgan_orange> #action lasse sent a mail on onap-discuss + initiate a wiki page to help the reinsourcing of csit tests
16:15:32 <morgan_orange> #info K has question on the capability of the k8s plugin in pythonsdk
16:15:41 <morgan_orange> #info Michal C indicates that a documentation exists
16:16:15 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk/-/merge_requests/130
16:16:23 <morgan_orange> #info this MR has to be merged for Guilin
16:16:27 <morgan_orange> #endmeeting