15:22:35 <morgan_orange> #startmeeting Integration weekly meeting 25/11/2020
15:22:35 <collab-meetbot> Meeting started Wed Nov 25 15:22:35 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:22:35 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:22:35 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_25_11_2020'
15:22:41 <morgan_orange> #topic action point follow up
15:22:59 <morgan_orange> #info AP1: morgan_orange update all the INFO.yaml of all the Integration repositorie
15:23:00 <morgan_orange> #info done
15:23:15 <morgan_orange> #info AP2: morgan_orange contact LF/TSC for dockerhub policy change as it may be blocking..
15:23:51 <morgan_orange> #info done, LF paied the 300$ annual fees => will be OK for jenkins/csit but not fix the daily deployement executed from gitlab.com on Orange servers or Azure
15:24:07 <morgan_orange> #info AP3: morgan_orange send a mail to TSC to ask for clarification on use case in guilin documentation
15:24:54 <morgan_orange> #info point clarified during TSC meeting, split doc into 2 parts: Guilin use cases (including new use cases, requirements and old use cases retested in guilin)  + 1 part for old/deprecated use cases
15:25:03 <morgan_orange> #info AP4: demo of CSIT / Music next week
15:25:08 <morgan_orange> #info done see following topic
15:25:18 <morgan_orange> #topic demo cmpv2 use case + pnf simulator
15:25:51 <morgan_orange> #info Krzysztof Kuzmicki shows the CMPV2 demo introduced in Guilin to demonstrate cmvp2 capabilities with ONAP
15:25:59 <morgan_orange> #info robot test integrated in CI
15:26:12 <morgan_orange> #info pnf-simu (ves-simu) has been updated
15:26:22 <morgan_orange> #info there are several pnf simu...it is a bit misleading
15:26:43 <morgan_orange> #info a pnf simulator was created several versions ago and not very maintained
15:26:50 <morgan_orange> #info a forw was done => mass-pnf
15:27:00 <morgan_orange> #info mass-pnf no more maintained (to be confirmed)
15:27:28 <morgan_orange> #info but legacy pnf simulator refactored, it offers a full REST API (with a swagger) to manage template/config
15:27:52 <morgan_orange> #info it can be used for CDS (to simulate a config update) or by loop tests to generate events
15:28:08 <morgan_orange> #info morgan_orange indicates it will make sense to referenc eit more properly in the official documentation
15:28:27 <morgan_orange> #action morgan_orange create a tools section in official integration documentation
15:28:44 <morgan_orange> #action contact mass-pnf simu to get a status
15:28:57 <morgan_orange> #info legacy pnf simu repo is here:
15:29:19 <morgan_orange> #link https://git.onap.org/integration/simulators/pnf-simulator/
15:29:39 <morgan_orange> #info actions to be planned in Honolulu for a better identification of the simulators
15:29:59 <morgan_orange> #info KK indicates trhat he discovered some regression (cert authen working fine by basic auth no more)
15:30:12 <morgan_orange> #action krzysztof fix pnf-simu basic authen
15:30:33 <morgan_orange> #info tests in progres on python-sdk tests were initiated with the mass-pnf simu...
15:31:21 <morgan_orange> #info cmpv2 tests will be improved in Honolulu
15:31:29 <morgan_orange> #topic demo csit reactoring
15:31:57 <morgan_orange> #info lass presents the proposed flow for CSIT including a demo to illustrate the change with  Music project
15:32:01 <morgan_orange> #info new jjb recreated
15:32:32 <morgan_orange> #info the goal is to reintegrate the CSIT in project repo and trigger them on patch submition rather than out of the blue in daily/csit
15:32:56 <morgan_orange> #info projects started doing differently (SDC) and some have inter project dependencies (mix of functionnal and integration tests)
15:33:13 <morgan_orange> #info the refactoring gives a real value to the tests for the project
15:33:22 <morgan_orange> #info it also imposes a review of the docker buil strategy
15:33:36 <morgan_orange> #info Lasse is discussing this refactoring with PTL during PTL meeting
15:34:09 <morgan_orange> #info Christophe indicates that providing also feedback from sona in this flow will be appreciated by the PTL
15:34:46 <morgan_orange> #info for the moment sonar is run as a daily batch indepandently from the code
15:35:01 <morgan_orange> #action christophe contact Music to give a try on merge flow
15:53:25 <morgan_orange> #link https://wiki.onap.org/pages/viewpage.action?pageId=93001989
15:53:31 <morgan_orange> #topic AoB
15:53:48 <morgan_orange> #action all committers review  mail on release note
15:54:08 <morgan_orange> #info new tests expected on NBI/macro flow/pnf/basic clamp..
15:54:33 <morgan_orange> #info thanks to Dan and KK for the installation of windriver staging SB-00
15:54:43 <morgan_orange> #info 2 Guilin staging labs available for testing
15:54:57 <morgan_orange> #endmeeting