08:34:28 <morgan_orange> #startmeeting Integration Weekly meeting 26/08/2020
08:34:28 <collab-meetbot> Meeting started Thu Aug 27 08:34:28 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:34:28 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:34:28 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_26_08_2020'
08:34:38 <morgan_orange> #topic action point follow up
08:34:47 <morgan_orange> #link https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/weekly_integration_meeting_19_08_2020/onap-int-weekly_integration_meeting_19_08_2020.2020-08-19-15.00.html
08:34:59 <morgan_orange> #info AP1 morgan_orange amine andreas thierry give a try to Michal structure  with  existing tests (basic_vm, basic_vm(yaml), basic_clamp,  basic_network)
08:35:19 <morgan_orange> #info test done, first patch merged, see dedicated sections below
08:35:36 <morgan_orange> #topic Admin
08:36:13 <morgan_orange> #info windriver: OPNFV functest test setup to evaluate performance on Intel/Windriver lab
08:36:45 <morgan_orange> #info last VMTP tests showed that the performance are lower than they used to be before the move and after OPNFV (Cédric) audit
08:36:53 <morgan_orange> #info tests needed to confirm that
08:37:16 <morgan_orange> #info Andreas cofirms that low level infra issues have a big impact on ONAP
08:37:46 <morgan_orange> #Action morgan_orange redo some tests then conctact Intel/Windriver lab team to report results and see how to proceed to improve
08:38:23 <morgan_orange> #info as the machines have been reinstalled after the move, it could look like a MTU setting /switching issues
08:39:09 <morgan_orange> #info a risk has been raised for Guilin on the availability of an Integration lab for the use cases
08:39:34 <morgan_orange> #action morgan_orange send mail to use case onwers + PTL to report infra test status
08:39:53 <morgan_orange> #info new repositories available (sdc and terraform)
08:40:23 <morgan_orange> #info strange => creation done with the self-service method, but INFO.yaml created is not reported in the repository (an additional patch is needed)
08:40:46 <morgan_orange> #info baseline image follow up: Python 7.0.1 (no ONBUILD constraints) released
08:41:10 <morgan_orange> #info tern-tool test on the baseline image planned by dmaap showed the presence of GPLv3
08:41:22 <morgan_orange> #info xtesting dockers: frankfurt dockers created
08:41:40 <morgan_orange> #info it is now possible to precise that the branch can be used in docker build probess (not only tags)
08:42:09 <morgan_orange> #info howver classical issue => master branch lead to master tags, where latest is used (no master tags)
08:42:19 <morgan_orange> #info issue reported to Jessica through a LF ticket
08:42:54 <morgan_orange> #topic Maintenance releases
08:43:08 <morgan_orange> #info El Alto and Frankfurt release officially available
08:43:17 <morgan_orange> #info both CI chains still run on Orange HW
08:43:26 <morgan_orange> #topic Guilin
08:43:32 <morgan_orange> #info demo Pawel on version check
08:43:55 <morgan_orange> #info sub demo focusing on introspection of AAI dockers to verify Java and python versions according to SECCOM recommendations
08:44:34 <morgan_orange> #info parallelization needed because a full sequential audit would take more than 2h
08:44:44 <morgan_orange> #info the demo (AAI only) takes ~10 minutes
08:44:59 <morgan_orange> #info the introspector connect to each pod and run a version command line
08:45:12 <morgan_orange> #info results are cllected and compared to the reference versions set by SECCOM
08:45:26 <morgan_orange> #info work in progress to optimize the test duration
08:45:38 <morgan_orange> #info goal is to include it in security xtesting docker
08:45:58 <morgan_orange> #agreed put all the xfail lists in integration/seccom
08:46:09 <morgan_orange> #info for the moment some are in integration repo some in xtesting repo
08:46:40 <morgan_orange> #action pawel morgan_orange move all the waiver/xfail lists in integration/seccom + adapt the Dockerfile accordingly
08:47:10 <morgan_orange> #info pythonsdk basic_vm (without the cleaning) executed successfully on daily_frankfurt last friday
08:47:23 <morgan_orange> #info test structure validated and merged
08:48:19 <morgan_orange> #link https://gerrit.onap.org/r/c/testsuite/pythonsdk-tests/+/110288
08:48:38 <morgan_orange> #info several JIRAs have been created to start from this structure and start implementing new use cases
08:49:01 <morgan_orange> #info the 3 ones used in Frankfurt based onap_tests shall be replaced + new ones
08:49:20 <morgan_orange> #link https://wiki.onap.org/display/DW/Onap_tests+to+pythonsdk-tests+migration
08:49:55 <morgan_orange> #info goal is to migrate on Master for mid september (onap_tests are not fully reliable due to customer race conditions in SDC), new versions shall be more reliable and trustable
08:50:30 <morgan_orange> #info discussions on how to manage multicloud/no multicloud configuration => change in DB needed or use 2 Cloud regions
08:50:45 <morgan_orange> #action Thierry andreas find the best way to cover both options
08:51:06 <morgan_orange> #info andreas working onmacro workflow using CDS + Multicloud for vFW
08:51:17 <morgan_orange> #info still k8s operations needed for CDS (expose a node port)
08:51:43 <morgan_orange> #info demo testsuite DB: how do we define tests/pods
08:51:47 <morgan_orange> #info hwo to push results
08:51:55 <morgan_orange> #info how to create your own test DB/Test API
08:52:08 <morgan_orange> #info use the ansible galacy role created by C.Ollivier (OPNFv Functest)
08:52:21 <morgan_orange> #link https://wiki.opnfv.org/pages/viewpage.action?pageId=29098314
08:52:32 <morgan_orange> #info for public reporting you can use testresults.opnfv.org
08:53:35 <morgan_orange> #info reporting page is created through a python scrypt
08:53:37 <morgan_orange> #link https://gitlab.com/Orange-OpenSource/lfn/onap/xtesting-onap/-/blob/master/doc/generate_status.py
08:53:42 <morgan_orange> #topic AoB
08:54:02 <morgan_orange> #info Andreas detected a regression in master for E2E tests due to the misalignement between AAI (new fields) and SO
08:54:22 <morgan_orange> #action andreas create a JIRA on SO/AAI data change problem in master
08:54:51 <morgan_orange> #endmeeting