14:26:15 <morgan_orange> #startmeeting Integration weekly meeting 9/12/2020
14:26:15 <collab-meetbot> Meeting started Wed Dec  9 14:26:15 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:26:15 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:26:15 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_9_12_2020'
14:26:38 <morgan_orange> #topic Action point follow-up
14:26:50 <morgan_orange> #link https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/integration_weekly_meeting_2_12_2020/onap-int-integration_weekly_meeting_2_12_2020.2020-12-03-16.31.html
14:27:01 <morgan_orange> #info AP1 contact mass-pnf simu to get a status
14:27:26 <morgan_orange> #info done, Ericcson responds that no one on their side was maintaining sur simualtor anymore
14:27:47 <morgan_orange> #topic discussion MDONS use case
14:27:58 <morgan_orange> #info presentation of the use case MDONS extension
14:29:02 <morgan_orange> #link https://wiki.onap.org/display/DW/Integration+Meeting+Minutes?preview=%2F11930007%2F93003492%2FMDONS-Extension-R7.pdf
14:29:24 <morgan_orange> #info MDON (Multiple Domain Optical Networks) was introduced in Frankfurt
14:29:37 <morgan_orange> #info see presentation for call flows and architecture
14:30:27 <morgan_orange> #info it is based on MEF modelisation, In trankfurts it fulfills an interco between a Fujitsu equipment and openRoadm
14:30:42 <morgan_orange> #info work for a compelte multi Service Provider including transport PCE
14:31:26 <morgan_orange> #info in OOF the main change is the use of OOF and setup of CL for the optimal optical path computation (event sent in VES in cas of bad interdfomain link or error)
14:31:57 <morgan_orange> #info a Domain Controller simulator was developed in F but needs to be improved if we want to use it for automate the use case
14:32:10 <morgan_orange> #info test done on real physical equipment
14:32:24 <morgan_orange> #info test scripts shall also be improved
14:32:33 <morgan_orange> #topic Honolulu
14:32:50 <morgan_orange> #info discussion on the license verification
14:33:59 <morgan_orange> #info a tern PoC test was done in September
14:34:13 <morgan_orange> #info few pods were tested and results pushed to LF backend
14:34:28 <morgan_orange> #link https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/09-20-2020_08-09/security/licenses/aaf-core.html.gz
14:34:45 <morgan_orange> #info Tern is pretty clear on the layer and the components/licenses introduced by layer
14:35:03 <morgan_orange> #info LF whitesource tool (used in SaaS mode) also provides some licesing information
14:35:21 <morgan_orange> #info PTL shall have an access to this kind of tools (like sonarcloud)
14:35:29 <morgan_orange> #info but it is not directly linked to the code
14:35:50 <morgan_orange> #info to run Ten, some priviledges are needed and the test is relatively long
14:36:02 <morgan_orange> #info discussion on where such test shall be triggered
14:36:37 <morgan_orange> #info 2 possible options: in the integration chain (weekly chain) or in the docker build creation chain (LF / jenkins when asking for new release)
14:37:04 <morgan_orange> #action morgan alexander contact Jessica to see if it would be possible to add the script when building the dockers
14:39:28 <morgan_orange> #info if not possible a temp solution could be to run in the CI chain (fully managed by Integration)
14:39:28 <morgan_orange> #info testsuite back to OOM in progress
14:39:29 <morgan_orange> #info on Master oom/testsuite is now emptu, the code has been transfered back to OOM
14:39:29 <morgan_orange> #info for guilin change oom/testsuite remains the rught place (but change directly in guilin branch - no Master/cherry pick)
14:39:30 <morgan_orange> #info reflexion on the evolution of the robot pod to be done
14:39:30 <morgan_orange> #info pod run as root, using an ubuntu image, without limits including python 2.7, not cloud native (robot and DB in the same pod)...we can do better
14:39:36 <morgan_orange> #info evolution initiated by D.Rose (split nginx/robot)
14:39:52 <morgan_orange> #info work to be completed...
14:40:02 <morgan_orange> #info look for volunteer to refactor the robot pod in H...
14:40:13 <morgan_orange> #into test top priority
14:40:27 <morgan_orange> #info where shall we focus our resources for H...
14:40:52 <morgan_orange> #action morgan_orange create a page to list possible new tests => team will vote for the priorities...
14:41:15 <morgan_orange> #info several new tests already in the pipe (nasic_cds, basic_clamp, macro with PNF,..)
14:41:35 <morgan_orange> #info automation of vFW CL/Scale out...doc updated
14:41:40 <morgan_orange> #info qui of vCPE Tosca
14:41:52 <morgan_orange> #action morgan_orange contact China mobile to see the status of the test
14:42:30 <morgan_orange> #info CI/CD evolution => continue reflexion offline, but reinstallation of Windriver not before Q2 2021..we will ahve to live with the existing windriver for H
14:42:41 <morgan_orange> #topic Guilin
14:42:44 <morgan_orange> #info doc finalized
14:42:53 <morgan_orange> #info testsuite 1.7.3
14:43:09 <morgan_orange> #info build chain seems broken but lots of instability on jenkins last days
14:43:25 <morgan_orange> #info new changes done by Brian for vFW CL to be integrated for Guilin
14:43:38 <morgan_orange> #action morgan_orange Krzysztof fix build chain
14:43:49 <morgan_orange> #info stability test page updated
14:44:03 <morgan_orange> #link https://logs.onap.org/production/vex-yul-ecomp-jenkins-1/rtdv3-global-verify-master/3024/docs/integration-s3p.html#integration-s3p
14:44:10 <morgan_orange> #info memory leak detected on SDNC
14:44:30 <morgan_orange> #link https://jira.onap.org/browse/SDNC-1430
14:44:55 <morgan_orange> #info we also observed that the average time of test is increasing
14:45:33 <morgan_orange> #action morgan_orange create a ticket to track the fact that the duration=f(t) seems to increase in average
14:45:57 <morgan_orange> #endmeeting