#onap-int: Integration weekly meeting 22/01/2020

Meeting started by morgan_orange at 14:01:10 UTC (full logs).

Meeting summary

  1. action point follow-up (morgan_orange, 14:01:31)
    1. AP1: morgan investigate the Chromedriver issue introduced with the move to python3.8 => possibility to revert to 3.7 (as it it was OK in 3.7) (morgan_orange, 14:01:38)
    2. done, chrome driver included and python version set to python 3.7 (morgan_orange, 14:01:45)
    3. problem with chrome driver (morgan_orange, 14:02:37)
    4. Krzysztof repors there is an issue => ok with firefox drivers (morgan_orange, 14:03:29)
    5. ACTION: Krzysztof investigate on the driver issue (morgan_orange, 14:05:46)
    6. AP2: morgan_orange check if we can add verify job on integration (morgan_orange, 14:07:26)
    7. done, mail sent to contributors, see discussion in next topic (morgan_orange, 14:07:34)

  2. Admin (morgan_orange, 14:07:52)
    1. windriver lab is back (morgan_orange, 14:07:57)
    2. ACTION: morgan_orange set a daily CI chain on windriver (morgan_orange, 14:08:20)
    3. DDF: any feedback on the slide decks (morgan_orange, 14:09:17)
    4. several presentations in Prague - we need to have more automation + more people in defining and automate tests (morgan_orange, 14:10:27)
    5. maybe more people from DT in the near future (morgan_orange, 14:10:48)
    6. David also agrees on the need ofr automation (morgan_orange, 14:11:34)
    7. slide decks in Prague page (morgan_orange, 14:11:52)
    8. https://wiki.lfnetworking.org/pages/viewpage.action?pageId=25364127 (morgan_orange, 14:12:45)
    9. discussion verification jobs (morgan_orange, 14:23:26)
    10. ACTION: morgan_orange create a wiki page (morgan_orange, 14:23:45)
    11. we cannot be blocked (morgan_orange, 14:25:31)
    12. add quality check => informative in first step (morgan_orange, 14:26:38)
    13. discussion during DDF rocket chat seems problematic for some controbutors? confirmation? => there is already a slack channel for onpa-integration managed by LF (morgan_orange, 14:27:20)
    14. https://app.slack.com/client/TLEFM5VD2/CL8KEE28Z (morgan_orange, 14:28:31)
    15. ACTION: morgan_orange send mail for rocketchat/slack (morgan_orange, 14:31:44)

  3. Frankfurt (morgan_orange, 14:32:00)
    1. we did not reach the M2/M3 milestones due to 1 JIRA (morgan_orange, 14:32:08)
    2. some gerrit patch are opened for a long time (morgan_orange, 14:32:14)
    3. https://jira.onap.org/browse/INT-1378?jql=labels%20%3D%20relman%20AND%20fixversion%20%3D%20%22Frankfurt%20Release%22%20AND%20%22Epic%20Link%22%20%3D%20%22R6%20M2%2F3%20API%20and%20Functional%20Freeze%22%20AND%20project%20not%20in%20(SANDBOX%2C%20CIMAN)%20AND%20type%20%3D%20Task%20AND%20project%20%3D%20%22INT%22%20AND%20status%20%3D%20%22In%20Progress%22%20ORDER%20BY%20status%20ASC%2C%20updated%20ASC (morgan_orange, 14:32:29)
    4. CI status (morgan_orange, 14:36:32)
    5. Use case update (morgan_orange, 14:36:39)
    6. Discussion on 3rd party Controller mock (BBS use case) (morgan_orange, 14:36:45)
    7. problem: BBS can be tested only in lab whn we have specific vendor controllers => proposal to create a Mock of third party controller (more or less generic) (morgan_orange, 14:37:28)
    8. it would help us to redo BBS independently from the equipment (morgan_orange, 14:37:46)
    9. they developped a very lightweigh controller for BBS => can maybe reuse part of it (morgan_orange, 14:38:10)
    10. next step look at the external edge controller and see how feasible it is to use it and make it more generic (morgan_orange, 14:41:35)
    11. ACTION: David look at edge controller to see if they can be used for emulator (morgan_orange, 14:43:32)
    12. review use case page (morgan_orange, 14:44:02)
    13. ACTION: morgan_orange send mail to use case users (morgan_orange, 14:44:18)
    14. Requests from Seccom (morgan_orange, 14:45:20)
    15. kubernetes CIS verification (morgan_orange, 14:49:46)
    16. onap-java docker (morgan_orange, 14:51:08)
    17. kubernetes CIS verification (morgan_orange, 14:53:55)
    18. introduction of the security docker in CI chains (morgan_orange, 14:54:03)


Meeting ended at 15:02:29 UTC (full logs).

Action items

  1. Krzysztof investigate on the driver issue
  2. morgan_orange set a daily CI chain on windriver
  3. morgan_orange create a wiki page
  4. morgan_orange send mail for rocketchat/slack
  5. David look at edge controller to see if they can be used for emulator
  6. morgan_orange send mail to use case users


Action items, by person

  1. morgan_orange
    1. morgan_orange set a daily CI chain on windriver
    2. morgan_orange create a wiki page
    3. morgan_orange send mail for rocketchat/slack
    4. morgan_orange send mail to use case users
  2. UNASSIGNED
    1. Krzysztof investigate on the driver issue
    2. David look at edge controller to see if they can be used for emulator


People present (lines said)

  1. morgan_orange (45)
  2. collabot` (3)


Generated by MeetBot 0.1.4.