14:00:45 <morgan_orange> #startmeeting Integration weekly meeting 12/02/2020
14:00:45 <collabot`> Meeting started Wed Feb 12 14:00:45 2020 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:45 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:45 <collabot`> The meeting name has been set to 'integration_weekly_meeting_12_02_2020'
14:00:49 <morgan_orange> #topic action point follow up
14:00:54 <morgan_orange> #info AP1: morgan_orange organize ad hoc meeting with lab owners to share tooling and best practices
14:00:58 <morgan_orange> #info done, mail sent to Open Lab subcommitee, wait for feedback
14:01:01 <morgan_orange> #info AP2: pawel complete the scripts to exclude false positive
14:01:06 <morgan_orange> #info done for jdwp
14:01:13 <morgan_orange> #link https://gerrit.onap.org/r/c/integration/+/101517
14:01:14 <morgan_orange> #info still to be done for http endpoints
14:01:18 <morgan_orange> #info mail sent to the community to collect the exception for HTTP exposure
14:01:23 <morgan_orange> #action: pawel complete the scripts to exclude false positive in http_endpoints scanning
14:01:28 <morgan_orange> #info AP3: all review the page and adjust the criteria / morgan to report to David before the end of the week
14:08:58 <morgan_orange> #info link sent to David Mc Bride
14:09:09 <morgan_orange> #info AP4: morgan_orange create JIRA on OOF and VFC
14:09:14 <morgan_orange> #info done
14:09:20 <morgan_orange> #link https://jira.onap.org/browse/OPTFRA-697
14:09:24 <morgan_orange> #info fixed and merge
14:09:29 <morgan_orange> #link https://jira.onap.org/browse/VFC-1616
14:09:34 <morgan_orange> #info fixed wait for merge
14:09:41 <morgan_orange> #info AP5: morgan move ingress_nodeport to infrastructure-healthcheck
14:10:15 <morgan_orange> #info done
14:10:24 <morgan_orange> #topic Feedback from the Syncho with Seccom/OOM
15:54:06 <morgan_orange> #info meeting last week with seccom
15:54:54 <morgan_orange> #info conclusion can be found in  https://wiki.onap.org/display/DW/Docker+and+Kubernetes+Security
15:55:25 <morgan_orange> #info priority pod_roots, then remove jdpw ports, reduce list of public HTTP endpoints, improve CIS as much as possible
15:55:34 <morgan_orange> #topic Admin
15:55:41 <morgan_orange> #info Specific Integration milestones to be defined and reported to David McBride: Integration M4 milestone possible evolution
15:55:45 <morgan_orange> #info Update on Integration verification job
15:55:51 <morgan_orange> #info python verification job added in Integration repo (for vCPE)
15:55:55 <morgan_orange> #info alias team.onap.eu created
15:56:03 <morgan_orange> #info reinsourcing of oom/robot in robot: https://gerrit.onap.org/r/c/oom/+/101605
15:59:22 <morgan_orange> #info oom/robot was initially in oom repository, then it was decided to use submodules (aai then robot did the work to externalize the helm charts). But the OOM position is now to come back to first view as it is very difficult to manage for OOM team especially when refactoring for secret,  common DB, ..
15:59:30 <morgan_orange> #topic Lab Status
15:59:47 <morgan_orange> #info no update
15:59:52 <morgan_orange> #topic Frankfurt status
16:00:17 <morgan_orange> #info Use case update
16:00:42 <morgan_orange> #info PNF onboarding blocked by DCAE issue. Patch submitted to fix it
16:00:54 <morgan_orange> #link https://gerrit.onap.org/r/c/oom/+/99998
16:02:29 <morgan_orange> #info issues dealing with AAF under investigation on Gating part (Only Orange platform seems to be impacted - better results on Azure)
16:02:49 <morgan_orange> #info vFW use case - no change
16:02:55 <morgan_orange> #info scaleout will include improvement on CDS side
16:03:02 <morgan_orange> #info preload ONAP with some date including which controller we want to use
16:03:08 <morgan_orange> #info leverage the latest CDS functionalities (preload data)
16:03:17 <morgan_orange> #info in previous release, some manual steps where needed (which controllers in SO)
16:03:25 <morgan_orange> #info still work needed on integration
16:04:40 <morgan_orange> #info Prahbu provided an update on use case 18 - more a feature than a use case
16:05:03 <morgan_orange> #info wiki and rst files have been updated
16:05:05 <morgan_orange> #link https://gerrit.onap.org/r/#/c/sdc/+/82573/3/docs/configuration.rst
16:05:13 <morgan_orange> #link https://gerrit.onap.org/r/#/c/sdc/+/82573/3/docs/externaltesting.rst
16:05:47 <morgan_orange> #info it is an extended feature of Dublin release in SDC and has been successfully tests in Vodafone and Huawei's lab
16:06:40 <morgan_orange> #info Tech Mahindra working on stability test (72h)
16:06:53 <morgan_orange> #info discussions in progress with Brian (the right person)
16:06:59 <morgan_orange> #info documentaiton is lacking
16:07:44 <morgan_orange> #info morgan_orange suggests to start a doc based on exchanges with Brian as such tests are very valuabel, should be runnable in any lab and even extended
16:07:53 <morgan_orange> #info discussion during Prague DDF on this topic
16:08:48 <morgan_orange> #link https://wiki.lfnetworking.org/pages/viewpage.action?pageId=25364127&preview=/25364127/28738378/performance_robustness_tests_final.pdf
16:09:18 <morgan_orange> #info DCAE and pnf_registrate tests blocked by DCAE issue
16:09:57 <morgan_orange> #info Portal tests: morgan_orange sent a mail to Portal PTL to know if there is any test plan. It would be nice to add basic tests (login/logout of all users, browsing, access to sub pages)
16:10:31 <morgan_orange> #info a test already exists (healthportalapp but 5 tests are failing (and all users not tested) but it could be a good base
16:10:57 <morgan_orange> #info refactoring would be needed but it could bring value all the more as we can integrate it in the gate
16:11:35 <morgan_orange> #info Open question on "basic CDS" test availability
16:12:16 <morgan_orange> #action Get Feedback from Yuri on the availability of such test (as CDS had some issue in El Alto release - we should test it more and automate basic test to give more trust to end users)
16:13:16 <morgan_orange> #info update on CM and k8s/CDS: Lukasz is confident, good progress done by Samsung team, integration phase started (no patchset pending for the moment)
16:13:36 <morgan_orange> #info JIRA status
16:13:36 <morgan_orange> #link https://jira.onap.org/secure/RapidBoard.jspa?rapidView=207&quickFilter=630
16:13:57 <morgan_orange> #info in the blocking point there is an open JIRA dealing with Log and pomba which is not supported in Frankfurt
16:14:14 <morgan_orange> #action morgan_orange contact Andrew to see if the log/pomba blocking point is still relevant
16:14:24 <morgan_orange> #info New A&AI regression detected (no more tenant id leading to failure of the end to end VNF tests)
16:14:48 <morgan_orange> #info Jimmy built a staging docker, successfully tested on windriver, a release version shall be built very soon
16:14:57 <morgan_orange> #info CI status
16:15:01 <morgan_orange> #info Master status
16:15:08 <morgan_orange> #link https://orange-opensource.gitlab.io/lfn/tools/results_ts_view/
16:15:40 <morgan_orange> #info status relatively stable, several fix APPC, OOF expected soon
16:16:06 <morgan_orange> #info Parallelization of the VNF and security tests (to save CI time) in progress to save CI time and keep CI under control
16:16:16 <morgan_orange> #info windriver CI still pending - runner is working well but clean/server creation seems to request parameters that do not fit well together
16:16:19 <morgan_orange> #topic AoB
16:16:34 <morgan_orange> #info time slot to be planned for Estech simulator presentation to Integration team
16:16:57 <morgan_orange> #info Kube-hunter new security test introduce to report k8s vulnerabilities
16:17:43 <morgan_orange> #info morgan_orange will be in PTO  until the 26th, Marco and Brian will be your Master of Ceremony for next weekly meetings
16:17:45 <morgan_orange> #endmeeting