13:01:10 <morgan_orange> #startmeeting integration weekly meeting 15/04/2020
13:01:10 <collabot`> Meeting started Wed Apr 15 13:01:10 2020 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:10 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:10 <collabot`> The meeting name has been set to 'integration_weekly_meeting_15_04_2020'
13:01:36 <morgan_orange> #topic Action points follow-up
13:01:44 <morgan_orange> #info AP1 morgan_orange plan new JIRA to address the points mentioned by SECCOM
13:01:49 <morgan_orange> #info started but not completed
13:01:54 <morgan_orange> #action morgan_orange plan new JIRA to address the points mentioned by SECCOM
13:06:23 <morgan_orange> #info AP2 morgan_orange contact Daniel to share view on the status of the robot deployment for Frankfurt
13:06:29 <morgan_orange> #info done, too late for micro service architecture, secure simple evolution (update of the repositories + build chain)
13:06:34 <morgan_orange> #info micro services archi postpone to Guilin
13:06:43 <morgan_orange> #info AP3 marco launch scripts to reinstall ONAP on SB-04 for VNFSDK
13:06:59 <morgan_orange> #info crosscheck with him offline
13:07:10 <morgan_orange> #info AP4 morgan_orange reschedule a 15 slots for ATT new test framework
13:07:18 <morgan_orange> #info done see next topic
13:07:26 <morgan_orange> #info AP5 morgan_orange continue mailthread, discuss on possible testsuite + list ATT integration contributors
13:07:35 <morgan_orange> #info done
13:07:40 <morgan_orange> #info AP6 morgan_orange initiate a wiki page to initiate discussion on Guilin priorities
13:07:44 <morgan_orange> #info done
13:09:10 <morgan_orange> #info AP3 done
13:09:16 <morgan_orange> #topic Admin
13:09:26 <morgan_orange> #info Ready for self release testsuite 1.6.0: did anyone test the new docker?
13:10:37 <morgan_orange> #info Introduction of a verification on doc (rst + md) in progress...to avoid regression in doc
13:12:27 <morgan_orange> #info externalization of pnf-simulator seems on good track
13:14:30 <morgan_orange> #topic Introduction AT&T SDN testing framework
13:14:48 <morgan_orange> #action morgan_orange update new version of the pdf describing the SDN framework
13:17:41 <morgan_orange> #info legacy ONAP Robot Framework  => refactored with focus on //ization
13:21:10 <morgan_orange> #info framework targeting Dev and Operation community
13:23:16 <morgan_orange> #info portable, up to 65% reusable code
13:30:58 <morgan_orange> #info question on the opportunity  to test this framework for G version
13:32:23 <morgan_orange> #info open question onf the capability to decouplet opensource part from proprietary
14:05:22 <morgan_orange> #topic Frankfurt status
14:05:27 <morgan_orange> #info almost all the components have been integrated in OOM Master
14:05:32 <morgan_orange> #link https://wiki.onap.org/display/DW/Frankfurt+Readiness+dashboard
14:05:36 <morgan_orange> #info CLI, MSB and Music still in the OOM gates (security issues with hardcoded certificates)
14:05:41 <morgan_orange> #info Blocking issues: 1: Frankfurt Release Integration Test Blocking Issues
14:05:47 <morgan_orange> #link https://wiki.onap.org/display/DW/1%3A+Frankfurt+Release+Integration+Test+Blocking+Issues
14:05:52 <morgan_orange> #info CI status (Daily Master)
14:05:56 <morgan_orange> #link https://gating-results.onap.eu/results/
14:06:01 <morgan_orange> #info test status:
14:06:05 <morgan_orange> #info Security (last miles for rooted pods (<20)  and http public end points (Music and CLI)
14:06:10 <morgan_orange> #info E2E: pnf_registrate looks better (1/2 OK - DCAE part OK), E2E better since AAI update on service-schema (basic_vm ok on some gating), freeradius_nbi: discussion in progress with NBI and SO, APi could have been modified
14:07:20 <morgan_orange> #info Andreas reported a pb on onap-tests, as we are doing the test in // but not always using a unique ID, it seems that the SDC gets lost and distributions are not really completed, all are said to be OK but SO saw only hte first one
14:07:36 <morgan_orange> #info no resources to go further on vCPE for the moment
14:07:44 <morgan_orange> #info JIRA: think to update your Jira (close / fix or move to G or H)
14:07:48 <morgan_orange> #topic Use cases
14:07:53 <morgan_orange> #info Health of SB-01 => shall we reinstall it on master (without staging assuming that 90% of the docker have been released (music, MSB and CLI missing) Frankfurt Readiness dashboard
14:08:14 <morgan_orange> #info Marco indicates that SB-01 is used (all the components have not been installed, expalining why there are so many healthcheck errors)
14:08:31 <morgan_orange> #info morgan indicates that robot has been updated to 1.6.0-staging
14:08:39 <morgan_orange> #info SB-04 installed last week
14:08:56 <morgan_orange> #info SB-02 or 03 to be installed begining of next week
14:09:25 <morgan_orange> #info could use OOM Master (95% of RCO with possibly staging for MSB, CLI, MUSIC and OOF?)
14:09:30 <morgan_orange> #info Review of the use cases page
14:09:35 <morgan_orange> #link https://wiki.onap.org/display/DW/2%3A+Frankfurt+Release+Integration+Testing+Status
14:10:13 <morgan_orange> #action morgan_orange send a mail to use case owner to indicate the availability of a lab next week + see how we will manage the progress reporting (during weekly meeting?)
14:10:51 <morgan_orange> #info question from marcin => current page with baisc status indicators (<90 <95 completed) is very limited => init / in progress / done
14:11:11 <morgan_orange> #info we do not have information on the number of use cases / test plan status / ...
14:11:21 <morgan_orange> #topic Guilin
14:11:28 <morgan_orange> #undo
14:11:28 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2118110>
14:12:35 <morgan_orange> #info morgan_orange indicates that ideally we should move from wiki to gate (as for pnf_registrate) but it is not trivial..and it will take time but he agrees that declarative status is misleading - test case may work in specific environement and be very difficult to replay in another, that is why a gate would be better..
14:12:43 <morgan_orange> #topic guiling
14:12:44 <morgan_orange> #info no meeting next week due to vF2F
14:12:50 <morgan_orange> #info topic submitted to defined Guilin priorities
14:12:55 <morgan_orange> #info wiki page initiated
14:12:59 <morgan_orange> #link https://wiki.onap.org/display/DW/Integration+Priorities+for+Guilin
14:13:01 <morgan_orange> #endmeeting