15:40:16 <morgan_orange> #startmeeting ONAP integration weekly meeting 12/08/2020
15:40:16 <collab-meetbot> Meeting started Wed Aug 12 15:40:16 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:40:16 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:40:16 <collab-meetbot> The meeting name has been set to 'onap_integration_weekly_meeting_12_08_2020'
15:40:26 <morgan_orange> #topic Action point follow-up
15:40:53 <morgan_orange> #info AP1 kryzstof start a mail thread to evaluate the load/difficulty to automate k_s plugin test for DCAE
15:41:00 <morgan_orange> #info not done yet
15:41:09 <morgan_orange> #action  kryzstof start a mail thread to evaluate the load/difficulty to automate k_s plugin test for DCAE
15:41:18 <morgan_orange> #info AP2 morgan_orange update the k8s version to 1.5.11 on windriver (patch needed in master/frankfurt)  and give a new try..
15:41:51 <morgan_orange> #info test done by Christophe on windriver, version change has no impact (and it is well working on Nokia using 1.15.3 + OOM reco = 1.15.x)
15:41:57 <morgan_orange> #info done
15:42:11 <morgan_orange> #info AP3 morgan_orange split Amine patch into 2 patches: structure (Thierry proposal) / clamp (Amine)
15:42:18 <morgan_orange> #info not needed, there were already 2 patches
15:42:42 <morgan_orange> #info Amine patches includ update of the proposal from thierry but the 2 patches (infra / CLAMP) were separated
15:43:00 <morgan_orange> #info AP4: Sebastien  (Bell):  provide code + procedure to give a first try ...
15:43:04 <morgan_orange> #info not done
15:43:21 <morgan_orange> #info Sebstien indicated that he was not sure to be able to do it this week
15:43:34 <morgan_orange> #info AP5 Trevor (Bell): tell if OK with a dedicated repository. As it is functional  testing, it is usually hosted in the project...cds/cds/tests (under Dan  responsibility)
15:43:41 <morgan_orange> #info done, request sent to coordinator
15:43:50 <morgan_orange> #info AP6: Kuldeep initiate a mail thread
15:43:52 <morgan_orange> #info done
15:44:00 <morgan_orange> #info AP7 Kuldeep initiate a mail thread   morgan_orange send a mail with the procedure to run onap-k8s tests on any ONAP solution
15:44:02 <morgan_orange> #info done
15:44:10 <morgan_orange> #info AP8: morgan_orange send the windriver CI SB-00 jenkins script to Sandeep
15:44:14 <morgan_orange> #info done
15:44:24 <morgan_orange> #topic Admin
15:44:36 <morgan_orange> #info new alpine based java image ready to be merged
15:44:54 <morgan_orange> #info it seems that committers do not have the +2/merge despite an up to date INFO.yaml
15:45:09 <morgan_orange> #action morgan_orange report INFO.yaml unsync issue to LF
15:45:23 <morgan_orange> #info once merged => a 7.1.0 will be produced
15:45:53 <morgan_orange> #info reminder the goal is to propose a GPLv3 free community java 11.08 baseline image
15:46:17 <morgan_orange> #info projects can do whatever they want but tjis image is without GPLv3 and with the SECCOM recommended version
15:46:42 <morgan_orange> #info projects must be compliant with these 2 topics (GPLv3 + java11)
15:46:54 <morgan_orange> #info michal indicated that a new version of the python baseline is needed
15:47:18 <morgan_orange> #info the directive prevent the install of package pip -r requirement executed, but system lib needed
15:47:36 <morgan_orange> #action morgan michall review offline what is needed and release a 7.0.1 version for onap-python
15:48:33 <morgan_orange> #info new repository creation requests: testsuite/cds (request sent) + integration/simulators/cn-simulator, integration/terraform
15:48:51 <morgan_orange> #action morgan initiate the procedure to create integration/simulators/c,-simulator
15:49:05 <morgan_orange> #undo
15:49:05 <collab-meetbot> Removing item from minutes: #action morgan initiate the procedure to create integration/simulators/c,-simulator
15:49:17 <morgan_orange> #action morgan initiate the procedure to create integration/simulators/cn-simulator
15:49:24 <morgan_orange> #action morgan_orange initiate the procedure to create integration/terraform
15:49:56 <morgan_orange> #info note that it is a bit painfull to manage...as the notion of right heritage is not really working (see unsync INFO.yaml issues) but it is clearer for maintenance
15:50:07 <morgan_orange> #info windriver lab
15:50:29 <morgan_orange> #info several issues on SB-00 and windriver daily
15:50:44 <morgan_orange> #info CLAMP deployement is failing, OOM is suspected (was working in Frankfurt)
15:51:06 <morgan_orange> #info DB/login passwords are available in the secret but empty from the init container of the clamp DB
15:51:22 <morgan_orange> #info as a consequence DB not startin > backend not starting > clamp deployment failing
15:51:29 <morgan_orange> #info it is reproducible on windriver
15:51:42 <morgan_orange> #on this other hand no issue reported on Orange or Nokia lab
15:52:08 <morgan_orange> #info SB-00 reinstalled on the 5th of August => all healthcheck (except CLAMP) were PASS
15:52:21 <morgan_orange> #info 7 days later several HC issues reported
15:52:50 <morgan_orange> #info performance issues have already been reported in the lab but it seems that it is hard to keep a stable version of ONAP
15:52:59 <morgan_orange> #info infrastructure is stable
15:53:45 <morgan_orange> #info info Stephe Goosh disk are only SSD or NVME => no no issue due to old disc and known Cassandra/ceph performance issue
15:54:10 <morgan_orange> #info hard to reinstall every 2 days all the more as previous lab managers (Gary / Marco) are o more involved
15:54:51 <morgan_orange> #info installation procedure is based on Gary's script, jenkins script is on jenkins server. conf files in the integration repository
15:55:01 <morgan_orange> #info manual operations are needed to maintain the sync
15:55:25 <morgan_orange> #info during Frankfurt, we detected relatively late that the versions of kubernetes and helm were not the ones recommended by OOM team
15:56:20 <morgan_orange> #info as we are lacking resources, morgan_orange suggests to give the feedback to TSC and release manager. Stability is needed before offering the lab for testing
15:56:52 <morgan_orange> #info in the past charts were regularly reinstalled to fix issues but these resources are no more present to deal with that
15:57:17 <morgan_orange> #info it is still possible to use Orange lab assuming that part of the daily could be offloaded (e.g. daily master run on DT chain?)
15:58:07 <morgan_orange> #action morgan_orange indicate that Integration ONAP installation Intel/Windriver lab is under investigation to work on the stability and cannot be used until it is fixed.
15:58:48 <morgan_orange> #info possible mitigation gate resources to supervize the lab. But reinstalling every 3 days is not an option
15:59:03 <morgan_orange> #topic Status on ElAlto Maintenance release
15:59:17 <morgan_orange> #link https://gating-results.onap.eu/results/onap_daily_pod4_elalto-682043557/smoke-usecases/basic_vm/xtesting.debug.log
15:59:40 <morgan_orange> #info last issue looks like an integration issue and a KEYSTONE_V2/KEYSTONE_V3 bad configuration in SO adapter
15:59:51 <morgan_orange> #info additional tests are needed to verify
16:00:06 <morgan_orange> #info if instantiation can be completed El Alto Maintenance release will be ready for tagging
16:00:33 <morgan_orange> #info note as reported to PTL last Monday, new critical components will expire within 50 days...
16:01:02 <morgan_orange> #info improvement done in frankfurt shall improve the cert manager in the future but if El Alto is fine..let's tag it
16:01:13 <morgan_orange> #topic Status on Frankfurt Maintenance release
16:01:34 <morgan_orange> #info daily frankfurt stable, tagging done by LF
16:01:46 <morgan_orange> #topic Guilin
16:02:02 <morgan_orange> #info discussions on the structure of the tests leveraging pythonsdk
16:02:28 <morgan_orange> #link https://gerrit.onap.org/r/c/testsuite/pythonsdk-tests/+/110288
16:02:34 <morgan_orange> #info Michal submitted a proposal
16:02:37 <morgan_orange> #agreed
16:02:52 <morgan_orange> #info we need to test it through examples
16:03:13 <morgan_orange> #info possible to add a yaml support to match Thierry expectencies to have flexibility on the service (with several VF)
16:03:37 <morgan_orange> #info maybe wording could be improved => base = scenario / component = step ?
16:04:24 <morgan_orange> #action morgan_orange amine andreas thierry give a try to Michal structure with existing tests (basic_vm, basic_vm(yaml), basic_clamp, basic_network)
16:04:31 <morgan_orange> #info plan a demo next week
16:04:47 <morgan_orange> #info demo cert => currently run mannualy
16:04:56 <morgan_orange> #info allow to get info on the certificates
16:05:18 <morgan_orange> #info same code for tests executed from outside (node port / ingress to be added) or inside
16:05:35 <morgan_orange> #info tests done and results shared with the community on daily elalto and daily frankfurt
16:05:47 <morgan_orange> #info a JIRA has been created to integrate it in CI
16:05:56 <morgan_orange> #info demo version postponed to the 26th of August
16:05:59 <morgan_orange> #topic AoB
16:06:11 <morgan_orange> #info question from yoonsoon on where to push his code
16:06:35 <morgan_orange> #action morgan_orange initiate admin procedure + send a mail to yoonsoon
16:06:57 <morgan_orange> #info open question on the stability of the installation using Terraform and the possibility to get a demo
16:07:05 <morgan_orange> #action morgan_orange plan a terraform demo next week
16:07:11 <morgan_orange> #endmeeting