15:00:54 <morgan_orange> #startmeeting weekly integration meeting 19/08/2020
15:00:54 <collab-meetbot> Meeting started Wed Aug 19 15:00:54 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:54 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:54 <collab-meetbot> The meeting name has been set to 'weekly_integration_meeting_19_08_2020'
15:01:04 <morgan_orange> #topic Action point follow-up
15:01:22 <morgan_orange> #info AP1:    kryzstof start a mail thread to evaluate the load/difficulty to automate k_s plugin test for DCAE
15:01:24 <morgan_orange> #info done
15:01:36 <morgan_orange> #info AP2: morgan_orange report INFO.yaml unsync issue to LF
15:02:17 <morgan_orange> #info done but only on the reported repo, the issue occurs regularly on new repository. It was suggested to create a cron to resync regularly. Meanwhile the way to resync = LFN ticket
15:02:28 <morgan_orange> #info AP3: morgan michall review offline what is needed and release a 7.0.1 version for onap-python
15:02:40 <morgan_orange> #info patch in the gate to remove the oNBUILD contrainst
15:03:03 <morgan_orange> #info Christophe reported that SDC had no issue and provides his Dockerfile
15:03:11 <morgan_orange> #info unfortunately it does not work
15:03:20 <morgan_orange> #info so the question of the patch remain open
15:03:38 <morgan_orange> #info if no workaround 7.0.1 could ge officially released without the ONBUILD directives
15:03:49 <morgan_orange> #info AP4: morgan initiate the procedure to create integration/simulators/cn-simulator
15:03:52 <morgan_orange> #info done
15:04:02 <morgan_orange> #info AP5: morgan_orange initiate the procedure to create integration/terraform
15:04:09 <morgan_orange> #info done, demo planned today
15:04:22 <morgan_orange> #info AP6: morgan_orange indicate that Integration ONAP installation  Intel/Windriver lab is under investigation to work on the stability and  cannot be used until it is fixed.
15:04:37 <morgan_orange> #info done, topic created for last PTL meeting
15:06:33 <morgan_orange> #info Christophe mentioned that he made a minimal installation on windriver with only 1 node => clamp issue is reproducible
15:08:55 <morgan_orange> #info so it does not look linked to the deployment..infra audit in progress we need to eliminate scenario (hardware/infra/deployment/..)
15:09:08 <morgan_orange> #info AP7: morgan_orange amine andreas thierry give a try to Michal structure  with existing tests (basic_vm, basic_vm(yaml), basic_clamp,  basic_network)
15:09:27 <morgan_orange> #info activity started but still in progress..
15:09:37 <morgan_orange> #info AP8: morgan_orange initiate admin procedure + send a mail to yoonsoon
15:09:39 <morgan_orange> #info done
15:09:44 <morgan_orange> #info AP9    morgan_orange plan a terraform demo next week
15:09:45 <morgan_orange> #info done
15:09:56 <morgan_orange> #action morgan_orange amine andreas thierry give a try to Michal structure  with existing tests (basic_vm, basic_vm(yaml), basic_clamp,  basic_network)
15:10:08 <morgan_orange> #topic Admin
15:10:30 <morgan_orange> #info Windriver SB-00
15:10:45 <morgan_orange> #info reinstallation of Functest Gate on Windriver to get facts and figures based on Functest test suites
15:10:59 <morgan_orange> #info daily CI chain to be reset
15:11:08 <morgan_orange> #info new repo on track
15:11:24 <morgan_orange> #link https://gerrit.linuxfoundation.org/infra/c/releng/info-master/+/65140
15:11:33 <morgan_orange> #link https://gerrit.linuxfoundation.org/infra/c/releng/info-master/+/65138
15:11:40 <morgan_orange> #link https://gerrit.linuxfoundation.org/infra/c/releng/info-master/+/65139
15:12:01 <morgan_orange> #info java baseline image released 7.1.0 (based on alpine)
15:12:25 <morgan_orange> #info python baseline image discussion to know if we keep (or not) the ONBUILD constraints
15:12:35 <morgan_orange> #info M5 Guilin Jira already there
15:13:02 <morgan_orange> #info we are late, some code activity did not start (robot helm chart, switch onap_tests /pythonsdk-tests,..integration of new tests...)
15:13:09 <morgan_orange> #info M4 is planned for mid september
15:13:17 <morgan_orange> #topic Maintenance releases
15:13:23 <morgan_orange> #info frnakfurt release note updated
15:13:34 <morgan_orange> #info elalto and frankfurt CI are fine
15:13:42 <morgan_orange> #topic Guilin
15:13:46 <morgan_orange> #info demo terraform
15:14:12 <morgan_orange> #info yoonsoon developp terraform/terragrunt scripts to simplify the deployement of the cloud infra to host ONAP
15:14:22 <morgan_orange> #info demo of the creation of the VM according to OOM reco
15:14:31 <morgan_orange> #info code will be shared in integration/terraform
15:14:45 <morgan_orange> #info no plan to go further - OOM scripts will be reused as such
15:14:58 <morgan_orange> #info wait for community feedback on resources creation
15:15:34 <morgan_orange> #info K indicates that Nokia considered this option but there were some issues linked to weird metadata management (VM spawning could take very long time and even get stuck)
15:15:44 <morgan_orange> #info function is possible to reduce the risk
15:15:59 <morgan_orange> #info demo of Amine (basic_clamp and basic_loop)
15:16:14 <morgan_orange> #info Amine shares the work done on python SDK to support clamp call
15:16:49 <morgan_orange> #info he developped the SDK part following the rules and quality constraints + a clamp Mock (in GO) + scenario (levergaing for the Moment Thierry's structure)
15:17:09 <morgan_orange> #info in the demo he was able to shows both use cases
15:17:37 <morgan_orange> #info basic clamp can be used to retrieve the existing loop, edit the rules,..it consists in a clamp CSIT test
15:18:13 <morgan_orange> #info basic_loop includes clamp in a more global usecase => deploy a VNF including VES agent then trigger loop condition and check that the loop is triggered
15:18:24 <morgan_orange> #topic AoB
15:18:54 <morgan_orange> #agreed VNF_API is now fully deprecated, you are allowed to remove the BNF_API based use cases in Master
15:19:11 <morgan_orange> #info Andreas detected blocking bugs in multicloud (using old version of MSB API)
15:19:29 <morgan_orange> #infoit shows that these features are not really tested (no integration tests) + no use case using it
15:19:44 <morgan_orange> #info extending the scope of tests is one of the ambition of the new SDK
15:19:47 <morgan_orange> #endmeeting