15:49:45 <morgan_orange> #startmeeting weekly integration meeting 9/9/2020
15:49:45 <collab-meetbot> Meeting started Wed Sep  9 15:49:45 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:49:45 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:49:45 <collab-meetbot> The meeting name has been set to 'weekly_integration_meeting_9_9_2020'
15:49:55 <morgan_orange> #topic Action point follow-up
15:50:17 <morgan_orange> #info AP1: Mike Eliott provide some date on the contribution in testsuite/cds repo
15:50:49 <morgan_orange> #ingo nagendra indicates  that they have still some dependeny issue with kafka prior to commit CDS tests
15:51:03 <morgan_orange> #info AP2: morgan_orange contact recent inactive committers to get their plans
15:51:06 <morgan_orange> #info done
15:51:14 <morgan_orange> #info AP3 all think to 2 or 3 new committers to replace inactive committers
15:51:30 <morgan_orange> #info no objection to initiate the procedure for Michal, Lukasz and Thierry
15:51:51 <morgan_orange> #action morgan_orange initiate committer promotion (xcheck with them first then initiate the procedure)
15:52:01 <morgan_orange> #info AP4 morgan create a LF IT ticket to clean first attempts on onap-integration
15:52:19 <morgan_orange> #info done, WIP..I do not have the expected menus
15:52:33 <morgan_orange> #info AP5: morgan send a mail to notify the new location of the daily and gating  results and optionnaly configure a redirection from the previous place
15:52:38 <morgan_orange> #info done + redirection active
15:52:44 <morgan_orange> #info morgan ask some feedback on clamp gating to clamp team
15:53:33 <morgan_orange> #info christophe indicates that they used it but they do not use it as much as they expect - clmap is small and mature and clamp team now moved to SDC and has no time to add tests
15:53:41 <morgan_orange> #info however it was useful
15:54:00 <morgan_orange> #info christophe moved SDC CSIT tests back to SDC, he would like to setup also gating on SDC in the future
15:54:13 <morgan_orange> #info subset of functionnal tests could be used for gating/daily
15:55:20 <morgan_orange> #info AP7: morgan_orange retrieve master versions, compare with frankfurt and ask  the PTL during the PTL meeting on their options (M4=code freeze supposed  to be mid of September..)
15:55:27 <morgan_orange> #info done, shared with PTL and the community
15:55:47 <morgan_orange> #link https://wiki.onap.org/display/DW/Guilin+Docker+version+follow-up
15:56:17 <morgan_orange> #info AP8: morgan shared the evolution on onap-discuss and wait for feedback
15:56:22 <morgan_orange> #info done 0 feedback
15:56:31 <morgan_orange> #info AP9 all give feedback on CI evolution for Guilin
15:56:34 <morgan_orange> #info see next section
15:56:44 <morgan_orange> #info AP10 bisjwajit initiate a thread offline integration / So / AAF flag / robot tests
15:56:52 <morgan_orange> #info mail not sent yet
15:56:56 <morgan_orange> #topic Admin
15:57:12 <morgan_orange> #info windriver lab status
15:57:29 <morgan_orange> #info no feedback on the performance issue, TSC took the point but no feedback since thursday
15:57:41 <morgan_orange> #info only feedback reported on power outage affecting the DC
15:57:46 <morgan_orange> #info power is back but no access
15:57:58 <morgan_orange> #info no feedback on lab stability => TSC issue
15:58:18 <morgan_orange> #info high risk that Integration team cannot provide labs neither for pairwise not use case support
15:58:34 <morgan_orange> #info info shared during last TSC with several mitigation scenario, no feedback so far
15:58:45 <morgan_orange> #info discussion with Pratik - patch on CI optimization (cache, depth in cloning, ..)
15:58:48 <morgan_orange> #info noshow
15:59:13 <morgan_orange> #info christophe indicates that some of his patches have eben merged on SDC (no regreesion)
15:59:33 <morgan_orange> #info in integration it triggers regressions (linting), wait for correction before being able to move forward
15:59:54 <morgan_orange> #info new committers: check with Michal, Lukasz and Thierry, if Ok launch promotion mechanism
16:00:07 <morgan_orange> #action morgan_orange contact new committers and initiate the procedure
16:00:20 <morgan_orange> #topic Guilin
16:00:28 <morgan_orange> #info several pages created on the wiki
16:00:43 <morgan_orange> #link https://wiki.onap.org/display/DW/Integration+G+Release
16:00:55 <morgan_orange> #info blocking points: https://wiki.onap.org/display/DW/Guilin+Integration+blocking+points
16:01:14 <morgan_orange> #info readiness page: https://wiki.onap.org/display/DW/Guilin+Readiness+dashboard, docker version tracking
16:01:30 <morgan_orange> #info use case follow-up (now JIRA based): https://wiki.onap.org/display/DW/Guilin+Use+case+follow-up
16:01:42 <morgan_orange> #info Master daily very ugly today
16:02:05 <morgan_orange> #link https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-09-2020_08-09/
16:02:10 <morgan_orange> #info better results yesterday
16:02:21 <morgan_orange> #link https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-07-2020_06-09/
16:02:37 <morgan_orange> #info only difference => move OOM from no limit to limits
16:02:53 <morgan_orange> #info let's see if issue is reproducible...not sure..
16:03:21 <morgan_orange> #info daily master in DT 100% OK (infra + healthcheck tests)
16:03:46 <morgan_orange> #info Nokia reported also possible race condition on DCAE side that lead to deployment issues
16:04:08 <morgan_orange> #action Krysztof create a jira to track cloudify/DCAE bootstrap race condition issue
16:04:19 <morgan_orange> #info Master weekly created (tun once a week)
16:04:32 <morgan_orange> #info first integration tests on versions and certificate in progress
16:05:44 <morgan_orange> #info CI chain evolution - list of use cases final cut
16:05:55 <morgan_orange> #info no objection to proposal from last week (shared by mail)
16:06:08 <morgan_orange> #agreed adopt guilin Ci evolution as described last week
16:06:21 <morgan_orange> #info ONAP tests to pythonsdk migration status
16:06:31 <morgan_orange> #info several patches merged (availability zone, multicloud)
16:06:46 <morgan_orange> #info Andreas has still some patches to merge (pb on AAI, Vendor creation using Yaml
16:07:13 <morgan_orange> #agreed, instantiation scenario shall be based on yaml file (at least for the VNF param)
16:07:20 <morgan_orange> #info SECCOM test follow up
16:07:30 <morgan_orange> #info review with AMY on the status of the security tests for Guilin
16:07:36 <morgan_orange> #info xfail list reset
16:07:46 <morgan_orange> #info versions soon available in weekly (Sunday)
16:07:59 <morgan_orange> #action morgan_orange initiate Jira to the projects for the different tests
16:08:10 <morgan_orange> #info question on who is responsible for the upstream ccomponents
16:08:19 <morgan_orange> #info if upstream attached to a project X => X
16:08:22 <morgan_orange> #info if generic => OOM
16:09:00 <morgan_orange> #action morgan_orange create bunch of JIRAs
16:09:05 <morgan_orange> #info pythonsdk basic_scenario shall be available soon (goal before the end of the week)
16:09:08 <morgan_orange> #endmeeting