14:38:34 <morgan_orange> #startmeeting weekly integration test 30/09/2020
14:38:34 <collab-meetbot> Meeting started Wed Sep 30 14:38:34 2020 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:38:34 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:38:34 <collab-meetbot> The meeting name has been set to 'weekly_integration_test_30_09_2020'
14:38:44 <morgan_orange> #topic action point follow-up
14:38:59 <morgan_orange> #link https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/integration_weekly_meeting_23_09_2020/onap-int-integration_weekly_meeting_23_09_2020.2020-09-23-14.56.html
14:39:13 <morgan_orange> #info AP1:      all review your JIRA and update, for M4 we should not have High  priority Jira opened for more then 36 hours, fix, or move them to  Honolulu
14:39:38 <morgan_orange> #info still to be done..review your JIRA, postpone the one that you will not be able to do for Guilin...close the ones done
14:39:46 <morgan_orange> #info AP2 michal see with Sylvain how to release the new version
14:39:51 <morgan_orange> #info done see next section
14:39:59 <morgan_orange> #info AP3: all complete the pythonsdk evolution etherpad
14:40:08 <morgan_orange> #info still shy, do not hesitate to complete...
14:40:28 <morgan_orange> #info AP4 morgan_orange morgan_orangecreate JIRA on GPLv3
14:40:29 <morgan_orange> #info done
14:40:44 <morgan_orange> #info note that xtesting & robot pods have also GPLv3 inside..
14:41:11 <morgan_orange> #info AP5 lasse sent a mail on onap-discuss + initiate a wiki page to help the reinsourcing of csit tests
14:41:17 <morgan_orange> #info done, see next topic
14:41:24 <morgan_orange> #topic Admin
14:41:51 <morgan_orange> #info windriver lab up&running and seems slow but stable => the cleanup of the 5 Integration labs seems to be enough to ensure a good level of stability
14:42:00 <morgan_orange> #info feel free to use the lab..
14:42:14 <morgan_orange> #info Auzre lab created, 8 people asked for an access to the lab
14:42:47 <morgan_orange> #info zoom bridge, ticket raised on the 24th of September, no real response yet, LF resources busy with ONES virtual event
14:42:57 <morgan_orange> #info use a public zoom for the demo
14:43:57 <morgan_orange> #topic Guilin
14:44:02 <morgan_orange> #info CSIT status
14:44:09 <morgan_orange> #info lasse initiated a wiki page
14:44:22 <morgan_orange> #link https://wiki.onap.org/display/DW/Moving+CSIT+to+project+repositories
14:44:42 <morgan_orange> #info CSIT as it is today has most of the time no sense. csdk tests are delaing with..dublin
14:44:50 <morgan_orange> #info PTL must revisit
14:45:10 <morgan_orange> #info morgan indictaes that such functional tests must be performed in the project repo..to avoid such maintenance issues
14:45:21 <morgan_orange> #info tests are triggered daily independently from code submission
14:45:58 <morgan_orange> #info gating extension on target env are real integration tests: on patch submission => docker obuilt on the fly => deployment + Test => feedback before merge
14:46:23 <morgan_orange> #info currently most of tests done on master => code need to be merged, no verification before merged
14:46:41 <morgan_orange> #indo SDC reinsourced such tests in their verify jobs
14:46:49 <morgan_orange> #info other projects shoudl do the same...
14:47:16 <morgan_orange> #action morgan lasse prepare a slide deck to share with PTL during PTL meeting in 2 weeks
14:47:26 <morgan_orange> #info CI status
14:47:36 <morgan_orange> #link https://logs.onap.org/onap-integration/daily/onap_daily_pod4_master/09-30-2020_07-09/
14:47:41 <morgan_orange> #info Ci pretty stable
14:48:14 <morgan_orange> #info issue with DCAE - race condition on slow labs? DCAE cannot be installed properly, problem reported by several labs
14:48:28 <morgan_orange> #info we should be careful and avoid the need of overcommited lab to make things work...
14:48:41 <morgan_orange> #link https://jira.onap.org/browse/DCAEGEN2-2457
14:48:58 <morgan_orange> #info SDNC/AAI issues also preventing End to End test to be fully completed
14:49:48 <morgan_orange> #link https://jira.onap.org/browse/SDNC-1371?src=confmacro
14:50:02 <morgan_orange> #info pythonsdk status
14:50:20 <morgan_orange> #info version 7.0.0 release this week (7.0.0 <=> Guilin)
14:50:40 <morgan_orange> #info new features: - Network instantiation
14:50:40 <morgan_orange> - SDC properties assignment
14:50:40 <morgan_orange> - SDC artifacts assignment
14:50:40 <morgan_orange> - PNF onboarding
14:50:40 <morgan_orange> - SO macro flow instantiation
14:50:41 <morgan_orange> - CLAMP closed loop instantiation
14:50:52 <morgan_orange> #info   - SDC properties assignment
14:50:59 <morgan_orange> #info - SDC artifacts assignment
14:51:06 <morgan_orange> #info - PNF onboarding
14:51:11 <morgan_orange> #info - SO macro flow instantiation
14:51:18 <morgan_orange> #info - CLAMP closed loop instantiation
14:51:40 <morgan_orange> #info pythonsdk = function to interact with ONAP != use cases
14:52:08 <morgan_orange> #info use cases are in pythonsdk-tests and potentially in other places, but pythonsdk-tests is used by integration to create use case leveraging pythonsdk
14:52:35 <morgan_orange> #info packaging done, the master version of xtestin-smoke-usecases-pythonsdk is now fully based on pythonsdk
14:52:57 <morgan_orange> #info old framework based on onap_tests is deprecated (was supporting only VNF_API which is fully deprectaed now)
14:53:04 <morgan_orange> #info docker available
14:53:22 <morgan_orange> #info demo how to run it and how to create your own use case based on pythonsdk
14:54:10 <morgan_orange> #info integration in CI in progress (shall be OK before the end of the week)
14:56:31 <morgan_orange> #info command to run basic_vm using xtesting docker run -v <path to your clouds.yaml>:/root/.config/openstack/clou
14:56:31 <morgan_orange> ds.yaml -v <path to your res dir>:/var/lib/xtesting/results --add-
14:56:31 <morgan_orange> host=portal.api.simpledemo.onap.org:<your cluster IP> --add-
14:56:31 <morgan_orange> host=vid.api.simpledemo.onap.org:<your cluster IP> --add-
14:56:31 <morgan_orange> host=sdc.api.fe.simpledemo.onap.org:<your cluster IP> --add-
14:56:31 <morgan_orange> host=sdc.api.be.simpledemo.onap.org:<your cluster IP> --add-
14:56:31 <morgan_orange> host=aai.api.sparky.simpledemo.onap.org:<your cluster IP> --add-
14:56:32 <morgan_orange> host=so.api.simpledemo.onap.org:<your cluster IP> --add-
14:56:32 <morgan_orange> host=sdnc.api.simpledemo.onap.org:<your cluster IP> --add-
14:56:33 <morgan_orange> host=mr.api.simpledemo.onap.org:<your cluster IP> --env-file env
14:56:33 <morgan_orange> nexus3.onap.org:10003/onap/xtesting-smoke-usecases-pythonsdk:master
14:56:39 <morgan_orange> #undo
14:56:39 <collab-meetbot> Removing item from minutes: #info command to run basic_vm using xtesting docker run -v <path to your clouds.yaml>:/root/.config/openstack/clou
15:21:38 <morgan_orange> #info docker run -v <path to your clouds.yaml>:/root/.config/openstack/clouds.yaml -v <path to your res dir>:/var/lib/xtesting/results --add-host=portal.api.simpledemo.onap.org:<your cluster IP> --add-host=vid.api.simpledemo.onap.org:<your cluster IP> --add-host=sdc.api.fe.simpledemo.onap.org:<your cluster IP> --add-host=sdc.api.be.simpledemo.onap.org:<your cluster IP> --add-host=aai.api.sparky.simpledemo.onap.org:<your cluster IP> --a
15:21:38 <morgan_orange> dd-host=so.api.simpledemo.onap.org:<your cluster IP> --add-host=sdnc.api.simpledemo.onap.org:<your cluster IP> --add-host=mr.api.simpledemo.onap.org:<your cluster IP> --env-file env nexus3.onap.org:10003/onap/xtesting-smoke-usecases-pythonsdk:master
15:21:51 <morgan_orange> #info with 2 mandatory variables in the env file
15:22:32 <morgan_orange> #info ONAP_PYTHON_SDK_SETTINGS=onaptests.configuration.ubuntu16_nomulticloud_settings & OS_TEST_CLOUD=onap-master-daily-vnfs-ci
15:22:40 <morgan_orange> #info Demo
15:23:01 <morgan_orange> #info pnf-registrate blocked by a bug
15:23:18 <morgan_orange> #info CMPv2 test in progress, evolution with pythonsdp possible in Honolulu
15:23:41 <morgan_orange> #info OOM issue reported by Bartek (CMPv2 evolution leads to issue on offline deployments)
15:23:50 <morgan_orange> #endmeeting