14:51:54 <morgan_orange> #startmeeting Integration weekly meeting 13/1/2021
14:51:54 <collab-meetbot> Meeting started Wed Jan 13 14:51:54 2021 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:51:54 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:51:54 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_13_1_2021'
14:52:00 <morgan_orange> #topic action point follow up
14:52:23 <morgan_orange> #info no remaining action points, last week meeting canceled (no quorum due to bank holidays)
14:52:30 <morgan_orange> #topic Honolulu
14:52:39 <morgan_orange> #info demo CDS regression tests
14:53:07 <morgan_orange> #info teh demo shows how Bell is performing CDS regression tests (CDS considered as a standalone component)
14:53:26 <morgan_orange> #link https://wiki.onap.org/display/DW/Integration+Meeting+Minutes?preview=/11930007/93006984/cds_regression_test.pdf
14:53:42 <morgan_orange> #info several mock services needed, tests done in parallel
14:53:55 <morgan_orange> #info ingress controller to run the tests to different CDS versions
14:54:18 <morgan_orange> #info CI based on gitrlab-CI - 6 stages pipeline including deployment/configuration (CDS)
14:54:47 <morgan_orange> #info tests = bash script running command on CDS with mock services for CDS <=> services emulation
14:54:54 <morgan_orange> #info looks feasible to include that in CI
14:55:02 <morgan_orange> #info ONAP integraiton CI/CD is based on gitlab
14:55:14 <morgan_orange> #info tests are // through xtesting dockers
14:55:38 <morgan_orange> #info Jozsef indicates that the repo shall be updated (upstream code no more up to date)
14:55:51 <morgan_orange> #action morgan_orange create CDS test Epic for Honolulu
14:56:06 <morgan_orange> #info review repo + Mock servcies, include cds code in xtesting docker
14:56:15 <morgan_orange> #info then give a try on a daily
14:56:58 <morgan_orange> #info cds regression tests coudl be added to healthcheck (as we are testing 1 component) or on smoke
14:57:19 <morgan_orange> #info note with pythonsdk a first test has been committed to enrich the CBA (and exposde the port)
14:57:50 <morgan_orange> #info second demo on DataFileCollector (DCAE feature)
14:58:09 <morgan_orange> #info copy/paste adaptation of what was available in ftp/sftp
14:58:21 <morgan_orange> #info new feature for http/https server (for the moment only http)
14:58:32 <morgan_orange> #info modification needed in integration
14:58:43 <morgan_orange> #info then enrichment of CSIT tests planed
14:59:07 <morgan_orange> #link https://gerrit.onap.org/r/c/integration/+/116574
14:59:21 <morgan_orange> #topic Guilin maintenance release
14:59:31 <morgan_orange> #info testsuiote 1.7.3 generated and available in the Nexus
14:59:40 <morgan_orange> #info change committed in OOM/guilin
15:00:02 <morgan_orange> #info note oom/testsuite is valid only up to Guilin (so commit done in Guilin branch directly)
15:00:20 <morgan_orange> #info for next release the chart is hosted back in oom to avoid circular dependency issues
15:21:55 <morgan_orange> #topic vEvent
15:22:03 <morgan_orange> #info several sessions planned for the next vEvent
15:22:29 <morgan_orange> #link https://wiki.lfnetworking.org/display/LN/2021+February+Developer+Topic+Proposals
15:22:35 <morgan_orange> #info for integration 3 sessions so far
15:23:01 <morgan_orange> #info session 1 with Alexander (scope LFN) introduction to Tern (dynamic licence scanning)
15:23:12 <morgan_orange> #aciton morgan_orange recontact Alexander and plan a status update
15:23:42 <morgan_orange> #info session 2: lessons learned and Honolulu plan
15:24:05 <morgan_orange> #info colelctive session, morgan_orangewill recontact the integration committers and plan to share the sessions with update on pythonsdk, CSI, labs,...
15:24:15 <morgan_orange> #info session3: updtae and stability resiliency
15:24:31 <morgan_orange> #info detail what has been done in guilin
15:24:39 <morgan_orange> #info new tests done by Natacha on // testing in SDC
15:24:47 <morgan_orange> #info a status shall be planned soon
15:24:55 <morgan_orange> #info first results seem to say that it is fine
15:25:21 <morgan_orange> #info the errors seen in CI due to parallel processing is not seen anymore even if the nulber of services accumulated becomes big
15:25:36 <morgan_orange> #action plan a update with Natacha on the last tests done
15:25:54 <morgan_orange> #info if any integration contributor woudl like to present another topic => fell free
15:25:57 <morgan_orange> #topic AoB
15:26:02 <morgan_orange> #endmeeting