16:06:44 <morgan_orange> #startmeeting Integration weekly meeting 20/01/2021
16:06:44 <collab-meetbot> Meeting started Wed Jan 20 16:06:44 2021 UTC and is due to finish in 60 minutes.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:44 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:06:44 <collab-meetbot> The meeting name has been set to 'integration_weekly_meeting_20_01_2021'
16:07:04 <morgan_orange> #topic action point follow up
16:07:19 <morgan_orange> #link https://ircbot.wl.linuxfoundation.org/meetings/onap-int/2021/integration_weekly_meeting_13_1_2021/onap-int-integration_weekly_meeting_13_1_2021.2021-01-13-14.51.html
16:07:32 <morgan_orange> #info AP1 morgan_orange create CDS test Epic for Honolulu
16:07:46 <morgan_orange> #info AP2 morgan_orange plan a update with Natacha on the last tests done
16:07:51 <morgan_orange> #info done see next topic
16:08:02 <morgan_orange> #topic admin
16:08:13 <morgan_orange> #info new repositories created
16:08:21 <morgan_orange> #info 3 mock repositories for cds regression tests
16:08:32 <morgan_orange> #info the chart shall be hosted with other chartq
16:08:46 <morgan_orange> #action morgan_orange contact OOM team to see where to host test charts
16:08:56 <morgan_orange> #info real time support chan
16:09:06 <morgan_orange> #info rocket chat will be closed end of January
16:09:12 <morgan_orange> #info recommendation is to move to slack
16:09:24 <morgan_orange> #info christophe initiated an internal exception procedure for ATT users
16:09:37 <morgan_orange> #info not possible to export/import rocket chat history in slack
16:09:55 <morgan_orange> #info but possible to save rocket chan history locally
16:10:23 <morgan_orange> #info local saving requires rocketchat application
16:10:28 <morgan_orange> #topic Honolulu
16:10:47 <morgan_orange> #info PNF demo postponed to next week (DT workshop today)
16:10:59 <morgan_orange> #info CSIT redesign update
16:11:11 <morgan_orange> #info lasse will update the status to PTL next Monday
16:11:48 <morgan_orange> #info light changes to remove the dependency to the nexus..as teh verificaiton/merge job is done in 1 job it is possible to reuse the locally built docker and not push docker in staging nexus
16:12:01 <morgan_orange> #info it simplifies the workflow and save CI/CD resources
16:12:26 <morgan_orange> #info presentation of the stability onboard tests performed beginning of january
16:12:47 <morgan_orange> #link https://wiki.onap.org/display/DW/Honolulu+stability+test+evolution
16:12:57 <morgan_orange> #info goal of 10 simultaneous onboarding seems OK
16:13:07 <morgan_orange> #info duration = f(nb // onboarding)
16:13:30 <morgan_orange> #info size of teh DB has no influence: onboarding series executed after lots of onbaording faster than first series
16:13:44 <morgan_orange> #info impossible to reproduce the race condition seen regularly in CI
16:13:56 <morgan_orange> #info possible to mix scenarios to try to reproduce the issue seen in CI
16:14:06 <morgan_orange> #info presnetation planned for the vEvent
16:25:41 <morgan_orange> #action christophe contact ATT operational team for KPI definitions (nb of simultaneous onboarding/instantation/loop/messages/;..) in order to build a realistic scenario
16:26:26 <morgan_orange> #info update on tern tests
16:26:47 <morgan_orange> #info alexander luanched tests + scan code on almost all the ONAP images used in the weekly aster lab
16:26:58 <morgan_orange> #info 80% contains GPLv3
16:27:34 <morgan_orange> #link https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/01-14-2021_00-01/tern-reports/
16:27:57 <morgan_orange> #info note some of the files are very big..so it takes time to open#info information of the components layer by layer
16:28:13 <morgan_orange> #info some images have an incredible number of layers..lots of space for optimization
16:28:39 <morgan_orange> #info GPLv3 python lib included in the baseline image provided by alpine
16:28:54 <morgan_orange> #action morgan_orange send a mail to PTL to explain that the results are available
16:29:14 <morgan_orange> #action alexander contact steve Winslow to clarify some legal issues
16:29:31 <morgan_orange> #info a presentation is planned in Plenary during the  vEvent on a feedback of dynamic scanning
16:30:26 <morgan_orange> #info thanks to docviz, it is also possible to visualize the links between the different dockers, it is very useful to see the different heritages..and identify which hardening could be the most useful
16:30:42 <morgan_orange> #link https://logs.onap.org/onap-integration/weekly/onap_weekly_pod4_master/01-14-2021_00-01/tern-reports/images-created-by2.png
16:30:59 <morgan_orange> #topic CI/CD
16:31:16 <morgan_orange> #info request from Xin Miao to redeploy SB00 on windriver
16:31:50 <morgan_orange> #action Krzysztof Kuzmicki ask Daniel if it is possible to redeploy SB-00 using the Nokia scripts used mid december
16:32:19 <morgan_orange> #info resiliency tests (backup and restore, disaster recovery,..) to be considered and initiated.
16:32:27 <morgan_orange> #info it is part of the presentation planned for the event
16:33:01 <morgan_orange> #info we are almost sure that ONAP today cannot survive the reboot of a worked node hosting pod with NFS storage...but evidence would eb nice to create JIRA
16:33:25 <morgan_orange> #info historically Gary introduced a test: test => delete pod => test => delete pod => test => .....to test the resiliency
16:33:52 <morgan_orange> #info it shall be easily reproducible by relaunching the basic_vm test as we did during the long duration test
16:34:18 <morgan_orange> #info short dev needed to list the pod, delete them, wait for recovery before re-launching the test
16:34:27 <morgan_orange> #info to be planned as part of resiliency activities
16:34:52 <morgan_orange> #info additionnaly nice k8s chaos monkey frameworks are available, if you are interested..please come back to me
16:35:42 <morgan_orange> #info one of the open question assuming that ONAP cannot survive some reboot... "why the k8s magic cannot apply.."
16:36:32 <morgan_orange> #info the cloudreadiness is not good enough..but with the last OOM improvement it should be better (especially the work on storage class)
16:36:45 <morgan_orange> #topic vEvent
16:37:15 <morgan_orange> #info 3 presentations for integration: docker dynamic scanning, stability/Resiliency, Integration lesson learned + Honolulu planned
16:37:29 <morgan_orange> #info first slide deck shared with commiters
16:38:29 <morgan_orange> #info the topics are: Lab support, Testcases, Pythonsdk, CI/CD, CSIT, Community and use case support, quality of code and simulators, stability&resiliency testing
16:38:47 <morgan_orange> #agreed bartek will ahev a look at the quality part (verification jobs)
16:39:38 <morgan_orange> #info additionnaly he will have a look at the existing simulators in order to get a good view on what is mature, can be promoted in future Honolulu doc (good doc needed)
16:39:56 <morgan_orange> #info Pawel indicates that there is no need for a dedicated security test topics => part of testcases
16:40:05 <morgan_orange> #info some refactoring needed on the existing security tests
16:40:09 <morgan_orange> #endmeeting