13:44:50 <kennypaul> #startmeeting TSC-July-13-2017
13:44:50 <collabot`> Meeting started Thu Jul 13 13:44:50 2017 UTC.  The chair is kennypaul. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:44:50 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:44:50 <collabot`> The meeting name has been set to 'tsc_july_13_2017'
13:45:22 <kennypaul> #chair phrobb, CaseyODL
13:45:22 <collabot`> Current chairs: CaseyODL kennypaul phrobb
14:01:27 <cdonley> #info Chris Donley, Huawei
14:01:37 <RannyHaiby> #info Ranny Haiby, Nokia
14:01:39 <gilbert> #info mazin gilbert, AT&T
14:01:57 <Rajesh-Intel> #info Rajesh Gadiyar Intel
14:02:05 <edwarnicke> #info edwarnicke
14:02:23 <Lingli_> #info Lingli Deng, China Mobile
14:02:29 <xinhuili> #info Xinhui Li, VMware
14:02:43 <Zhaoxing> #info Huabing Zhao, on behalf of Zhaoxing Meng, ZTE
14:02:56 <Jamil> hello
14:03:01 <munish> #info munish, Ericsson,proxy for Stephen
14:03:10 <JasonHunt> #info Jason Hunt, IBM
14:03:26 <Xiaojun> #info Xiaojun Xie, China Telecom
14:04:59 <kennypaul> #topic subcommittee election status
14:05:37 <kennypaul> #info small subcommittee that will be providing recommended charter changes next week
14:06:27 <kennypaul> #info one week for comment, and 2 days for TSC decision
14:06:37 <Liron> #proxy, Liron Shtraichman, amdocs
14:08:01 <kennypaul> #topic Amsterdam M1 Reviews
14:08:21 <kennypaul> #topic VID review
14:09:55 <kennypaul> #info form imcomplete
14:10:34 <kennypaul> #topic Logging Enhancements
14:11:46 <kennypaul> I just lost audio
14:12:20 <kennypaul> Need a member of the communbity to please take notes
14:12:31 <amir_levy> #info Amir Levy, GigaSpaces
14:16:35 <tykeal> we can make that mechanically enforced...
14:17:01 <kennypaul> back on audio
14:17:36 <kennypaul> #agreed review for logging approved
14:18:46 <kennypaul> #topic Application Authorization Framework
14:21:01 <kennypaul> #action -Varun update API section of
14:21:16 <kennypaul> #undo
14:21:16 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2694050>
14:21:27 <kennypaul> #action -Varun update API section of document
14:21:39 <kennypaul> #info checklist complete
14:23:42 <kennypaul> #info PTL needs to take an active roll in socializing AAF across the projects
14:23:59 <kennypaul> #agreed AAF review approved
14:24:11 <kennypaul> #topic DMaap
14:26:42 <kennypaul> #action Varun- update the API  section
14:27:03 <kennypaul> #info checklist complete
14:27:57 <kennypaul> #action varun- clean up contributor list
14:28:19 <kennypaul> #agreed DMaaP review approved
14:28:43 <kennypaul> #topic VNF Requirements
14:32:52 <kennypaul> #info Helen- unlikely for all VNF to be tested on this release
14:33:47 <kennypaul> #action -Steve Wright- meeting with other PTLs to understand deliverables.
14:36:40 <kennypaul> #info documentation created would be text files treated as code.
14:37:30 <kennypaul> #agreed VNF Requirements review approved
14:38:01 <kennypaul> #topic SDC
14:39:28 <kennypaul> #action - Eden fill in arch and API sections
14:39:56 <kennypaul> #info info exists, but be linked in
14:40:00 <bhedstrom> @kennypaul, was VNF Requirements passed? I don't recall hearing Gildas pass it
14:40:00 <collabot`> bhedstrom: Error: "kennypaul," is not a valid command.
14:40:13 <kennypaul> #info checklist complete within the next week.
14:40:56 <bhedstrom> kennypaul, was VNF Requirements passed? I don't recall hearing Gildas pass it
14:42:00 <kennypaul> #agreed SDC review approved w/ AI contingencies and an update on checklist in a week.
14:43:04 <kennypaul> #topic Developer Best Practices adoption\
14:47:36 <kennypaul> #info lironsh- question about the size of commits
14:48:47 <kennypaul> #info ed- recommend breaking up into themes
14:49:28 <kennypaul> #info andy- there is a draft feature which is not a commit. Drafts are private by default.
14:50:02 <kennypaul> #info -andy making drafts public needs to be approved by the TSC
14:51:48 <kennypaul> #info ed- recommends not enforcing % of code coverage
14:52:52 <kennypaul> #info helen- focus would be on new code
14:53:41 <edwarnicke> #info edwarnicke actually points out the dangers and tradeoffs of enforcing high code coverage bars to early, as it can lead to tests that mistakenly bake *bugs* into code, making it much harder to fix those bugs
14:57:42 <kennypaul> #info some of these best practices cover a subset of CII requirements
14:58:42 <phrobb> Shall the TSC approve the ONAP Development Best Practices as documented in the slide deck presented by Gildas? +1, 0, -1
14:59:00 <Lingli_> #vote +1
14:59:01 <gilbert> #vote +1
14:59:02 <kennypaul> #startvote Agreed the TSC approve the formalization of the proposed best practices, with the inclusion of making Drafts public, for ONAP #vote +1, 0 -1
14:59:02 <collabot`> Unable to parse vote topic and options.
14:59:04 <tykeal> phrobb: I think you're a chair
14:59:04 <Guest73002> +1
14:59:06 <amir_levy> #vote +1
14:59:07 <phrobb> #startvote Shall the TSC approve the ONAP Development Best Practices as documented in the slide deck presented by Gildas? +1, 0, -1
14:59:07 <collabot`> Begin voting on: Shall the TSC approve the ONAP Development Best Practices as documented in the slide deck presented by Gildas? Valid vote options are +1, 0, -1.
14:59:07 <collabot`> Vote using '#vote OPTION'. Only your last vote counts.
14:59:08 <munish> #vote +1
14:59:09 <edwarnicke> #vote +1
14:59:09 <Xiaojun> #vote +1
14:59:18 <cdonley> #vote +1
14:59:20 <Jamil> #vote +1
14:59:24 <Lingli_> #vote +1
14:59:30 <gilbert> #vote +1
14:59:38 <Guest73002> #vote +1
14:59:39 <JasonHunt> #vote +1
14:59:42 <Rajesh-intel> #vote +1
14:59:57 <phrobb> #endvote
14:59:57 <collabot`> Voted on "Shall the TSC approve the ONAP Development Best Practices as documented in the slide deck presented by Gildas?" Results are
14:59:57 <collabot`> +1 (10): Jamil, Xiaojun, Guest73002, JasonHunt, edwarnicke, cdonley, gilbert, Lingli_, Rajesh-intel, munish
15:00:19 <Rajesh-intel> #info I have to drop now
15:00:32 <phrobb> #agreed the Best Practices as presented by Gildas is approved by the TSC
15:01:56 <kennypaul> #topic July Virtual meeting
15:09:45 <kennypaul> #agreed DAYS: July 24, 25, 26 (Mon, Tue, Wed), TIMES: UTC noon-4PM / China 8PM-midnight / Eastern 8AM-noon / Pacific 5AM-9AM
15:09:59 <kennypaul> #endmeeting