#onap-meeting: July2017Face2Face

Meeting started by phrobb at 12:05:08 UTC (full logs).

Meeting summary

  1. Dependency Validation (phrobb, 12:05:43)
    1. Alla Goldner, Amdocs (alla, 12:05:47)
    2. Stephen Terrill, Ericsson (SteveT, 12:06:09)
    3. Gildas shared the dependancies between the projects based on the project release reviews (SteveT, 12:09:03)
    4. it was commented that there is no holmes to clam direct link (SteveT, 12:11:21)
    5. that was no holmes to clamp direct link (not clam) (SteveT, 12:11:51)
    6. ACTION: gildaslanilis to update the graph to reflect that Holmes and CLAMP do not have a direct link (phrobb, 12:12:10)
    7. ACTION: gildaslanilis to also check the source (project release) (SteveT, 12:13:22)
    8. Question was rasied whether the dependancies are in the form of an API. This was confirmed and that the API should be documented in the M2 milestone (SteveT, 12:17:15)
    9. SDNC should have a dependency on multi-vim (SteveT, 12:19:01)
    10. There was a question regarding the double dependancies and whether that is an issue. It was recomended that the teams with double depencies communite to understand whether there are issues (SteveT, 12:21:31)
    11. There was a question about should we have a dependancy id to be used later in the release planning activities (SteveT, 12:22:30)
    12. Looking at the interface is also part of the architecture sub-committee charter (SteveT, 12:23:51)
    13. there was a question about whether its possible to add a link to each API description in the graph. The answer from Gildas was that he recognized the value, but wasn't sure how it could be done and is open to suggestions on how (SteveT, 12:26:47)
    14. Question. Is the external API only dependant on SO? PLease check (SteveT, 12:28:20)
    15. Add dependancy on holmes and DCAE (SteveT, 12:28:41)
    16. ACTION: #gildaslinus to add holmes and DCAE dependancy (SteveT, 12:29:25)
    17. Amir Levy Gigaspaces/Cloudify (amir_levy, 12:31:43)
    18. ACTION: gildaslanilis to research if SDC has a dependency on Portal FW (phrobb, 12:33:06)
    19. ACTION: gildaslanilis to capture dependencies as part of the M2 checklist (phrobb, 12:35:41)

  2. Release Status, Release Process and Scrum Board Usage (phrobb, 12:36:23)
    1. gildaslanilis described the overall status of the planned epics from information obtained from jira, as well the tasks and subtasks (SteveT, 12:39:59)
    2. Gildas asked whether there were any questions or concenrs on the graphs. (SteveT, 12:46:44)
    3. I'd like to hear more discussion on this topic. My impression, based on meeting schedules, is that there was a lot of activity happening, but the graphs seem to indicate otherwise? (SteveT, 12:47:02)
    4. my impression from some of the meetings I've participated in is that there are activities around planning, aligning with architecture, use cases etc. and less the actual development at this point, this probably explains (alla, 12:48:28)
    5. most of the use cases related discusions has already completed (alla, 12:49:26)
    6. there are still some remaining issues though (alla, 12:50:11)
    7. we have R1 architecture since last week only (alla, 12:52:32)
    8. we need to make sure that all involved projects are aligned on this architecture view (alla, 12:52:53)
    9. Gildas requested whether there was belief that we can make it. It was pointed out that the next milestone was 3rd August, which is functionality freeze. It felt it was reasonabil.e (SteveT, 12:53:05)
    10. as, when we approved projects, some of them were approved conditionally depending on the architecture, once agreed (alla, 12:53:32)
    11. There is architecture meeting tomorrow and the project scope discussion can handle there (SteveT, 12:57:06)
    12. Gildas described "what is M2" (SteveT, 12:58:02)
    13. Gildas requested PTLs to fill in checklist for the next milestone (SteveT, 13:00:41)
    14. It was suggested that we should finalize the components that are used by many others first. (SteveT, 13:02:56)
    15. question about the dependencies on the open-o nexus repo. Info that was to be closed, but the code will remain accessible. Relivant code should be moved into ONAP repositories. (SteveT, 13:16:10)
    16. Question about when is FOSSology available on LF infra. The answer is that FOSSology has already be run on the current code base, and feedback is expected in the next 1-2 weeks. It was clarified that the FOSSology scan is done monthly . (SteveT, 13:17:55)
    17. There was a question about the software packing of our deliverables, docker images, deb, rpm etc. The answer was that the expectation was docker images (SteveT, 13:20:07)
    18. If there are changes in the API after api freeze, this may have to be done, but it is important to communicate this. It was suggested that API changes after M3 are lifted to the TSC for communication purposes at least (SteveT, 13:24:48)
    19. TSC would be grateful for information regarding implications of the API change when this is requested (SteveT, 13:26:41)
    20. when disucssing the APIs, it was questioned whether it also goes to YANG models as well. the answer was yes. (SteveT, 13:32:34)
    21. gildas introduced the scrumboard. (SteveT, 13:32:48)

  3. Release Versioning (SteveT, 14:04:09)
    1. oliver lead a discusson in release versioning (SteveT, 14:05:37)
    2. Symentic version is assumed as a way to express the versions (SteveT, 14:05:59)
    3. Helen version can be defined in o-parent project (SteveT, 14:08:29)
    4. proposal to have an overall release, and that each project/repo can have independant values that are tied to the main release (and can be independantly released) (SteveT, 14:18:52)
    5. correction: independantly stepped (SteveT, 14:19:08)
    6. Gildas asked about a manifest file (SteveT, 14:24:50)
    7. The conclusion for the versioning is : Each project decides its own versioning per project and/or repo. Then an overall version is captured in o-parent. This was with inline with the proposal on the additional page, and was considered to be a baseline. Oliver will further describe this properly and bring it to the TSC. (SteveT, 14:33:24)
    8. ACTION: Oliver to expand on the description of the release versioning and bring it to the TSC (SteveT, 14:36:18)
    9. While this enables a independant releases schedules per project/repo, that is not the intention at this time (SteveT, 14:38:41)

  4. . Security Review (kennypaul, 14:41:49)
    1. looking for a volunteer project for CII badging (kennypaul, 14:48:24)
    2. (Roberto KUNG) "Comment on vulnerability team: Ruan He from Orange has also volunteered" (kennypaul, 14:49:15)
    3. CLAMP volunteered as a pilot (kennypaul, 14:52:42)
    4. show of hands 12 people prefer maturity model (kennypaul, 14:55:00)
    5. FLOSS vs. FOSS the same in the eyes of this project (kennypaul, 15:00:34)
    6. (Helen) what level of code coverage are we comfortable with for each project? (kennypaul, 15:05:05)
    7. need to have common sense procedures (kennypaul, 15:06:05)
    8. introduced static code scanning concepts (kennypaul, 15:07:09)
    9. (Catherine LeFfevre) I have put some suggested tools on the wiki page (kennypaul, 15:08:27)
    10. https://wiki.onap.org/display/DW/ONAP+Vulnerability+Management (kennypaul, 15:08:27)
    11. PKI needs to be discussed further by team (kennypaul, 15:11:46)
    12. (Catherine LeFfevre) it would be great to integrate with Jenkins so it part of our CI/CD suite (kennypaul, 15:13:08)

  5. E2E Test Cases (kennypaul, 15:14:32)
    1. need more specific definition of "similar labs" on slide 2 (kennypaul, 15:16:53)
    2. delivery of vendor HW is at risk. (kennypaul, 15:21:20)


Meeting ended at 16:03:50 UTC (full logs).

Action items

  1. gildaslanilis to update the graph to reflect that Holmes and CLAMP do not have a direct link
  2. gildaslanilis to also check the source (project release)
  3. #gildaslinus to add holmes and DCAE dependancy
  4. gildaslanilis to research if SDC has a dependency on Portal FW
  5. gildaslanilis to capture dependencies as part of the M2 checklist
  6. Oliver to expand on the description of the release versioning and bring it to the TSC


Action items, by person

  1. gildaslanilis
    1. gildaslanilis to update the graph to reflect that Holmes and CLAMP do not have a direct link
    2. gildaslanilis to also check the source (project release)
    3. gildaslanilis to research if SDC has a dependency on Portal FW
    4. gildaslanilis to capture dependencies as part of the M2 checklist
  2. UNASSIGNED
    1. #gildaslinus to add holmes and DCAE dependancy
    2. Oliver to expand on the description of the release versioning and bring it to the TSC


People present (lines said)

  1. SteveT (43)
  2. kennypaul (19)
  3. alla (10)
  4. phrobb (7)
  5. collabot (5)
  6. Catherine_ (3)
  7. sakth (2)
  8. JasonHunt (1)
  9. amir_levy (1)
  10. Lusheng (1)
  11. gildaslanilis (0)


Generated by MeetBot 0.1.4.