#onap-meeting: tsc 2018-01-04

Meeting started by kennypaul at 13:47:04 UTC (full logs).

Meeting summary

  1. rollcall (kennypaul, 13:48:30)
    1. Frank Brockners, Cisco (will be on IRC only for the first 30min) (frankbrockners, 14:00:33)
    2. Jason Hunt, IBM (JasonHunt, 14:01:26)
    3. Alla Goldner, AMDOCS (kennypaul, 14:01:27)
    4. Dhananjay Pavgi, Tech Mahindra (DhananjayPavgi, 14:01:41)
    5. Ranny Haiby, Nokia (RannyHaiby, 14:01:52)
    6. Chris Donley Huawei (cdonley, 14:02:26)
    7. Filipe_ (Filipe_, 14:02:54)
    8. Filipe Caetano (Coriant) (Filipe_, 14:03:18)
    9. Zhaoxing Meng, ZTE (Zhaoxing, 14:03:33)
    10. Rajesh Gadiyar Intel (RajeshGadiyar, 14:03:46)
    11. Munish, Proxy for Stefen Terrill, Ericsson (munish, 14:05:04)
    12. Xinhui Li, VMWare (kennypaul, 14:09:19)
    13. Lingli Deng, CMCC (kennypaul, 14:09:46)
    14. jamil for Orange (jamil, 14:09:53)

  2. housekeeping (kennypaul, 14:11:10)
    1. collaboration dates. (kennypaul, 14:11:33)
    2. virtual meeting week of Feb 5th. (kennypaul, 14:12:42)
    3. ACTION: kenny coordinate VF2F (kennypaul, 14:13:06)
    4. more days rather than longer hours. (kennypaul, 14:13:58)
    5. my vote representing Alla Goldner (kennypaul, 14:17:14)
    6. my vote is on behalf of Xinhui (phrobb, 14:18:23)
    7. VOTE: Voted on "Does the TSC confirm the election of Pam Dragosh as the Chair of the Control-Loop Subcommittee?" Results are, +1: 12 (kennypaul, 14:18:51)

  3. multi-cloud confirmation vote. (kennypaul, 14:19:57)
    1. phrobb vote is on behalf of Xinhui (phrobb, 14:21:48)
    2. my vore representing Alla Goldner (kennypaul, 14:22:19)
    3. gildas lanilis voted on behalf of Lingli (gildaslanilis, 14:23:10)
    4. VOTE: Voted on "Does the TSC confirm the promotion of Liang Ke as a committer on the Multi-Cloud project?" Results are, +1: 12 (kennypaul, 14:23:26)

  4. TSC Election Process (phrobb, 14:24:59)
  5. Release Status (Beijing) (phrobb, 14:30:02)
    1. gildaslanilis reviewed the Project Proposal status for new projects wanting to join the ONAP project (phrobb, 14:31:06)
    2. Container Based Network Service/Function Deployment is going back to Arch committee next week (phrobb, 14:31:51)
    3. "Image Manager" project is recommended to put under the A&AI project (phrobb, 14:33:06)
    4. gilbert Notes that we need to ensure that the A&AI project scope is not enlarged by inclusion of this new project (phrobb, 14:34:08)
    5. Run-Time Catalog project Has had advice to talk to SDC project for possible inclusion. They will talk next week (phrobb, 14:40:17)
    6. Certificate and Secret Mgmt Service - This project has outstanding questions still (phrobb, 14:41:04)
    7. ONAP Benchmark project has been approved to be a subproject of 'Integration" (phrobb, 14:42:13)
    8. Open Source Access Mgmt - still need to go back to Arch. committee. (phrobb, 14:43:55)
    9. Distributed KV Store - The recommendation was to join another project. No further info known at this time (phrobb, 14:44:33)
    10. CHAP (Now known as MUSIC) Presented to Arch this week. (phrobb, 14:45:47)
    11. Centralization & Externalization of Parser Distribution - Is being discussed as part of Functional Requirement for Beijing in Use Case subcommittee. This is likely not going to be a separate project request (phrobb, 14:47:51)
    12. Amir Levy Cloudify (amir_levy, 14:48:10)
    13. gildaslanilis reviews the upcoming Beijing milestones. (phrobb, 14:48:22)
    14. Gildas notes that the TSC approved OOM as the main method for ONAP deployment. The question of support, or level of support for Heat Templates is still open. (phrobb, 14:50:55)
    15. gilbert notes that we may be supporting OOM as primary with Heat as a secondary (deprecated) deployment method for Beijing, and have it removed from support in Cassablanca and beyond (phrobb, 14:52:32)
    16. The question is really to the Integration team on what they can support for Beijing testing of deployment methods (phrobb, 14:52:53)
    17. Gildas asks on the regard of upgrading from Amsterdam to Beijing. What is the TSC stance on any support from Amsterdam to Beijing. (phrobb, 14:54:27)
    18. TSC consensus is that no upgrade path will be required from Amsterdam to Beijing. For Beijing and beyond, upgrade mechanisms need to be in place (phrobb, 14:59:43)
    19. the Arch committee is requested to start a sub-team now to create a recommendation on upgrades for Beijing and beyond (phrobb, 15:00:34)
    20. It is noted that OOM has migration capabilities. Hence work on migration needs to include OOM has part of the plans/discussions (phrobb, 15:01:39)
    21. Gildas asks TSC to vote on the request to make the Fix and Affect version fields in Jira mandatory. (phrobb, 15:02:38)
    22. Some questions on the impact to PTLs with this change (phrobb, 15:04:53)
    23. Key point is that at defect creation we don't know if the bug was found in Amsterdam or Beijing and what the request is. Having that info is very helpful, hence the request (phrobb, 15:06:11)
    24. Noted that more should be heard from the PTLs because this impacts them with a level of effort. (phrobb, 15:06:56)
    25. Noted that the Affect field should be mandatory on creation so that the project/PTL knows what is affected. (phrobb, 15:08:31)
    26. AGREED: the TSC notes that the Affect field is mandatory for bugs submitted at creation and the Fix field is mandatory at progress/transition (phrobb, 15:11:19)
    27. API Stability - Noted in discussion that the Docs project can oversee a more defined set of guidelines for use/delivery of Swagger in Beijing (phrobb, 15:12:50)
    28. Gildas walks through the Amsterdam bugs fixed that are targeted for SR1 (phrobb, 15:13:56)

  6. Platform Maturity (S3P) Requirements Update (kennypaul, 15:16:31)
    1. JasonHunt reviewed his slides (kennypaul, 15:17:04)
    2. some additional input is required for resiliency & scalability (kennypaul, 15:18:25)
    3. requesting guidance from the Benchmark team on areas such as tooling that can be leveraged by others (kennypaul, 15:20:53)
    4. Manageability is more focused on consolidated logging rather than user experience at this time. (kennypaul, 15:22:53)

  7. MUSIC (formerly named CHAP) Project Proposal (kennypaul, 15:25:18)
    1. Bharath reviewed the proposal (kennypaul, 15:25:50)
    2. https://wiki.onap.org/display/DW/MUSIC-Multi-site+State+Coordination+Service (kennypaul, 15:26:11)
    3. primary role is to coordinate states across sites. (kennypaul, 15:31:47)
    4. review has been approved by the Arc-Subcommittee. (kennypaul, 15:32:35)
    5. would like to understand what the specific S3P deliverable would be. (kennypaul, 15:33:49)
    6. need to classify as MVP or not (kennypaul, 15:35:38)

  8. OOM and AAI committer promotions (kennypaul, 15:37:30)
    1. email vote for both Boris [oom] and Venkata [aai] were approved. (kennypaul, 15:38:12)


Meeting ended at 15:38:24 UTC (full logs).

Action items

  1. kenny coordinate VF2F


People present (lines said)

  1. kennypaul (41)
  2. phrobb (33)
  3. collabot (15)
  4. jamil (3)
  5. JasonHunt (3)
  6. cdonley (3)
  7. DhananjayPavgi (3)
  8. munish (3)
  9. RannyHaiby (3)
  10. Zhaoxing (3)
  11. Ning (2)
  12. Filipe_ (2)
  13. gildaslanilis (2)
  14. RajeshGadiyar (2)
  15. gilbert (2)
  16. frankbrockners (1)
  17. amir_levy (1)


Generated by MeetBot 0.1.4.