#onap-meeting: tsc 2018-02-22

Meeting started by kennypaul at 14:01:05 UTC (full logs).

Meeting summary

    1. Rajesh Gadiyar Intel (Rajesh_, 14:01:24)
    2. proxy Pamela Dragosh, AT&T (Pamela_, 14:01:31)
    3. Frank Brockners, Cisco (frankbrockners, 14:01:33)
    4. Jason Hunt, IBM (JasonHunt, 14:01:36)
    5. Xinhui Li (xinhuili, 14:01:48)

  1. Roll call and Agenda Bashing (phrobb, 14:01:57)
    1. Chris Donley Huawei (cdonley, 14:02:06)
    2. Xinhui Li, VMware (xinhuili, 14:02:07)
    3. Dhananjay Pavgi, Tech Mahindra (kennypaul, 14:03:51)
    4. Stephen Terrill, Ericsson (SteveT, 14:04:06)
    5. Lingli Deng, CMCC (kennypaul, 14:04:06)
    6. Xiaojun Xie, China Telecom (Xiaojun, 14:04:26)
    7. David Sauvageau, Bell (davidsauvageau, 14:05:20)
    8. Zhaoxing Meng, ZTE (Zhaoxing, 14:05:37)
    9. Ning So, Reliance Jio (ningso, 14:05:39)
    10. jamil for Orange (jamil, 14:05:41)
    11. ACTION: kennypaul check on availability of a room @ons for tsc meeting (kennypaul, 14:10:27)
    12. backup plan teleconf or ptl meeting (kennypaul, 14:10:53)
    13. CLAs to be distributed shortly. Must be signed by all developers and companies (kennypaul, 14:15:13)
    14. developers will be locked out if not signed begining march 20. (kennypaul, 14:15:35)

  2. Release status (kennypaul, 14:15:51)
    1. sdc, multicloud and usecaseui have completed all necessary info for M2 (kennypaul, 14:18:38)
    2. AGREED: these 3 projects pass M2 (kennypaul, 14:19:38)
    3. working on committer access lists in repos (kennypaul, 14:21:04)
    4. proposal to provide an exception for javascript code coverage for the beijing release (kennypaul, 14:24:12)
    5. concerns over how exception would be handled? (kennypaul, 14:26:42)
    6. LFIT to look at "ignoring" javascript (kennypaul, 14:32:00)
    7. ACTION: LFIT to look at "ignoring" javascript (kennypaul, 14:32:26)
    8. pypi repo up, but working on templates (kennypaul, 14:33:40)
    9. how to manage javascript exception TBD (kennypaul, 14:38:03)
    10. sonar security tracking (kennypaul, 14:38:49)
    11. PTLs need to LOGIN and then drill down to see these. (kennypaul, 14:40:07)
    12. discussion on vulnerability and including / use of libs (kennypaul, 14:43:45)
    13. exception list would need to be approved by TSC prior to release (kennypaul, 14:44:18)
    14. ACTION: SteveT to provide a write up for PTL meeting (kennypaul, 14:44:54)
    15. ACTION: Pamela_ to provide an example for other teams to review (kennypaul, 14:45:58)
    16. more coordination needed across projects due to upstream dependencies blocking downstream projects. (kennypaul, 14:48:35)

  3. 2018 plans TSC look into the link provided. (kennypaul, 14:54:05)
  4. architecture update (kennypaul, 14:54:47)
    1. 11 comments from the TSC 10 addressed. (kennypaul, 14:55:24)
    2. last team to close with still on holiday (kennypaul, 14:55:44)

  5. static code scanning w/ Coverity (kennypaul, 14:56:48)
    1. looking for a volunteer project to link into ci/cd to test drive this (kennypaul, 14:57:57)
    2. need to understand what the results would be. (kennypaul, 14:58:30)
    3. make make sense for java and non java (kennypaul, 14:59:00)
    4. AGREED: OOF to volunteer for pilot. (kennypaul, 14:59:40)
    5. concern over whether found issues will be fixed for beijing. (kennypaul, 15:03:38)
    6. Sastry Isukapalli from OOF is the contact for pilot (kennypaul, 15:04:08)
    7. seshu and steve to talk off line (kennypaul, 15:06:36)

  6. LFN Compliance (kennypaul, 15:06:57)
    1. Chris shared slides provided (kennypaul, 15:08:34)

  7. vvp (kennypaul, 15:23:02)
    1. vvp project will remain (kennypaul, 15:24:25)
    2. project for validation scripts (kennypaul, 15:24:42)
    3. meetings will restart (kennypaul, 15:25:06)
    4. was ot part of amsterdam, and there have been no code changes. (kennypaul, 15:27:11)
    5. discussion (kennypaul, 15:31:21)
    6. desire from community for inclusion fo vvp in beijing (kennypaul, 15:32:00)
    7. vvp is not dependendent on any other onap component (kennypaul, 15:32:26)
    8. more discussion next week. (kennypaul, 15:34:12)

  8. etsi meeting (kennypaul, 15:34:30)
    1. Deng requests thaa any comments regarding laison letter be provided asap. (kennypaul, 15:35:58)


Meeting ended at 15:36:09 UTC (full logs).

Action items

  1. kennypaul check on availability of a room @ons for tsc meeting
  2. LFIT to look at "ignoring" javascript
  3. SteveT to provide a write up for PTL meeting
  4. Pamela_ to provide an example for other teams to review


Action items, by person

  1. kennypaul
    1. kennypaul check on availability of a room @ons for tsc meeting
  2. Pamela_
    1. Pamela_ to provide an example for other teams to review
  3. SteveT
    1. SteveT to provide a write up for PTL meeting


People present (lines said)

  1. kennypaul (52)
  2. jamil (4)
  3. collabot_ (4)
  4. xinhuili (2)
  5. davidsauvageau (1)
  6. frankbrockners (1)
  7. Rajesh_ (1)
  8. ningso (1)
  9. phrobb (1)
  10. JasonHunt (1)
  11. SteveT (1)
  12. Pamela_ (1)
  13. cdonley (1)
  14. Xiaojun (1)
  15. Zhaoxing (1)
  16. gildaslanilis (0)


Generated by MeetBot 0.1.4.