#onap-meeting: tsc-2018-03-29

Meeting started by kennypaul at 14:08:18 UTC (full logs).

Meeting summary

    1. Stephen Terrill, Ericsson (SteveT, 14:09:05)
    2. TSC members please #info in (phrobb, 14:09:07)
    3. Frank Brockners (frankbrockners, 14:09:17)
    4. Huabing Zhao on behalf of Zhaoxing Meng, ZTE (Huabing_Zhao, 14:09:42)
    5. Ranny Haiby, Nokia (RannyHaiby, 14:10:08)

  1. Casablanaca theme (SteveT, 14:13:57)
  2. Casablanca architecture and requirements (phrobb, 14:14:00)
    1. proposed theme is deployability (SteveT, 14:14:41)
    2. topics - technical debt, modularity, 5G fundamentals (SteveT, 14:15:22)
    3. modularity, standards alignment, micro services, vnf/pnf, s3p, containers, external controllers (SteveT, 14:16:48)
    4. standards alignment (SteveT, 14:17:14)
    5. there was a question about vfc, appc, so, is that addressed. The answer is that It’s in the modularity and microservices (SteveT, 14:18:34)
    6. the above is food for thought from UC and Architecture (SteveT, 14:19:19)
    7. Xinhui Li, VMware (xinhuili, 14:21:05)
    8. proxy Marc-Alexandre Choquette, Bell Canada (ma_c, 14:21:18)
    9. there was a comment that its more than modularity, but also optional it’s (SteveT, 14:21:39)
    10. There was comments about the usability (SteveT, 14:26:25)
    11. that the usability has to improve. The learning curve is too high. This is both technical and documentation (SteveT, 14:27:29)
    12. it was raised edge cloud computing, which is necessary for 5G, and osm (SteveT, 14:28:22)
    13. It was commented that the operators need to drive (SteveT, 14:29:40)
    14. It is proposed that we have an end-user advisory committee. (SteveT, 14:30:30)
    15. the proposed staffing of the end-user advisory committee is the likes of product managers that own/deploy onap (SteveT, 14:31:43)
    16. proposed knowledge sharing (SteveT, 14:33:57)
    17. weekly webinars requested from members (kennypaul, 14:34:01)
    18. it was informed by phill that there is a LFN wide end-user advisory committee, that has workgroups. This would fit into a workgroup under that (SteveT, 14:35:03)
    19. one question raised is what is the right state for what components (SteveT, 14:36:30)
    20. proposal to get a onap focus end-user group, that could be considered a workgroup under LFN end-user. It should be operator focused, but vendor still not excluded (SteveT, 14:43:26)
    21. proposed to do this under the LFN structure. The members need to sign a form saying they know they are speaking in public, etc. Phil can initiate this. Mazin said within a week he can get a number of operators to join this (SteveT, 14:49:33)
    22. On the topic of webinars. The education committee is going to lead. Looking for the entire community. Suggested weekly. (SteveT, 14:53:16)
    23. request for clarify of the milestone details at M1 (SteveT, 15:03:42)

  3. Casablanca planning (SteveT, 15:04:36)
    1. https://wiki.onap.org/plugins/servlet/mobile?contentId=3246393#content/view/3246393 (SteveT, 15:05:34)
    2. Gildas presented the draft time plan (SteveT, 15:06:23)
    3. proposed time line M0 5/25, M1 6/28, m2 7/26, M3 8/30, M4 9/20, release 11/15 (kennypaul, 15:07:06)
    4. new projects before the Beijing meeting (SteveT, 15:07:58)
    5. this is already sent out. 1 week to socialize this, approval is on the next Thursday meeting (SteveT, 15:08:40)
    6. ACTION: kenny add sched approval to next week's agebda (kennypaul, 15:09:44)

  4. M4 review (kennypaul, 15:09:59)
    1. gildas shared his slide deck (kennypaul, 15:10:49)
    2. items covered FOSS, Vulnerability template (kennypaul, 15:12:19)
    3. findings are to be shared ayt next week's meeintg (kennypaul, 15:12:46)
    4. item covered CII badging , code coverage, pending commits, csit failures (kennypaul, 15:14:28)
    5. portal updates required regarding music. (kennypaul, 15:18:50)
    6. cli -no ptl (kennypaul, 15:19:37)
    7. , portal cli, holmes, msb, music.vid. integration, doc passed (kennypaul, 15:21:08)
    8. clamp integration ongoing (kennypaul, 15:21:53)
    9. vnfrqts no ptl (kennypaul, 15:22:35)
    10. aai - integration with aaf garphadm=in not done pass otherwise. (kennypaul, 15:23:15)
    11. policy stretch goal targetred for RC0 pass otherwise (kennypaul, 15:24:19)
    12. oom some stories will bw completed during integration. CLM visibility -gildas will follow up. (kennypaul, 15:25:19)
    13. some projects haven’t done their conversion to help for OOM, this needs to be done quickly. Message-router is expected ina couple of days. (SteveT, 15:30:23)
    14. integration priority message-router , dcae, sdnc, nmultivim, vfc (kennypaul, 15:32:23)
    15. OOF function development is undergoing (xinhuili, 15:34:54)
    16. multicloud - azsure postponed to future relase (kennypaul, 15:35:12)
    17. vfc (kennypaul, 15:35:30)
    18. risk etsi nfv compliance will take conversation offline (kennypaul, 15:36:16)
    19. oof a couple csit failures but pass otherwise (kennypaul, 15:36:52)
    20. appc ode coverage 48.7 %, (kennypaul, 15:37:20)
    21. mariadb descoped (kennypaul, 15:37:33)
    22. sdc short of code coverage, (kennypaul, 15:39:17)
    23. vnfsdk short on some code coverage, LFIT tickets to address some issues. (kennypaul, 15:39:53)
    24. code was merged at 8:09 this morning (kennypaul, 15:40:17)
    25. itools and dovetail done (kennypaul, 15:42:45)
    26. code coverage passed at 3am this morning (kennypaul, 15:43:42)
    27. ccsdk/storage/pgaas repo is not used in Beijing. Code has been removed and sonar data has been updated (djtimoney, 15:43:49)
    28. ccsdk (kennypaul, 15:44:04)
    29. mariadb descoped (kennypaul, 15:44:41)
    30. sdnc code coverage (kennypaul, 15:45:10)
    31. code came in to late and will be cut (kennypaul, 15:45:42)
    32. logging only python delivered in beijing (kennypaul, 15:46:54)
    33. Issues with sonar running python - LF looking into it
need to up the version on oparent to fix one of the builds the docker build fails because we have no required docker yet logging java stub - I will add tests on the weekend - there is no API yet - slated for Cassablanca
python library from multicloud team - thanks - either they or myself will add tests
vulnerability is standard elk ports (kennypaul, 15:48:17)
    34. modeling code coverage short, requestoign2 extra weeks to complete code coverage for java parser (kennypaul, 15:49:17)
    35. usecase ui no templates vulnerabilituy, cii, clm, code coverage short (kennypaul, 15:50:59)
    36. externalapi no templates vulnerabiliuty, cii, code coverage 0 (kennypaul, 15:52:29)
    37. eric says coverage will be provided my RC0 - does not pass M4 (kennypaul, 15:55:12)
    38. dmaap no vulnerability, 2 gpl licenses, gpl to be addresses by RC0 (kennypaul, 15:56:35)
    39. does not pass M4 (kennypaul, 15:56:54)
    40. aaf vi=vulnerabilit y tmeplate not done, code coverage not met, very late code contributions, fails csit (kennypaul, 15:58:27)
    41. aaf subproject ok, (kennypaul, 15:58:42)
    42. from randa APPC has dependency on AAF for feature AAF-91 (kennypaul, 15:59:08)
    43. catherise want this aaf to be escalated (kennypaul, 16:00:10)
    44. does not pass M4 and is a critica issue (kennypaul, 16:00:27)
    45. vvp no foss, no code coverage, does not pass M4 (kennypaul, 16:02:21)
    46. usecase ui did not pass m4 (kennypaul, 16:03:16)
    47. appc request extra to complete aaf integration. (kennypaul, 16:05:43)


Meeting ended at 18:49:43 UTC (full logs).

Action items

  1. kenny add sched approval to next week's agebda


People present (lines said)

  1. kennypaul (59)
  2. SteveT (28)
  3. collabot (7)
  4. phrobb (4)
  5. xinhuili (3)
  6. ma_c (1)
  7. frankbrockners (1)
  8. Huabing_Zhao (1)
  9. djtimoney (1)
  10. RannyHaiby (1)
  11. phrpobb (0)


Generated by MeetBot 0.1.4.