#onap-meeting: tsc-2018-04-26

Meeting started by kennypaul at 13:41:58 UTC (full logs).

Meeting summary

  1. rollcall (kennypaul, 13:42:29)
    1. Chris Donley Huawei (cdonley, 13:56:30)
    2. Alla Goldner, AMDOCS (kennypaul, 13:56:33)
    3. Lingli Deng, China Mobile (kennypaul, 13:57:21)
    4. Stephen Terrill, Ericsson (SteveT, 13:58:16)
    5. Susana Sabater Vodafone (Susana, 13:58:17)
    6. Rajesh Gadiyar Intel (RajeshGadiyar, 13:58:30)
    7. Xinhui Li, VMware (xinhuili, 14:01:21)
    8. Ranny Haiby, Nokia (RannyHaiby, 14:01:30)
    9. jamil for Orange (jamil_, 14:01:49)
    10. Frank Brockners, Cisco (frankbrockners, 14:01:52)
    11. Xiaojun Xie, China Telecom (Xiaojun, 14:02:09)
    12. Jason Hunt, IB (JasonHunt, 14:04:36)
    13. Jason Hunt, IBM (JasonHunt, 14:04:42)

  2. House Keeping (SteveT, 14:05:04)
    1. David Sauvageau, Bell (davidsauvageau, 14:05:59)
    2. Private Chats. Turn it off for everyone or have chats to Kenny be published. (SteveT, 14:06:28)
    3. Murat Turpcu, Turk Telekom (kennypaul, 14:06:49)
    4. Phil suggested to foster a culture of redirecting towards public chats. (SteveT, 14:07:00)
    5. PTL meeting timeslote. 6-7 PST had 10 votes (only 14 of 47 replied). there was a "show of hands" informal vote for 6am or 6:30 am (PST) start. The conclusion was 6am PST start time. (SteveT, 14:10:59)
    6. brian freeman, att (Brianfreeman, 14:11:09)
    7. proxy brian freeman, att (Brianfreeman, 14:11:43)
    8. - Request to register for the ONAP casapblance release event in China (SteveT, 14:11:56)
    9. OPNFV TSC - ONAP colocation, no feedback. If there is someone that can host a large crowd that would be fine. Suggestion was raised to also consider hotels. (SteveT, 14:14:35)

  3. Release Status (Gildas) (SteveT, 14:14:51)
    1. Gildas presented the status of the RCO status summary. (SteveT, 14:15:15)
    2. - RC0 criteria -> must pass OOM and Heat deployment. Conditional AAF, DCAE, External API, logging, portal, OOF, SDC, UseCase UI (SteveT, 14:17:07)
    3. DCAE: heat ok, OOM close. (1 more submission to be expected to be merged, then testing). Expected this week. (SteveT, 14:18:54)
    4. Michael O'buien reports logging now passing healthcheck on zoom chzt wwindow (kennypaul, 14:19:04)
    5. Portal: Still some issues on OOM. expect this week. (SteveT, 14:22:41)
    6. dcae- Lushing says eta is tomorrow for oom deploy (kennypaul, 14:23:31)
    7. ExternalApi - still working on OOM. Expect a result this week. (SteveT, 14:24:54)
    8. SDC OOM and Heat working. Code coverage is the main issue. (SteveT, 14:26:44)
    9. sdc working on 2 patches due today that will unblock for pairwise testing (kennypaul, 14:27:09)
    10. AAF: Heat is OK. OOM -work in progress. No ETA for OOM yet. Update requested. (SteveT, 14:29:29)
    11. OOF: Heat. issues are expected to be resolved this week. OOM. expected this week. (SteveT, 14:31:34)
    12. Logging. OOM working. Code coveraging is ongoing. CSIT work ongoing. (SteveT, 14:32:53)
    13. Usecase UI: work in progres to remove dependancy on mysql. (SteveT, 14:35:00)
    14. HelenChen suggests of giving "conditionals" a pass if they pass heat and oom (kennypaul, 14:39:29)
    15. recomended approve SDC for RC0, keep the code coverage for RC1 as its planned. (SteveT, 14:41:04)
    16. AGREED: that all projects in the "Pass" column and SDC passes RC0 (kennypaul, 14:42:24)
    17. Dhananjay Pavgi, Tech Mahindra Ltd (DhananjayPavgi, 14:42:39)
    18. Recommended criteria for RC1 pass oom, pass pairwise, and vFW, vLB , vCPE, VoLTE regression tests (kennypaul, 14:44:34)
    19. recommended testing priority (in order) stability , resiliency, security, scalability, performance, manageability, usability. then func,. requirements- manual scaling , HPA, CM, PNF (kennypaul, 14:47:45)
    20. discussion of RC1 definition. (kennypaul, 14:50:11)
    21. : Update on Use Case UI. there is no mysql dependancy in UUI now. (SteveT, 14:51:50)
    22. : For OOM based deployments, the question was raised whether there are documentation updates required. It was clarified that this is identified and ongoing.รง (SteveT, 14:54:50)
    23. content related to onap deployment via oom is being migrated to readthedocs (kennypaul, 14:55:22)
    24. Remaining item to fix with UUI is to get a working build (since the removal of mysql dependency, UUI is not building properly) (gildaslanilis, 14:56:51)
    25. helenchen shared her slides (kennypaul, 14:56:52)
    26. daily working session meetings (kennypaul, 14:57:32)
    27. https://wiki.onap.org/display/DW/Integration+Weather+Board (kennypaul, 14:59:25)
    28. https://wiki.onap.org/display/DW/Beijing+Release+Integration+Test+Blocking+Issues (kennypaul, 15:00:59)
    29. no target date for starting new functional testing. (kennypaul, 15:05:25)
    30. There was a question about when to start testing the new functional requirements. They haven't started and the leadtime was hinted to push us after the release date. (SteveT, 15:06:01)
    31. helenchen says new func test should have started at RC0 to ensure release. (kennypaul, 15:06:23)
    32. rogerm reports architectural changes still being made vs. bug fixes (kennypaul, 15:08:57)
    33. PLTs to report on any addl changes that need to be made at PTL meeting on Monday. (kennypaul, 15:12:06)
    34. for RC1 add any non-bugfix changes needed to checklist. (kennypaul, 15:15:52)
    35. decision on actual release date next week. (kennypaul, 15:17:19)

  4. vulenarability update (kennypaul, 15:17:38)
    1. aaf need to know about false positives, (kennypaul, 15:18:50)
    2. SteveT reviewed his slides (kennypaul, 15:19:12)
    3. reminder this is part of RC2 criteria (kennypaul, 15:21:06)

  5. Documentation status (kennypaul, 15:22:16)
    1. RC1 checklist check Sphinx HTML, spell checks, and link checks (kennypaul, 15:23:04)
    2. OOM info from wiki content being migrated to Quick-Start, Set-Up, and User Guides. (kennypaul, 15:24:15)
    3. discussion over how to handle WIP doc sets - will discuss offline. (kennypaul, 15:25:27)
    4. VNF reference list. (kennypaul, 15:25:55)
    5. subcommittees please send updates via email (kennypaul, 15:27:33)

  6. functional requirements (kennypaul, 15:27:43)
    1. individual project support for features but not a unified approach - conversation in zoom chat window. (kennypaul, 15:28:42)
    2. request to integration team to discuss at next meeting (kennypaul, 15:30:30)
    3. ACTION: alla goldnet to send email to all Functionality leads (kennypaul, 15:30:58)
    4. ACTION: kennypaul to send email to PTLs for same. (kennypaul, 15:31:52)


Meeting ended at 15:32:01 UTC (full logs).

Action items

  1. alla goldnet to send email to all Functionality leads
  2. kennypaul to send email to PTLs for same.


Action items, by person

  1. kennypaul
    1. kennypaul to send email to PTLs for same.


People present (lines said)

  1. kennypaul (44)
  2. SteveT (22)
  3. RajeshGadiyar (5)
  4. collabot` (5)
  5. DhananjayPavgi (3)
  6. Brianfreeman (2)
  7. JasonHunt (2)
  8. davidsauvageau (1)
  9. Susana (1)
  10. Xiaojun (1)
  11. xinhuili (1)
  12. cdonley (1)
  13. frankbrockners (1)
  14. gildaslanilis (1)
  15. RannyHaiby (1)
  16. jamil_ (1)
  17. phrobb (0)


Generated by MeetBot 0.1.4.