#onap-sdnc: SDNC 9/13/2017

Meeting started by mgkwill at 13:09:32 UTC (full logs).

Meeting summary

  1. Generic Resource API - Overview (mgkwill, 13:09:55)
    1. Generic Resource API works on - vnfs, vfs, networks, alloted resources (mgkwill, 13:15:14)
    2. GR-API is based on service model (mgkwill, 13:15:55)
    3. https://wiki.onap.org/display/DW/SDNC+APIs (mgkwill, 13:18:56)
    4. https://wiki.onap.org/download/attachments/13599902/Generic_Resource_ONAP_AID.docx?version=1&modificationDate=1505308737223&api=v2 (mgkwill, 13:19:40)
    5. top level is service and then we have config under it (mgkwill, 13:24:55)
    6. under service is service data and service status (mgkwill, 13:28:40)
    7. Possible VoLTE use case could use network create, vCPE would use TunnelXConn (mgkwill, 13:43:26)
    8. Generic Resource API will be used for underlay creation in VoLTE use case as well as overlay for vCPE use case (mgkwill, 13:44:15)
    9. Q: would tunnelXConn be used for VoLTE A: Network Topology Create would be used. (mgkwill, 13:46:24)

  2. Directed Graphs + Builder (mgkwill, 13:53:22)
    1. use directed graphs as tool in developing (mgkwill, 13:53:58)
    2. use docker container from ccsdk_dgbuilder as tool (mgkwill, 13:54:35)
    3. ACTION: Dan to put instruction for use of ccsdk_dgbuilder on wiki (mgkwill, 13:55:15)
    4. loading directed graph from import in dgbuilder will show you what that API action does visually (mgkwill, 13:57:58)

  3. VoLTE use case in SDNC (mgkwill, 14:07:29)
    1. Routing table info needs to be propagated through SDNC when overlay is created (mgkwill, 14:07:52)
    2. Q: What is API of third party controller A: Dan: There is email chain with Brian Freeman that discusses that (mgkwill, 14:09:42)
    3. Q: What is wan descriptor in VoLTE use case? (mgkwill, 14:11:51)
    4. Zhuoyao Huang working on TOSCA overlay model now (mgkwill, 14:13:24)

  4. M2/M3 Status for SDNC (mgkwill, 14:16:43)
    1. Currently being tracked as Red, but a lot is paper work and Dan said he would work on it. (mgkwill, 14:17:06)
    2. Discussion about CSIT Functional Robot Test Cases (mgkwill, 14:18:46)
    3. Dan mentions that we need robot test cases in integration repo to run on CI/CD interval (mgkwill, 14:19:31)
    4. need unit tests for northbound to close 30% requirement for M3 in sonar (mgkwill, 14:21:18)
    5. ACTION: Dan add jira tasks for unit tests for sdnc-northbound (mgkwill, 14:24:00)


Meeting ended at 14:24:06 UTC (full logs).

Action items

  1. Dan to put instruction for use of ccsdk_dgbuilder on wiki
  2. Dan add jira tasks for unit tests for sdnc-northbound


People present (lines said)

  1. mgkwill (30)
  2. collabot (4)


Generated by MeetBot 0.1.4.