#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:01:29 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 17:03:34)
    1. wget to opensuse URLs is not working from our infra (inside a docker container). seems related to MTU size. maybe opensuse servers are sending back too large packets. (jamoluhrsen, 17:06:16)
    2. ACTION: zxiiro will rebuild the docker images with fixed mtus to 1458 (zxiiro, 17:07:15)
    3. https://git.opendaylight.org/gerrit/c/68114/ <-- patch to change rpm spec to build different rpm depending on which host OS (opensuse or centos) it's running (jamoluhrsen, 17:10:54)
    4. deb pipeline fixes coming soon hopefully. mardim has read through the tooling and hopes to get some patches uploaded in the near term (jamoluhrsen, 17:14:48)

  2. release (jamoluhrsen, 17:15:12)
    1. nitro RC is ready. CSIT jobs are done and we will need to vet them. (jamoluhrsen, 17:15:42)
    2. carbon SR3 has a new candidate. the OFP blocker patch was merged and autorelease finished (jamoluhrsen, 17:16:32)
    3. CSIT tests for carbon SR3 just started. results ready tomorrow (jamoluhrsen, 17:16:53)
    4. nitrogen autorelease is no longer running daily. (jamoluhrsen, 17:17:31)
    5. oxygen is still delayed, no autorelease successful, need to decide if we are fully kicking eman, faas, vtn out of the release (jamoluhrsen, 17:18:39)
    6. gvrangan says the version bump patch was merged just today. LuisGomez will add vtn back to int/dist (jamoluhrsen, 17:19:03)
    7. ACTION: gvrangan to find someone to add vtn back to autorelease and int/dist (jamoluhrsen, 17:19:47)
    8. deadline for projects to get back in to the release will be the first RC we get (jamoluhrsen, 17:20:57)
    9. nic and unimgr are not in int/dist yet, but we expect nic to be there. no clue on unimgr (jamoluhrsen, 17:22:21)
    10. https://git.opendaylight.org/gerrit/#/c/68169/ Monster BIER code dump, risk of breaking world after merge (dfarrell07, 17:25:30)

  3. distribution (jamoluhrsen, 17:26:18)
    1. we still see SFT failures, but seems we are using enough memory (4G). (jamoluhrsen, 17:27:18)
    2. now we are starting to comment out SFT on a per project basis, which means there are probably projects having serious bugs and not getting fixed. But, we do not have bandwidth/cycles to help these projects figure this out any more and they are delaying everyone else. (jamoluhrsen, 17:28:55)

  4. builder (jamoluhrsen, 17:35:46)
    1. finally migrated the filesystems for nexus (hopefully no more inode exhaustion) (jamoluhrsen, 17:36:15)
    2. maven binaries are on their own partition and logs on another (jamoluhrsen, 17:36:33)
    3. old-logs are not done migrating yet, maybe another week (jamoluhrsen, 17:36:45)
    4. add in "old-logs" in front of the releng path, like this https://logs.opendaylight.org/old-logs/releng/vex-yul-odl-jenkins-1/netvirt-csit-1node-openstack-ocata-upstream-stateful-oxygen/882/ (jamoluhrsen, 17:37:46)
    5. the merge job counters started over and with the log sync in progress there is a possibility that some job's logs will have problems until rsync is complete (jamoluhrsen, 17:38:46)
    6. new global-jjb release in place now. (jamoluhrsen, 17:39:34)
    7. https://github.com/opendaylight/releng-builder/tree/master/jenkins-config (zxiiro, 17:39:40)
    8. emergency maintenance of jenkins coming due to new CVE (anon access can execute code on the jenkins system). this will happen ASAP (jamoluhrsen, 17:42:04)

  5. misc (jamoluhrsen, 17:42:42)
    1. gvrangan has a new approach to installing openstack and opendaylight via robot (jamoluhrsen, 17:43:49)
    2. https://git.opendaylight.org/gerrit/c/63168/ <-- patch for robot install of openstack and opendaylight (jamoluhrsen, 17:44:00)
    3. some new images are needed to make this new work possible. (jamoluhrsen, 17:46:43)
    4. vtn restconf seems broken after the version bump (jamoluhrsen, 17:49:40)
    5. klou brings up the idea that all int/dist committers become committers to autorelease, since a lot of patches to int/dist require a patch in autorelease as well. (jamoluhrsen, 17:53:12)
    6. ACTION: LuisGomez to send email to vote for int/dist and autorelease committers to be the same (jamoluhrsen, 17:55:34)


Meeting ended at 17:57:57 UTC (full logs).

Action items

  1. zxiiro will rebuild the docker images with fixed mtus to 1458
  2. gvrangan to find someone to add vtn back to autorelease and int/dist
  3. LuisGomez to send email to vote for int/dist and autorelease committers to be the same


Action items, by person

  1. zxiiro
    1. zxiiro will rebuild the docker images with fixed mtus to 1458
  2. UNASSIGNED
    1. gvrangan to find someone to add vtn back to autorelease and int/dist
    2. LuisGomez to send email to vote for int/dist and autorelease committers to be the same


People present (lines said)

  1. jamoluhrsen (36)
  2. zxiiro (4)
  3. odl_meetbot (3)
  4. dfarrell07 (2)
  5. odp-gerritbot (1)


Generated by MeetBot 0.1.4.