17:00:59 <colindixon> #startmeeting tsc
17:00:59 <odl_meetbot> Meeting started Thu Oct 12 17:00:59 2017 UTC. The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:59 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:59 <odl_meetbot> The meeting name has been set to 'tsc'
17:01:05 <colindixon> #topic agenda bashing and roll call
17:01:15 <colindixon> TSC members please #info in
17:01:18 <colindixon> #Info colindixon
17:01:30 <anipbu> #info anipbu
17:01:34 <rovarga_> #info rovarga_
17:01:45 <skitt> #info skitt
17:01:52 <jamoluhrsen> #info jamoluhrsen
17:02:09 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda still last week's agenda
17:02:28 <lori> #info lori
17:02:43 <colindixon> #info rovarga_ asks if we can do the creation review for TrieMap
17:02:47 <zxiiro> #info Thanh
17:03:02 <colindixon> #info CaseyODL would like to bring up the idea of a smaller release
17:03:14 <shague> #info shague
17:03:22 <colindixon> #Info CaseyODL notes that ask.opendaylight.org is now in read-only mode
17:03:34 <gilesheron> #info gilesheron (for edwarnicke)
17:03:53 <colindixon> #Link https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-10-05-17.00.html last week's meeting minutes
17:04:08 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan klou took the disclaimer off the top of the oxygen release plan
17:04:09 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Oxygen_Release_Plan klou updated Nitrogen SR1 to have a 10/26 release date and move the dates for branch locking and things as well
17:04:10 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/64205/ colindixon did the basic migration of the Oxygen release plan to rst
17:04:47 <colindixon> #undo
17:04:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x14bafd0>
17:04:50 <colindixon> #undo
17:04:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x14bad10>
17:05:09 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan klou updated Nitrogen SR1 to have a 10/26 release date and move the dates for branch locking and things as well
17:05:15 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/64205/ colindixon did the basic migration of the Oxygen release plan to rst
17:05:49 <colindixon> #action CaseyODL to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up at the OPNFV summit in portland, specifically figure out how many ODLers plan to go
17:05:50 <colindixon> #action phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL (via the board)
17:06:05 <colindixon> #action CaseyODL to coordinate rovarga to add a session to the TWS page about the lessons learned from nitrogen
17:06:25 <colindixon> #action klou to get rovarga to say mdsal is participating in oxygen
17:06:45 <colindixon> #action zxiiro to work with skitt and colindixon to see if we can get projects to opt-in (or opt-out) of having releng being empowered to merge any/all version bumps that relate to releases, not just after SRs
17:07:31 <colindixon> #action dfarrell07 to ask OPNFV when they would need an SR1 and is there anything that would actually be helpful that we could get in that, if not we'll leave it at 10/26
17:07:59 <abhijitkumbhare> #info abhijitkumbhare
17:08:33 <colindixon> #topic mailing list
17:08:34 <colindixon> #info no significant changes from last week
17:08:35 <colindixon> #topic events
17:08:39 <colindixon> #link https://www.opendaylight.org/global-events
17:08:45 <colindixon> #Link https://wiki.opendaylight.org/view/Events:Main
17:09:00 <colindixon> #info the Oxygen DDF was this week (Monday and Tuesday)
17:09:15 <colindixon> #info phrobb said he thougth it went quite well, was happen with the attendance, venue, topics, and outcomes
17:09:38 <vishnoianil> #info Anil Vishnoi
17:11:18 <colindixon> #info CaseyODL notes that there's OPNFV plug-fest in portland in December, the next major event would be ONS in March
17:11:44 <colindixon> #Info phrobb notest that there is some planning about an India road show as well, but not specific details yet
17:11:52 <colindixon> #undo
17:11:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1524050>
17:11:56 <colindixon> #Info phrobb notes that there is some planning about an India road show as well, but not specific details yet
17:12:25 <colindixon> #info the CFP for ONAP developer forum is coming out now, the forum itself will be the week of December 12th
17:13:37 <colindixon> #action CaseyODL to make sure we get whatever details we can for the india road show, ONS and ONAP forum are at least on the wiki events page
17:13:45 <colindixon> #topic Oxygen
17:13:50 <colindixon> klou: all yours
17:14:08 <colindixon> #info we're witing for M0 from md-sal
17:14:24 <colindixon> #info we are going to remove cardinal and ttp
17:14:32 <colindixon> #info jsonrpc is joining late
17:15:05 <colindixon> #info M1 status for offset 0 projects was 10/7, so far we only have 1-2 projects have submitted gerrit patches for their M1 status
17:15:47 <colindixon> #info M1 status for offset 1 and 2 projects are 10/14 (two days from now) and 10/21, respectively
17:16:39 <colindixon> #info genius broke the oxygen build, but it looks like we have a patch and the last one (15-hours ago was successful)
17:17:01 <colindixon> #topic nitrogen
17:17:19 <colindixon> #info klou says we're still having some problems getting a good build since we've released
17:17:53 <colindixon> #info klou says that there have been a lot of problems, the most recent one is in netvirt, shague is looking at it
17:18:32 <colindixon> #info shague says he can't repoduce it locally w/o sleeps, but zxiiro will spin off another one
17:18:43 <colindixon> #topic carbon
17:18:58 <colindixon> #info we have an RC for Carbon-SR2 that was built on Monday
17:19:31 <colindixon> #info klou says the only thing blocking us is checking off on the CSIT problems
17:19:56 <colindixon> #info anipbu says that this is all new failures, jamoluhrsen says he should be able to hammer a lot of those out this afternoon
17:20:34 <colindixon> #info anipbu notes that we really need to look at all the blocker bugs from nitrogen are fixed in carbon (as well as blocker bugs in carbon)
17:20:54 <colindixon> #action klou to make sure the blocker bugs from both carbon and nitrogen are fixed in Carbon-SR2 and update the spreadsheet
17:21:11 <colindixon> #info it sounds like LuisGomez is the person who needs to sign off on those
17:22:17 <colindixon> #topic system integration and test
17:23:09 <colindixon> #info rovarga_ is working about -all jobs and -only jobs, it turns out that we have tool from infrautils that lets us know when all the projects are loaded or not, this might help with the issues rovarga_ was experiencing (according to jamoluhrsen)
17:23:49 <colindixon> #topic infra
17:24:04 <colindixon> #info as of wednesday, the wiki is only taking LFIDs
17:24:11 <zxiiro> #link https://lists.opendaylight.org/pipermail/tsc/2017-October/008138.html ODLID -> LFID mapping form
17:24:25 * colindixon is apparently colindixon on the wiki now :-( :-(
17:25:14 <colindixon> #info colindixon asks if we're planning to do anything for people in China who can't get access to google forms
17:26:15 <colindixon> #topic TrieMap Creation Review
17:26:33 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2017-September/007932.html proposal sent on 9/18
17:26:44 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Triemap
17:27:27 <colindixon> #info "an entire formal new ODL project for these... 5 classes strikes me as… curious." --vorburger
17:27:35 <colindixon> #undo
17:27:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x153bb90>
17:27:40 <colindixon> #info 3 lines of feedback
17:27:49 <colindixon> #Info 1.) why do we need a new project for 5 classes?
17:27:57 <colindixon> #Info 2.) why can't it be in infrautils?
17:28:02 <colindixon> #info 3.) why can't it live on github?
17:28:59 <colindixon> #info w.r.t. 1.) rovarga_ says it won't be part of autorelease or simulatenous releases, it is very, very stable and won't release much and so won't have to deal with version bumps
17:29:13 <colindixon> #info w.r.t., 3.) rovarga_ says it's hard to depend on odlparent from github
17:30:29 <colindixon> w.r.t. 2.) rovarga_ says infrautils is still an incubation project, so having yangtools depending on it is somewhat odd, and the rovarga_ worries about the fact that infrautils scope doesn't (currently include it)
17:30:36 <colindixon> #info w.r.t. 2.) rovarga_ says infrautils is still an incubation project, so having yangtools depending on it is somewhat odd, and the rovarga_ worries about the fact that infrautils scope doesn't (currently include it)
17:32:01 <colindixon> #Info colindixon asks if it depends on odlparent, will it need to be version bumped every time odlparent is, skitt says no, not unless it's a runtime dependency, which there are few, rovarga_ says guava is the only thing that might be complicated
17:32:20 <colindixon> #info rovarga_ says he's considering dropping guava because they don't need a lot of it and it might cause problems
17:34:45 <colindixon> #info vishnoianil asks what the bar is for being an opendaylight project, usually "is it related to networking", but in this case it's not, is "an opendaylight project wants to use it" enough
17:35:06 <vrpolak> Tcpmd5 was a similar library project, but I guess it was networking-related enough.
17:36:28 <colindixon> #info vrpolak and colindixon point out that infrautils and tcpmd5 probably have the same issue
17:38:04 <colindixon> #info colindixon notes that his preference would be to amend the scope of infrautils and work to make it mature, but he won't block it
17:38:42 <abhijitkumbhare> I was talking on mute - but I was suggesting the same as vishnoianil - about an umbrella library ?
17:38:46 <colindixon> #info vishnoianil asks if we can have a single mature library project where we put things like this
17:39:13 <vrpolak> Set of projects is better with respect to tracking dependency relations.
17:39:31 <colindixon> vrpolak: +1, but single project is better for organizational survivability
17:39:43 <colindixon> losing a single developer can easily take out a whole project
17:39:55 <colindixon> and, in this case, a critical project
17:42:27 <vrpolak> Perhaps we can create projects such as Utils/LibA, Utils/LibB which would be officially independent, but they will share the same set of committers.
17:44:47 <colindixon> #info rovarga_ notes this is a matte of whether we'd do apache commons style, with lots of smaller projects, or the guava style with a single bigger project that revs all the time
17:45:28 <colindixon> #Info colindixon says the only thing he really sees as bad for having more projects are overhead and organizational survivability
17:47:16 <colindixon> #info colindixon is really only worries about the small number of committers on stable projects meaning you might lose all the developers, not notice for a while, and then discover you need to patch it and don't have any committers
17:47:59 <colindixon> #info abhijitkumbhare points out that projects also result in changing our electorate, spltiting a project out into many other projects theoretically allows more votes in elections
17:50:24 <colindixon> #info rovarga_ notes that this problem is real, but maybe not an issue, the idea that one huge project has the same votes as smaller projects might mean that splitting was good
17:50:41 <colindixon> #Info rovarga_ also notes that an incentive for big projects to split up, might improve understandability
17:51:47 <colindixon> #Info colindixon asks if we're ready to vote, abhijitkumbhare asks if we could have an option in voting for this goes into a common library vs. a new project
17:53:35 <colindixon> #info rovarga_ says the other option would be to have yangtools have a sub-repo under the same project
17:55:01 <colindixon> #info colindixon asks what rovarga_'s thoughts are right now
17:55:41 <colindixon> #Info rovarga_ says that he things infrautils is the wrong place for it, he's willing to park this issue if people aren't ready to vote yet, the votes issue that abhijitkumbhare brings up is a real one
17:56:04 <colindixon> #info rovarga_ notes that it's probably not enough to force all these issuse for splitting out 5k lines
17:57:40 <colindixon> #action colindixon to send out an e-mail asking if we want to have a vote of ordered options for what would happen with triemap (and figure out what the options are)
17:58:09 <colindixon> #info skitt notes that he agrees that infrautils is a bad place
17:58:35 <colindixon> #info skitt would like to have the ability to host small projects that are stable and don't really fit anywhere else
17:59:07 <abhijitkumbhare> rovarga_ & colindixon: Just to be clear - I don’t think this particular split makes much change to the TSC electorate for 2017/2018 - just thinking about the precedent & whether we want to do that. Also code organization wise - does it make sense to have a library with multiple independent repos?
17:59:26 <colindixon> #topic DDF outcomes around consolidated, more stable releases
17:59:35 <colindixon> #Info CaseyODL asks if we want to have a TWS about it and when
18:00:08 <colindixon> #action skitt to offer a tl;dr version of this before we have a TWS
18:00:48 <rovarga_> abhijitkumbhare: yup, I think I got your point. I am not sure -- we need to think about it a bit ;-)
18:00:57 <colindixon> #info LuisGomez says there were other topics for TSC that came out of the DDF: the above, but also differing requirements for different proejcts
18:00:59 <skitt> #action skitt to offer a tl;dr version of the "stable base" offset-0/1 proposal + offset-2 distros
18:01:20 <colindixon> #action colindixon to add different requirements for different kinds of projects in SRs to next week's agenda
18:01:37 <colindixon> #topic cookies
18:01:39 <rovarga_> abhijitkumbhare: in my mind a blanket 'utilities' project is something that should be avoided, for quite a few reasons
18:01:50 <vrpolak> In Nitrogen DDF we were talking about how leaf project can be moved out of Distribution (and Autorelease) and do standalone releases to be applied to the official distribution as add-ons.
18:01:53 <colindixon> #endmeeting