14:11:00 <bobmon01> #startmeeting armband 18Mar2016
14:11:00 <collabot`> Meeting started Fri Mar 18 14:11:00 2016 UTC.  The chair is bobmon01. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:11:00 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:11:00 <collabot`> The meeting name has been set to 'armband_18mar2016'
14:11:09 <bobmon01> #info bob Monkman
14:11:32 <StanKardach> #info Stan Kardach (Cavium)
14:11:33 <MikeHolmes> #info Mike Holmes
14:11:39 <AlexAvadanii> #info Alexandru Avadanii (Enea)
14:11:45 <florind> #info Florin Dumitrascu
14:11:47 <joekidder_> #info Joe Kidder
14:12:45 <bobmon01> #info puppet scripts completed for installing ODL to handle manually
14:14:42 <bobmon01> #info ODL depends on a library for cluster db and ODL pulls in an x86 dependent and so we have to manually install with puppet scripts
14:15:57 <bobmon01> #info we build our own ARM version of library and manually install thru puppet scripts to start ODL service
14:16:47 <bobmon01> #info still seeing an intermittent issue where ODL stalls but other times it starts fine.
14:17:05 <bobmon01> #info so we know it works but need to determine the occasional failure
14:17:35 <StanKardach> I can describe it in chat
14:17:54 <StanKardach> basically we need to have direct kernel boot for cirros
14:18:06 <StanKardach> #info basically we need to have direct kernel boot for cirros
14:18:09 <bobmon01> #info found another bug, which is fixed, related to the cirrus image
14:18:18 <StanKardach> sure
14:19:46 <StanKardach> #info it is required to boot machines on arm64. In the change implementing the direct boot mechanism I've made several mistakes in terms of code and image formats. I've fixed it, tested manually and now am applying it to fuel master for automation
14:20:06 <bobmon01> #info thanks Stan
14:24:29 <bobmon01> #info Ciprian is not on the call and so we do not have an update on FuncTest
14:25:08 <AlexAvadanii> #info there are still nice things that are not mandatory, but easy to add, and we plan to; like UEFI (EFK2) fw support for guest VMs
14:25:09 <bobmon01> #action Joe to chase down update on Functest
14:30:15 <bobmon01> #action we have a quorom on approving 3 new committers and Bob will send the request to IT.
14:31:10 <bobmon01> #stan's changes will be pushed up once he is a committer and then we can proceed to joining CI
14:32:21 <bobmon01> #need to set up a slave for deployment - slave to Jenkins
14:33:26 <AlexAvadanii> #link https://build.opnfv.org/ci/computer/arm-pod1/
14:33:35 <AlexAvadanii> #link https://build.opnfv.org/ci/computer/arm-build1/
14:34:12 <AlexAvadanii> #info Jenkins is in the works, Josep created the slaves and an internal master, we are still configuring some stuff
14:42:55 <AlexAvadanii> #link http://linux.enea.com/mos-repos/
14:43:33 <AlexAvadanii> #info this is very, very similar to official fuel-infra mirrors, but has arm64 packages too, including a linux-lts-trusty kernel for aarch64
14:43:59 <AlexAvadanii> #info also newer libvirt for armv8 support, and qemu 2.5
14:45:33 <bobmon01> Alex...did you say that the libvirt issue is now fixed?
14:45:46 <AlexAvadanii> yes, as far as we know
14:46:10 <StanKardach> in terms of our current setup, you'd need at least a single x86 VM for the fuel master
14:46:27 <AlexAvadanii> I don't really understand the x86 VMs questions
14:46:29 <bobmon01> #info the team are working with fathi to get all Jenkins slaves set up for CI
14:46:30 <StanKardach> this may be a bit suboptimal as that would mean a full-qemu virtualization
14:47:33 <AlexAvadanii> if you are talking about deploying openstack on aarch64 VMs, that should work
14:47:44 <StanKardach> sure
14:49:48 <AlexAvadanii> ealry next week, if everything works according to plan
14:51:42 <bobmon01> #discussion on when we can replicate the deployment in other labs
14:55:53 <bobmon01> #action Joe' steam will work with other labs to begin to hand over deployment artifacts and instructions to replicate the ARM pod configuration
14:58:20 <AlexAvadanii> http://pasteboard.co/2mm6pZ5B.png
14:58:29 <bobmon01> #info Ciprian arrived and reports that he is pushing some fixes into Functest tests
14:58:45 <AlexAvadanii> http://pasteboard.co/2mm8UHMR.png
15:00:58 <bobmon01> #info Ciprian plans to working on a Fuel 8 deployment any day now- needs help in setup of a Fuel Master
15:01:35 <bobmon01> #info then Functest on Brahamaputra components will proceed.
15:03:36 <bobmon01> #endmeeting