#opnfv-cperf: cperf

Meeting started by dfarrell07 at 18:04:28 UTC (full logs).

Meeting summary

    1. Nikos is not here today, sent feedback via email (dfarrell07, 18:04:52)
    2. Discussion about ODL perf whitepaper (dfarrell07, 18:07:09)
    3. Feedback around couching perf whitepaper results in terms of high-level use cases. We did that some this time, but could do better. (dfarrell07, 18:07:57)
    4. Feedback around providing clustering numbers next time. We're planning on clustering func testing first, then perf in CI, then real perf numbers to provide in paper. (dfarrell07, 18:10:11)
    5. Longevity testing should be 72 hours, says ATT guy (dfarrell07, 18:10:50)
    6. Nikos and Al have been working on feedback for their test tools, Nikos' group will release a version with those changes soon (dfarrell07, 18:12:11)
    7. All of us were at ONS last week (dfarrell07, 18:12:23)
    8. jamoluhrsen has been working on CBench hello world job in OPNFV CI (dfarrell07, 18:12:51)
    9. It looks like Intel Pod 2 is currently not ready for job (dfarrell07, 18:13:04)
    10. First job is passing verify, which is mostly a jenkins-jobs verify (dfarrell07, 18:13:18)
    11. First test is a hello world with cbench and apex and ODL (dfarrell07, 18:13:41)
    12. ODL will do another whitepaper for Boron with feedback taken into account (dfarrell07, 18:16:05)
    13. mgkwill will be leading an ODL-side perf group (dfarrell07, 18:17:58)
    14. ODL perf group will work closely with us on OPNFV side (dfarrell07, 18:18:08)
    15. mgkwill will send out an email to get things started, will likely have bi-weekly meetings (dfarrell07, 18:18:25)
    16. Perf group will do things like collab on shared things like dashboards (dfarrell07, 18:18:59)
    17. This effort will become more pressing for projects as they attempt to get Stable Features, which require perf/scale tests (dfarrell07, 18:19:58)
    18. LuisGomez has been reviewing various ONF whitepapers about how to do SDN perf testing. Questions about if/how some things can be measured. Will make sure he works with Al to understand standards side of world, give feedback from test side of world. (dfarrell07, 18:28:42)
    19. mgkwill talked to Ralph Daniels of Spirint about a perf tool. He had played with it and it was broken, but demo at ONS seemed to work. Hoping Ralph will install it on OPNFV Intel lab so we can play with it. (dfarrell07, 18:31:08)
    20. Ixia and Whaway (sp lol) had a perf paper going around at ONS with ODL numbers. Our numbers looked good says mgkwill, better than ONOS, but there were not details of how to reproduce the tests says LuisGomez. (dfarrell07, 18:32:15)
    21. Al has added CPerf to OPNFV C release (dfarrell07, 18:33:56)
    22. ACTION: dfarrell07 to review C release inclusion, make sure we're good (dfarrell07, 18:34:15)


Meeting ended at 18:34:18 UTC (full logs).

Action items

  1. dfarrell07 to review C release inclusion, make sure we're good


Action items, by person

  1. dfarrell07
    1. dfarrell07 to review C release inclusion, make sure we're good


People present (lines said)

  1. dfarrell07 (24)
  2. collabot (3)


Generated by MeetBot 0.1.4.