#opnfv-cperf: cperf

Meeting started by dfarrell07 at 18:14:07 UTC (full logs).

Meeting summary

    1. Meeting at new time, +15 mins from old time, as doc'd via email and wiki updates (dfarrell07, 18:14:29)
    2. https://gerrit.opnfv.org/gerrit/#/c/9209/ Hello world cbench job for cperf is making progress, LuisGomez jamoluhrsen and I have looked at it this week (dfarrell07, 18:15:25)
    3. https://gerrit.opnfv.org/gerrit/#/c/11973 Dockerfile patch for our test tools (dfarrell07, 18:20:10)
    4. Discussion b/t LuisGomez jamoluhrsen and dfarrell07 about JJB params, docs for them, JJB jobs in general (dfarrell07, 18:22:45)
    5. Nikos has a prototype of the latency test tool he has been developing with feedback from Al (dfarrell07, 18:26:34)
    6. https://github.com/anastop/latte (anastop, 18:26:39)
    7. https://github.com/anastop/latte Latency test tool prototype under-dev by Nikos (dfarrell07, 18:27:12)
    8. Nikos is running it against ODL Be, has initial results (dfarrell07, 18:27:30)
    9. Some concerns about overhead of test tools. Measured and seems okay initially, more work to come. (dfarrell07, 18:28:17)
    10. https://github.com/intracom-telecom-sdn/nstat/wiki/Performance-Report-v1.2#6-flow-scalability-stress-tests (anastop, 18:28:52)
    11. Nikos and his team have been doing some additional experiments for their report. Following idea of ODL upstream perf report of doing end-to-end, usecase-driven tests. (dfarrell07, 18:29:09)
    12. Nikos and team are still collecting results, but will release report soon (dfarrell07, 18:29:29)
    13. Nikos and team have done comparisons between Li and Be ODL (dfarrell07, 18:29:48)
    14. https://github.com/intracom-telecom-sdn/nstat/wiki/Performance-Report-v1.2#6-flow-scalability-stress-tests Some initial results from Nikos team/tool (dfarrell07, 18:30:05)
    15. testing scale with up to 5k switches (dfarrell07, 18:31:36)
    16. these results are for public upstream ODL releases (dfarrell07, 18:31:53)
    17. Some optimizations about config they have done, including how they pin threads and such, but currently prio (dfarrell07, 18:32:40)
    18. results on wiki are pretty much finalized (dfarrell07, 18:35:51)
    19. ACTION: dfarrell07 to send these results out widely once anastop gives okay that they are ready (dfarrell07, 18:36:09)
    20. ACTION: jamoluhrsen to link this report from ODL perf group wiki (idk where that is exactly) (dfarrell07, 18:36:46)
    21. ACTION: jamoluhrsen to link intracom perf report from ODL perf wiki (jamoluhrsen, 18:36:48)
    22. Intel Pod 2 had some hardware taken away, but they are ordering more, but it will not be in until end of April (so that's blocking actually running the Jenkins jobs we're working on) (dfarrell07, 18:40:41)
    23. We should talk to Uri if we need to force this topic (dfarrell07, 18:40:51)
    24. Al is at IETF SDN Benchmarking conf (dfarrell07, 18:42:32)
    25. Al has been getting good feedback about SDN benchmarking (dfarrell07, 18:42:44)


Meeting ended at 18:43:56 UTC (full logs).

Action items

  1. dfarrell07 to send these results out widely once anastop gives okay that they are ready
  2. jamoluhrsen to link this report from ODL perf group wiki (idk where that is exactly)
  3. jamoluhrsen to link intracom perf report from ODL perf wiki


Action items, by person

  1. anastop
    1. dfarrell07 to send these results out widely once anastop gives okay that they are ready
  2. dfarrell07
    1. dfarrell07 to send these results out widely once anastop gives okay that they are ready
  3. jamoluhrsen
    1. jamoluhrsen to link this report from ODL perf group wiki (idk where that is exactly)
    2. jamoluhrsen to link intracom perf report from ODL perf wiki


People present (lines said)

  1. dfarrell07 (24)
  2. collabot` (3)
  3. jamoluhrsen (3)
  4. anastop (2)


Generated by MeetBot 0.1.4.