13:02:21 <GeraldK> #startmeeting Doctor
13:02:21 <collabot> Meeting started Tue Mar 22 13:02:21 2016 UTC.  The chair is GeraldK. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:21 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:02:21 <collabot> The meeting name has been set to 'doctor'
13:02:25 <cgoncalves> #info Carlos Goncalves
13:02:29 <GeraldK> #topic Roll Call
13:02:37 <GeraldK> #info Gerald Kunzmann
13:02:37 <tojuvone> #info Tomi Juvonen
13:02:38 <uli-k_> #info Uli Kleber
13:03:04 <GeraldK> #chair cgoncalves
13:03:04 <collabot> Current chairs: GeraldK cgoncalves
13:03:52 <cgoncalves> #info agenda for today's meeting: https://etherpad.opnfv.org/p/doctor_meetings
13:04:35 <GeraldK> #info Hackfest Quick Reports
13:05:00 <GeraldK> #link https://etherpad.opnfv.org/p/doctor_2016Q1_hackfest
13:06:36 <GeraldK> #info all intended Nova and Aodh BPs are already implemented in upstream
13:07:27 <GeraldK> #info potential new use case on "how to mark down ports". gap analysis needed.
13:08:43 <GeraldK> #info we need to start discussion on OPNFV Summit in one of the next calls
13:09:27 <GeraldK> #info Colorado planning
13:11:09 <GeraldK> #info add installers, test cases, SB API specs, and integration of Inspector modules
13:12:10 <GeraldK> #info cgonvalves, we had a good discussion with Vitrage team on how to integrate Inspector(s). use could choose which one to use.
13:13:19 <GeraldK> #undo
13:13:19 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2befa10>
13:13:23 <GeraldK> #info cgonvalves, we had a good discussion with Vitrage team on how to integrate Inspector(s). user could choose which one to use.
13:14:43 <GeraldK> #info for maintenance, Tomi led discussion on "Maintenance". identified some gaps.
13:14:47 <cgoncalves> #link https://wiki.opnfv.org/_media/opnfv_doctor_maintenance_api_20160313.pptx
13:17:17 <GeraldK> #info it was discussed that this might not be the right approach to use the Inspector, but integrate the actions into Nova
13:19:34 <GeraldK> #topic Maintenance changes to Nova
13:21:06 <GeraldK> #info Tomi has a new proposal for the maintenance in mind
13:21:52 <GeraldK> #info Tomi already had some chat with John Garbutt (Nova plt) and he is also very interested about the topic and looking to see spec and it would be natural continue for get-valid-server-state work. Also proposed I could discuss this with API team.
13:22:23 <GeraldK> #info     Initial proposal would be to have start and end time visible. API to set that and visibility to VM owner also. Currently only disable/enable to stop schduling, but this would be for the real maintanance period.
13:22:32 <GeraldK> #info     Any actions for VMs would be harder and out of scope. Also talked a bit about this with Sean Dague (core). Mostly opinion has been to have this external, but gaps surely needs to implement in Nova if use case needs it. Some discussion exists about auro recovery, but perhaps addressed later.
13:24:27 <GeraldK> #info Tomi: the proposal from the hackfest was more complex and complete; the new proposal is to have maintenance window visible; have an API to have start time and end time.
13:25:06 <GeraldK> #info cgoncalves: would this fully cover maintenance use case or would we need other mechanisms, e.g. migration actions?
13:25:23 <GeraldK> #info Tomi: anyway all maintenance actions are left out of scope
13:28:31 <GeraldK> #action Tomi to share draft BP spec
13:30:56 <GeraldK> #info Tomi: user will be notified similar to "mark host down" use case
13:32:33 <GeraldK> #info cgoncalves: this is only a notification to VIM, but you would also need alarming to consumer to inform them about the planned maintenance window
13:34:11 <GeraldK> #topic AOB
13:34:38 <GeraldK> #info OpenStack Summit in Austin: multiple Doctor members got presentations accepted
13:36:31 <GeraldK> #info OPNFV Summit: Reminder  CFP deadline is March 31
13:37:27 <cgoncalves> sorry, I lost connection
13:40:33 <GeraldK> #info pls note the meeting time adjusted to summer times
13:45:17 <GeraldK> #info proposal to have discussion on OPNFV Summit proposals / demo in next week's call
13:46:20 <GeraldK> #info if someone missed the Vitrage demo from last week contact Ohad, they volunteer to present it again
13:47:07 <GeraldK> #info happy Easter
13:47:10 <GeraldK> #endmeeting