08:01:42 <jose_lausuch> #startmeeting Functest weekly meeting July 26th 2016
08:01:42 <collabot> Meeting started Tue Jul 26 08:01:42 2016 UTC.  The chair is jose_lausuch. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:42 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:42 <collabot> The meeting name has been set to 'functest_weekly_meeting_july_26th_2016'
08:01:48 <jose_lausuch> #link https://wiki.opnfv.org/display/functest/Functest+Meeting
08:01:52 <jose_lausuch> #topic roll call
08:02:12 <jose_lausuch> #chair SerenaFeng boucherv_orange
08:02:12 <collabot> Current chairs: SerenaFeng boucherv_orange jose_lausuch
08:02:33 <jose_lausuch> #info Jose Lausuch
08:02:43 <boucherv_orange> #info Valentin Boucher
08:03:08 <raghu_> #info raghavendrachari
08:03:46 <SerenaFeng> #info SerenaFeng
08:04:53 <jose_lausuch> May-meimei: there?
08:04:59 <jose_lausuch> lhinds: there?
08:05:07 <jose_lausuch> lhinds: we have some issues with security scan :)
08:05:11 <jose_lausuch> I'll info it later
08:05:16 <jose_lausuch> #topic Action point follow-up (meeting on the 19th July)
08:05:27 <jose_lausuch> #info AP: SerenaFeng update test api on testresults.opnfv.org with last version of datamodel
08:05:30 <jose_lausuch> SerenaFeng: any update?
08:06:19 <jose_lausuch> #info AP: May-meimei jose_lausuch check the problem with the jumphost accessing the artifacts: AccessDeniedException: 401 Login Required.
08:06:36 <jose_lausuch> #info problem solved, the compass pods have now access to push things to artifacts.
08:06:54 <SerenaFeng> not yet
08:07:07 <May-meimei> jose_lausuch: here
08:07:14 <May-meimei> sorry I am late
08:07:16 <jose_lausuch> is that right May-meimei?
08:07:18 <jose_lausuch> no problem
08:07:20 <jose_lausuch> ok SerenaFeng
08:07:27 <May-meimei> right
08:07:28 <jose_lausuch> ok
08:07:35 <jose_lausuch> #info AP: jose_lausuch contact Bryan (bryan_att) to report the failure. DONE. Being fixed at the moment.
08:07:47 <jose_lausuch> #info AP: jose_lausuch contact moon project to see when the scenario can be active. In progrress.
08:07:51 <jose_lausuch> #action jose_lausuch contact moon project to see when the scenario can be active.
08:08:01 <jose_lausuch> #info AP: jose_lausuch: try to find the reason why Functest-joid fails and contact joid folks for support.
08:08:06 <jose_lausuch> #info Functest has almost successfully run on JOID: https://build.opnfv.org/ci/view/functest/job/functest-joid-baremetal-daily-master/117/console
08:08:18 <jose_lausuch> #info However there are problems with Doctor test case
08:08:50 <jose_lausuch> #undo
08:08:50 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b577d0>
08:08:57 <jose_lausuch> #info However there are problems with  Domino test case
08:09:04 <jose_lausuch> #action jose_lausuch contact Domino team (JIRA) to report the failure.
08:09:14 <jose_lausuch> #action jose_lausuch contact Jack Morgan or Fatih, gsutils is not installed on intel-pod6 jumphost
08:09:44 <jose_lausuch> this is regarding the action points
08:09:50 <jose_lausuch> let's talk about status of feature projects
08:09:55 <jose_lausuch> #topic Feature projects integration status
08:10:16 <jose_lausuch> #info SDNVPN: test already in CI and reporting the results to DB.
08:10:42 <jose_lausuch> #info ODL-SFC to be enabled this week in CI, but they need a tacker-post install script on the controller side.
08:10:51 <jose_lausuch> regarding security
08:10:53 <jose_lausuch> lhinds: ping
08:12:08 <jose_lausuch> he doesnt seem to be at the computer...
08:12:15 <jose_lausuch> I'll try to report
08:12:31 <jose_lausuch> #info SECURITY: there is a problem that jenkins output reports "sudo: hiera: command not found"
08:12:54 <jose_lausuch> #action lhinds look into the problem "sudo: hiera: command not found" . Example: https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console
08:13:00 <jose_lausuch> there is another issue
08:13:27 <jose_lausuch> #info "security_scan - INFO - Installing OpenSCAP..." this takes too long and makes the jenkins job timeout...
08:13:48 <jose_lausuch> #action lhinds: look for the possibility to install OpenSCAP in the docker image so that we dont have to do it while running the job in Jenkins
08:14:06 <jose_lausuch> May-meimei: any words for Multisite?
08:14:29 <May-meimei> troubleshooting now
08:14:43 <jose_lausuch> #info MULTISITE: there are some problems with fetch_os_creds.sh because they have a deployment with 2 fuel environemnts (2 regions) and that is not considered in the script.
08:14:51 <jose_lausuch> that's what we were trying yesterday
08:15:04 <jose_lausuch> #info troubleshooting now
08:15:31 <May-meimei> still have  this issue
08:16:06 <May-meimei> Sashish is working on that
08:16:30 <jose_lausuch> May-meimei: there is a fix. We need an environment variable in the Docker called FUEL_ENV  https://gerrit.opnfv.org/gerrit/#/c/17515/
08:17:04 <jose_lausuch> #info Sashish working on that. The way to fix the fuel environment id is with a new environment variable for docker "FUEL_ENV"
08:17:08 <jose_lausuch> #link https://gerrit.opnfv.org/gerrit/#/c/17515/
08:18:02 * fdegir installed & verified gsutil on intel pod5 and pod6 jumphosts
08:18:21 <jose_lausuch> fdegir is watching us and doing the fixes on the fly...
08:18:25 <jose_lausuch> fdegir: thanks a lot :)
08:18:55 <jose_lausuch> #info fdegir installed & verified gsutil on intel pod5 and pod6 jumphosts
08:19:28 <jose_lausuch> #topic Colorado status
08:19:36 <jose_lausuch> #link https://jira.opnfv.org/issues/?filter=-1&jql=project%20%3D%20FUNCTEST%20AND%20status%20in%20(Open%2C%20%22In%20Progress%22)%20AND%20resolution%20%3D%20Unresolved%20ORDER%20BY%20updatedDate%20DESC
08:20:07 <jose_lausuch> #info : problem with ODL reporting is fixed, and now it also works with APEX. Tim Rozet had a fix for accessing the SDN_CONTROLLER_IP
08:20:30 <jose_lausuch> #info  vPing_ssh has been deactivated for ODL_L3 scenarios, due to an ODL Bug: https://bugs.opendaylight.org/show_bug.cgi?id=5586
08:20:52 <jose_lausuch> #info it will be reactivated as soon as we now floating ips work again
08:21:29 <jose_lausuch> #info The functest timeout for daily-smoke tests has been fixed to 120 seconds (2hours) and that has triggered some timeouts in some scenarios/installers. For example JOID or APEX: #link https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console
08:21:42 <jose_lausuch> #link https://build.opnfv.org/ci/job/functest-joid-baremetal-daily-master/116/console
08:21:46 <jose_lausuch> #link https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console
08:22:08 <jose_lausuch> #info let's put it to 180 for now: https://gerrit.opnfv.org/gerrit/#/c/17541/
08:22:19 <jose_lausuch> #info for apex, it could be due to the security install test, when installing OpenSCAP
08:22:24 <jose_lausuch> #info for JOID, the tests take longer than normal. For example, healthcehck takes 7 miinutes, whereas normally it takes 4. Tempest takes 60 minutes to complete whereas it takes 30 minutes max normally...
08:22:36 <jose_lausuch> May-meimei: what is the status for compass?
08:23:53 <May-meimei> https://build.opnfv.org/ci/view/functest/job/functest-compass-virtual-daily-master/209/console
08:24:07 <May-meimei> we have this issues but can't find out the reason
08:25:48 <May-meimei> and we have 13 testcases failures of each scenarios
08:27:31 <jose_lausuch> #info some failures in virtual deploements https://build.opnfv.org/ci/view/functest/job/functest-compass-virtual-daily-master/209/console
08:27:40 <jose_lausuch> #info compass looks quite "blue" in baremetal https://build.opnfv.org/ci/view/functest/job/functest-compass-baremetal-daily-master/
08:27:52 <jose_lausuch> #info Tempest takes around 10 minutes to execute all the smoke test in Compass
08:28:02 <jose_lausuch> May-meimei: can I ask you a favor?
08:28:21 <jose_lausuch> May-meimei: do you see the deprecation warnings for keystone?
08:28:49 <jose_lausuch> May-meimei: in fetch_os_creds.sh there is a call to endpoints "keystone endpoint-list". and that causes all those ugly warnings
08:29:01 <jose_lausuch> May-meimei: can you change that to openstack endpoint list or something that works?
08:30:57 <May-meimei> use "openstack endpoint list" instead?
08:31:35 <May-meimei> you mean this warning: Deprecated: authenticate of the v2 Authentication APIs is deprecated as of Mitaka in favor of a similar function in the v3 Authentication APIs.
08:32:07 <jose_lausuch> May-meimei: yes
08:32:32 <jose_lausuch> DeprecationWarning: The keystone CLI is deprecated in favor of python-openstackclient. For a Python library, continue using python-keystoneclient.
08:33:47 <May-meimei> this waring affect a lot?
08:34:31 <jose_lausuch> May-meimei: not now, but it might affect in latter versions of openstack
08:34:39 <May-meimei> oh! got your meaning
08:34:40 <jose_lausuch> and that output is ugly anyway :)
08:34:52 <May-meimei> you mean the output of functest
08:34:54 <jose_lausuch> yes
08:34:57 <May-meimei> :)
08:34:59 <May-meimei> ok!
08:35:00 <jose_lausuch> after fetch_os_creds
08:35:02 <jose_lausuch> I mean
08:35:04 <jose_lausuch> if you have time
08:35:08 <jose_lausuch> it would be nice to get rid of that
08:35:10 <jose_lausuch> if possible
08:35:18 <May-meimei> will do that
08:35:56 <jose_lausuch> May-meimei: thanks
08:36:00 <May-meimei> np
08:36:04 <jose_lausuch> May-meimei: regarding the glance problem
08:36:08 <jose_lausuch> never seen that
08:36:13 <jose_lausuch> 503 Service Unavailable: The server is currently unavailable. Please try again at a later time. (HTTP 503)
08:36:27 <May-meimei> :(
08:36:54 <jose_lausuch> its an strange problem
08:36:54 <May-meimei> we have had this issues after mitaka
08:36:57 <jose_lausuch> does it happen always?
08:37:00 <jose_lausuch> ah
08:37:18 <jose_lausuch> did you try to run things manually?
08:37:22 <jose_lausuch> like creating a glance image
08:37:50 <May-meimei> no
08:38:39 <May-meimei> try glance image-list sometimes successful, sometimes fail
08:38:42 <jose_lausuch> ok
08:38:53 <jose_lausuch> is it something that can be reported to ask.openstack.org?
08:38:59 <jose_lausuch> upstream bug or something
08:40:47 <May-meimei> ok! I will google that issue later
08:41:17 <jose_lausuch> May-meimei: thanks
08:41:28 <jose_lausuch> any other comments from other?
08:41:28 <May-meimei> :)
08:41:31 <jose_lausuch> #topic AoB
08:41:52 <SerenaFeng> https://jira.opnfv.org/browse/FUNCTEST-365
08:42:00 <jose_lausuch> Orange folks are on vacation but boucherv_orange who resists to take vacations :)
08:42:26 <boucherv_orange> jose_lausuch: yes ;-)
08:42:32 <jose_lausuch> SerenaFeng: let me merge this
08:42:33 <jose_lausuch> https://gerrit.opnfv.org/gerrit/#/c/17525/
08:42:41 <SerenaFeng> 'I have summit the code, but got flake8: error: no such option: --first'
08:43:05 <SerenaFeng> all the three summits have the same error
08:43:16 <SerenaFeng> have you encountered that?
08:43:27 <jose_lausuch> SerenaFeng: that is not a problem of your code change
08:43:31 <jose_lausuch> fdegir: https://build.opnfv.org/ci/job/opnfv-lint-verify-master/464/console
08:43:38 <jose_lausuch> running flake8 fails
08:43:43 <SerenaFeng> + xargs flake8 --exit-zero --first + find . -path ./releng_flake8 -prune -o -path ./.tox -prune -o -type f -name '*.py' -print Usage: flake8 [options] file file ...  flake8: error: no such option: --first Build step 'Execute shell' marked build as failure Finished: FAILURE
08:43:44 <jose_lausuch> Usage: flake8 [options] file file ...  flake8: error: no such option: --first
08:44:03 <SerenaFeng> yes, but I got the jekins -1
08:44:06 <jose_lausuch> SerenaFeng: that is the job that is running the code verification
08:44:15 <SerenaFeng> so the code cannot be merged I think
08:44:19 <jose_lausuch> nope
08:44:25 <jose_lausuch> we need to fix that flake8 thingy
08:44:55 <jose_lausuch> we need either Aric or Trevor from helpdesk
08:44:55 <SerenaFeng> So, still I can add to to do the code review?
08:45:17 <jose_lausuch> SerenaFeng: I will contact them, but they live in US... so the fix might come late today :(
08:45:45 <SerenaFeng> So, i will add you to do the code review now? or after the problem is solved?
08:45:52 <jose_lausuch> SerenaFeng: you can add me now
08:45:58 <SerenaFeng> okey
08:46:07 <jose_lausuch> SerenaFeng: and I will merge it as soon as the problem is fixed
08:46:26 <SerenaFeng> okey, thank you.
08:46:50 <jose_lausuch> np
08:47:48 <boucherv_orange> jose_lausuch: In few days, I will commit a code with a change to allow to use other endpoint type like internal or admin not always public
08:47:53 <fdegir> jose_lausuch: flake8 has --first option
08:47:58 <boucherv_orange> It's a new change into JOID code (public api exposition), we must specify the endpoint type to internal (with env variable OS_ENDPONINT_TYPE)
08:48:02 <fdegir> jose_lausuch: but why it fails, I don't know
08:48:08 <fdegir> jose_lausuch: trevor
08:48:12 <jose_lausuch> fdegir: ok, I will write to helpdesk
08:48:15 <jose_lausuch> boucherv_orange: ok
08:48:29 <jose_lausuch> boucherv_orange: sounds good, thanks
08:48:36 <jose_lausuch> #info boucherv_orange will commit a code with a change to allow to use other endpoint type like internal or admin not always public
08:48:41 <jose_lausuch> #info It's a new change into JOID code (public api exposition), we must specify the endpoint type to internal (with env variable OS_ENDPONINT_TYPE)
08:48:43 <boucherv_orange> I wrote some code, and I test rally, tempest vping etc.. And it's ok !
08:48:45 <jose_lausuch> fdegir: thanks
08:49:25 <SerenaFeng> and, I suggest we delete https://wiki.opnfv.org/display/functest/Collection+Of+Test+Results
08:50:04 <SerenaFeng> since it is not used any more, and not consistent with current implementation
08:50:24 <SerenaFeng> It will confuse some people who is not familiar with functest
08:50:42 <jose_lausuch> SerenaFeng: ok, we can delete it
08:51:02 <jose_lausuch> #action jose_lausuch remove or indicate that https://wiki.opnfv.org/display/functest/Collection+Of+Test+Results is outdated
08:51:11 <jose_lausuch> SerenaFeng: can we have something similar for the new version?
08:51:14 <SerenaFeng> suggested by "Klozik, MartinX" <martinx.klozik@intel.com>
08:51:17 <raghu_> hi
08:51:21 <jose_lausuch> although we have swagger
08:51:33 <jose_lausuch> raghu_: hi
08:51:39 <SerenaFeng> for now no
08:51:42 <jose_lausuch> ok
08:51:44 <raghu_> https://jira.opnfv.org/browse/FUNCTEST-176,
08:51:53 <jose_lausuch> ok
08:52:01 <SerenaFeng> but if we keep it, we should keep it consistent with implementation as we did before
08:52:15 <jose_lausuch> #info raghu_ submited this task in releng repo create a web portal to add test case/projects/pods to the DB
08:52:34 <SerenaFeng> we can generate it automatically using swagger-xx, but needs some work to study it
08:52:37 <jose_lausuch> #info https://gerrit.opnfv.org/gerrit/#/c/17243/
08:52:47 <jose_lausuch> SerenaFeng: ok
08:53:18 <raghu_> ok , but same as https://jira.opnfv.org/browse/FUNCTEST-26
08:53:34 <raghu_> which one we considered
08:53:42 <jose_lausuch> raghu_: good question
08:53:52 <jose_lausuch> raghu_: ok, one is the epic
08:54:05 <jose_lausuch> raghu_: and the other one is the task
08:54:11 <raghu_> ok
08:54:15 <jose_lausuch> raghu_: if you need to do more updates, you can create more tasks under that epic
08:54:30 <raghu_> ok sure , i'll
08:54:37 <jose_lausuch> ok
08:54:41 <jose_lausuch> any other business?
08:54:45 <jose_lausuch> otherwise we can close here
08:54:58 <jose_lausuch> raghu_: ok thanks
08:55:11 <SerenaFeng> np
08:55:21 <jose_lausuch> ok
08:55:27 <jose_lausuch> #endmeeting