08:00:14 <morgan_orange> #startmeeting Functest weekly meeting August 9th
08:00:14 <collabot> Meeting started Tue Aug  9 08:00:14 2016 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:14 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:14 <collabot> The meeting name has been set to 'functest_weekly_meeting_august_9th'
08:00:19 <morgan_orange> #topic call roll
08:00:25 <morgan_orange> #info Morgan
08:00:34 <juhak> #info Juha Kosonen
08:00:45 <lhinds> #info Luke Hinds
08:00:47 <SerenaFeng> #info SerenaFeng
08:00:48 <CG_Nokia> #info CG_Nokia (Colum Gaynor)
08:00:52 <JuhaHaapa> #info Juha Haapavirta
08:01:04 <May-meimei> #info meimei
08:01:05 <morgan_orange> #info agenda https://wiki.opnfv.org/display/functest/Functest+Meeting
08:01:23 <raghu_> #info raghavendrachari
08:01:24 <morgan_orange> any topic you want to add to the agenda?
08:01:50 <morgan_orange> #topic Action point follow-up
08:01:59 <morgan_orange> #info AP: jose_lausuch contact moon project to see when the scenario can be active.
08:02:06 <morgan_orange> #info Moon PTL contacted morgan_orange, seems there are OK from releng perspective, ready on functest side (without reporting), wait for scenario run
08:02:14 <morgan_orange> #info AP: jose_lausuch contact Domino team (JIRA) to report the failure.
08:02:36 <morgan_orange> #action morgan_orange check with Domino project (no update seen in the ltos of mail I discovered yesterday)
08:02:44 <morgan_orange> #info AP: jose_lausuch remove or indicate that https://wiki.opnfv.org/display/functest/Collection+Of+Test+Results is outdated
08:03:16 <morgan_orange> SerenaFeng: do you think we should remove the page or precise anything, how oudated is it?
08:03:28 <SerenaFeng> it is for Release B
08:04:02 <SerenaFeng> I think we should think of generate one using swagger-xx
08:04:06 <morgan_orange> OK so i suggest to put the link from the colorado page only and add a statement Brahmaputra only
08:04:15 <SerenaFeng> which will be easy to keep consistent with the code
08:04:19 <SerenaFeng> not do it by hand
08:04:28 <morgan_orange> #action morgan_orange reference this page from Brahamaputra page only
08:04:30 <SerenaFeng> okey
08:04:37 <morgan_orange> "action for Coloradao put the URl to swagger
08:04:48 <morgan_orange> #action morgan_orange  for Coloradao put the URl to swagger
08:04:51 <morgan_orange> ok
08:04:58 <morgan_orange> #info AP: lhinds look into the problem "sudo: hiera: command not found" . Example: https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/108/console
08:05:14 <morgan_orange> #info AP: lhinds: look for the possibility to install OpenSCAP in the docker image so that we dont have to do it while running the job in Jenkins
08:05:24 <morgan_orange> any update lhinds on these 2 points
08:05:35 <lhinds> [1] On my list for this week
08:06:12 <lhinds> [2] It can't be installed on the docker container, not sure who had that idea. But its not a remote scan, its a system scan, so needs to be on the host
08:06:29 <lhinds> but I am looking into the timeout issue and will see what can be done
08:06:50 <morgan_orange> ok
08:07:13 <morgan_orange> #info AP: Manuel Buil troubleshooting ODL-SFC bugs
08:07:22 <morgan_orange> is Manuel around?
08:07:40 <morgan_orange> #info AP: morgan contact copper people to troubleshooting failure problem
08:07:55 <morgan_orange> #action morgan_orange contact bryan_att to sync on this issue
08:08:03 <morgan_orange> #info AP: SerenaFeng contack docker people to trouble shooting failure problem
08:08:34 <SerenaFeng> I think they have already trouble shooting it, so I didn't contact him
08:08:41 <SerenaFeng> I will follow this one
08:08:50 <morgan_orange> ok
08:08:54 <morgan_orange> #info AP: SerenaFeng contact parser people when to start parser test
08:09:14 <SerenaFeng> last week they make a patch to logger the error info
08:09:33 <morgan_orange> #info patch done to get more error for parser
08:09:53 <morgan_orange> #info AP: viktor follow the progress of black list of testcases
08:10:37 <SerenaFeng> "#info patch done to get more error for parser" I mean for the doctor error
08:10:38 <SerenaFeng> sorry
08:11:18 <morgan_orange> for the black list, I saw that valentin validate the exclusion of some tests with joid
08:12:14 <morgan_orange> I think we will have to discuss on the procedure to exclude test cases, the idea is not to exclude test cases because we want 100% of success but we exclude test cases because there is a bug in a component preventing the case to pass
08:12:27 <morgan_orange> we should be careful
08:13:01 <SerenaFeng> I agree
08:13:07 <morgan_orange> #action all formalize the condition for tempest smoke suite case exclusion (may initiate a wiki page for that)
08:13:24 <morgan_orange> #info SerenaFeng morgan discuss about the 'No space left' on testresults.opnfv.org issue
08:13:30 <morgan_orange> #info issue due to elastic search licence issues (lots of logs claiming that the licence is not valid...)
08:13:40 <SerenaFeng> I think 10G is too small
08:14:04 <SerenaFeng> even if we delete elastic search log, only 2G free
08:14:12 <SerenaFeng> easy to run out of space
08:14:23 <morgan_orange> it is not a lot, and one of the concern is that this VM is used for all the reporting
08:14:39 <morgan_orange> I would suggets to boost the capability to 20Go
08:14:50 <morgan_orange> anyway we may have a discussion on how to deal with elastic search
08:14:57 <morgan_orange> shall we contact the people from bitergia
08:14:58 <morgan_orange> ?
08:15:13 <SerenaFeng> yeah, Aric suggest buy an official licence
08:15:24 <morgan_orange> #action morgan_orange ask for x2 on storage capability for the testresult VM
08:15:25 <SerenaFeng> to the helpdesk
08:15:56 <morgan_orange> #action morgan_orange see if we should buy (OPNFV has money..) an elasticsearch licence (if none available for free software project)
08:16:05 <SerenaFeng> for elasticsearch and kibana dashboard is stopped
08:16:15 <morgan_orange> to avoid regular issues with licence expiration
08:16:25 <SerenaFeng> yeah,
08:16:41 <morgan_orange> I will report it to the TSC, we shall prepare the mail together with Juraj
08:16:55 <morgan_orange> #info AP: SerenaFeng jose morgan discuss whether report function will be supported in CLI
08:17:20 <morgan_orange> I saw the mail exchange, it seems that the question is still open
08:17:33 <SerenaFeng> yes
08:17:45 <morgan_orange> the question is shall we upgrade the CLI to add the capability to produce reporting
08:17:47 <SerenaFeng> jose said we should discuss it after the vocation
08:18:05 <morgan_orange> I think we can...lots of integration work at the moment
08:18:06 <SerenaFeng> yeah
08:18:10 <morgan_orange> but just to share with the others
08:18:27 <morgan_orange> we will vote end of August
08:18:41 <SerenaFeng> okey
08:18:42 <morgan_orange> shall we add this function in the CLI or keep it for the CI only
08:19:01 <boucherv_orange> ok
08:19:07 <morgan_orange> #info decision on the integration of reporting capability within the CLi end of August
08:19:22 <morgan_orange> I think it is all for the AP
08:19:29 <morgan_orange> any comment/remark
08:19:52 <morgan_orange> #topic Feature projects integration status
08:20:02 <morgan_orange> I will use the summary done by José
08:20:20 <morgan_orange> #info SDNVPN: completed. Tests running in CI and reporting to DB. Almost a sun in the bgpvpn scenario http://testresults.opnfv.org/reporting/functest/release/master/index-status-fuel.html (maybe when you read this it is a sun hopefully)
08:20:27 <morgan_orange> #info ODL-SFC: integration completed but execution with bugs. Being troubleshooted by Manuel Buil. He will provide more fixes in Functest during next days. Please Valentin and Serena, give him a +2 and merge when he needs it. When they produce some results, they need to add the code to report it to the DB.
08:20:35 <morgan_orange> #info ONOS-SFC: Integrated and running and reporting to DB. But they use the name ‘onos’ for both test cases: the default ‘onos’ we already had before, and ‘onos_sfc’ for the new SFC test case. I suggested them to split that into 2 different test cases à keep the old onos test and add a new test in the features tier for the sfc test. https://jira.opnfv.org/browse/ONOSFW-172
08:20:43 <morgan_orange> #info Multisite: They run tempest with a specific configuration.  https://git.opnfv.org/cgit/functest/tree/ci/exec_test.sh#n161   but the multisite.py script is still empty… They are running the tests virtually, specially tempest. Still some failures: https://build.opnfv.org/ci/view/functest/job/functest-fuel-virtual-suite-master/lastBuild/console
08:20:54 <morgan_orange> #info Moon: I have no info about it. The scenario is not active in CI, so no tests run…
08:20:59 <morgan_orange> #info Domino: the test fails
08:21:06 <morgan_orange> #link https://build.opnfv.org/ci/view/functest/job/functest-joid-baremetal-daily-master/132/console
08:21:11 <morgan_orange> #info Copper: the test is integrated but it fails.
08:21:15 <morgan_orange> #link https://jira.opnfv.org/browse/COPPER-20
08:21:20 <morgan_orange> #link https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/131/console
08:21:24 <morgan_orange> #info Doctor: the test fails in CI.
08:21:28 <morgan_orange> #link https://jira.opnfv.org/browse/DOCTOR-63
08:21:36 <morgan_orange> #link https://build.opnfv.org/ci/view/functest/job/functest-apex-apex-daily-master-daily-master/131/console
08:21:39 <morgan_orange> #info Parser: VNF integrated
08:21:40 <morgan_orange> #link https://gerrit.opnfv.org/gerrit/#/c/17785/
08:22:04 <morgan_orange> I took the point in the AP to discuss with Bryan (copper) and Ruan (moon)
08:22:27 <morgan_orange> I will also contact Domino
08:22:40 <morgan_orange> SerenaFeng: you are in touch with Doctor team?
08:22:47 <morgan_orange> and Parser team?
08:23:02 <SerenaFeng> I am in touch with parser team
08:23:07 <SerenaFeng> doctor not yet
08:23:25 <SerenaFeng> I think parser will be ready tomorrow
08:23:45 <morgan_orange> anyone from onos-sfc on the chan?
08:24:37 <morgan_orange> the split mentioned by José should not be difficult, it already exists in the DB as 2 test cases are defined
08:24:40 <morgan_orange> onos and onos_sfc
08:25:10 <morgan_orange> #info parser should be ready this week
08:25:30 <morgan_orange> #info possibility to split onos and onos_sfc already possible in the DB
08:25:43 <morgan_orange> #action morgan_orange contact onos-sfc to discuss this option
08:25:56 <morgan_orange> anyone in touch with multisite team?
08:26:19 <morgan_orange> I think May-meimei submitted a patch I merged yesterday
08:26:31 <morgan_orange> that should fix the issue
08:26:44 <May-meimei> #info: last two failures, Ashish is working on this issure
08:26:44 <May-meimei> # https://build.opnfv.org/ci/view/functest/job/functest-fuel-virtual-suite-master/15/console
08:27:57 <morgan_orange> ok troubleshooting in progress with 2 remaining errors
08:28:20 <morgan_orange> any volunteer to follow doctor?
08:28:35 <SerenaFeng> I will
08:28:45 <morgan_orange> ok thanks
08:29:01 <morgan_orange> for the moment it is systematically failing so apex scenario scoring is impacted
08:29:10 <morgan_orange> http://testresults.opnfv.org/reporting/functest/release/master/index-status-apex.html
08:29:30 <morgan_orange> it is possible to put doctor in black list to avoid taking it into account for the display until it is fixed into the CI
08:29:52 <morgan_orange> lhinds: note that I also for the moment excluded security_scan from the reporting
08:30:19 <morgan_orange> #action SerenaFeng contact Doctor team to support integration
08:30:32 <lhinds> morgan_orange: did not follow, from reporting or runnning?
08:30:40 <morgan_orange> just reporting
08:30:55 <lhinds> ok
08:31:07 <morgan_orange> the url I mentioned above, it is automatically done based on the results stored in the DB
08:31:18 <morgan_orange> and the declaration of the testcases in the testcases.yaml
08:31:50 <morgan_orange> security_scan is declared so it should be part of the test case mentioned in the page, it is currently not because I excluded it temporarily, but I can re enable it
08:31:59 <morgan_orange> as you want
08:32:10 <lhinds> is this until something is fixed?
08:32:40 <morgan_orange> it makes sense to enable it when it is clean from a CI perspective
08:33:07 <lhinds> ah ok, so currently it seems to be running ok against compute, but not controllers
08:33:28 <lhinds> I think something is wrong in Apex, but I need to get to the bottom of it
08:33:47 <lhinds> but I don't mind you turning off for now, to reduce the noise
08:33:52 <lhinds> that's fine by me.
08:33:59 <morgan_orange> and for the moment you run the scan and cretae the page for the artifcat but you do not push anything in DB
08:33:59 <morgan_orange> http://testresults.opnfv.org/test/api/v1/results?case=security_scan&last=10
08:34:12 <morgan_orange> so it makes sense to keep it in the reporting black list
08:34:21 <morgan_orange> ok
08:34:33 <morgan_orange> #topic Colorado status
08:34:42 <morgan_orange> #info documentation
08:35:07 <morgan_orange> CG_Nokia: I saw your mail and your questions, I hope I can try to process them today
08:35:15 <CG_Nokia> ok
08:35:35 <CG_Nokia> if we can have short webex it will be more efficient for u!
08:35:57 <CG_Nokia> I know u are busy however.
08:36:19 <morgan_orange> ok let's do it at 2 PM (CET), you send me an invitation?
08:36:36 <CG_Nokia> morgan_orange: ok
08:37:00 <morgan_orange> #action CG_Nokia organize webex to discuss remaining topic on documentation
08:37:22 <morgan_orange> #info scenarios: almost 7 now per installer, with new fdio scenario recently
08:37:43 <morgan_orange> did anyone get any question from fdio team?
08:38:51 <morgan_orange> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59
08:39:43 <morgan_orange> #info most of the JIRA linked to project integration now
08:40:06 <morgan_orange> some may be abandonned, no news from tacker since summit
08:41:23 <morgan_orange> I do not know if we reported a status to David for the release, but I think we are between Green and Orange
08:41:59 <SerenaFeng> I think jose send a mail to David
08:42:00 <morgan_orange> the framework is ready, we are now wotrking on feature project integration, troubleshooting and finalizing the documentation
08:42:36 <morgan_orange> was there any discussion on the daily/weekly Ci loop?
08:43:00 <morgan_orange> test in weekly loops are not run at all now (e.g. vIMS, tempest full or rally Full)
08:43:10 <SerenaFeng> no
08:43:20 <morgan_orange> could make sense to try to run them
08:43:43 <morgan_orange> ok I will contact Fatih, there was a discussion on CI refactoring, I need to see the update
08:44:11 <morgan_orange> #action morgan_orange contact releng team to see if we could have weekly run on Sunday to give a chance to vIMS, Tempest full and Rally full
08:44:48 <morgan_orange> any concern/remark/issue you want to share with Colorado?
08:45:06 <boucherv_orange> morgan_orange: thanks
08:45:38 <morgan_orange> regarding elastic search, during the summit we got a presentation from bitergia
08:45:50 <morgan_orange> they are now using ELK
08:46:03 <morgan_orange> OPNFV has a contract with them
08:46:32 <morgan_orange> I think it would make sense to see if they could hemp us to valorize our data as we are able to export our mongo data to elastic search
08:47:15 <morgan_orange> I can try to initiate a mail with SerenaFeng Juraj Frank and Ray before we try to contact bitergia
08:47:49 <morgan_orange> #action morgan_orange initiate mail for bitergia related to test results
08:47:55 <morgan_orange> #topic Dovetail
08:48:19 <morgan_orange> #info we may plan a GTM next week for an update on dovetail
08:48:58 <morgan_orange> #info dovetail aims to select a subset of functest/yardstick/storeperf/* test projects to qualify and certify as system as an OPNFV system
08:49:15 <morgan_orange> they are involved in the next plugfest (beginning of December)
08:49:39 <morgan_orange> #action morgan_orange invite hongbo to present Dovetail update to Functest team
08:50:09 <morgan_orange> BTW does anyone plan to attend the hackfest or the plugfest?
08:50:48 <morgan_orange> for the plugfest, we will need a Functest representative, but we have still time to discuss it
08:50:58 <morgan_orange> it will be hosted in Boston in UNH
08:51:08 <morgan_orange> #topic Student Intern project proposals
08:51:21 <morgan_orange> #info mark created a page for intern program
08:51:32 <morgan_orange> #link https://wiki.opnfv.org/display/DEV/Intern-projects-page
08:51:53 <morgan_orange> as a confluence MC he also create a button...so creating a proposal is very simple
08:52:18 <morgan_orange> several academic partners are already referenced (CENGN, Okinawa, UNH,...)
08:52:26 <morgan_orange> Fraunhoffer should join
08:52:47 <morgan_orange> so if you have ideas (and have time to mentor) feel free to add proposal
08:53:16 <morgan_orange> I think it could make sense to propose some basic VNF integration or simple additional functional tests
08:53:47 <morgan_orange> #action all brainstorm on intern proposals
08:54:18 <morgan_orange> we can exchange by mail on the proposal before submitting
08:54:28 <morgan_orange> #topic AoB
08:55:09 <morgan_orange> #info I have been contacted by OAI (Open Air Interface), I would invite them to a weekly test meeting
08:55:19 <morgan_orange> they are interested to add tests
08:55:23 <morgan_orange> so for D release
08:56:38 <morgan_orange> I planned to organize a Functest meetup (as we did in Espoo) for D release beginning of October
08:56:43 <morgan_orange> after C release
08:57:38 <SerenaFeng> I think OpenStack Summit is in October
08:58:07 <morgan_orange> yes 25-28 October
08:58:38 <morgan_orange> so we could do it the week before
08:58:46 <morgan_orange> not strong view now
08:59:12 <morgan_orange> did you plan to go to barcelona?
08:59:29 <SerenaFeng> don't know yet
08:59:33 <SerenaFeng> depend on the boss
08:59:44 <morgan_orange> how was Shangai? did you meet Rally's people?
09:00:48 <SerenaFeng> they just work on Rally very soon
09:00:59 <SerenaFeng> do some bugfix just like us
09:01:17 <morgan_orange> ok
09:01:26 <morgan_orange> anything you want to add for today?
09:01:49 <SerenaFeng> I haven't update testapi in testresults
09:01:55 <SerenaFeng> I will do it tomorrow
09:02:09 <morgan_orange> #info testapi update planned for tomorrow
09:02:34 <morgan_orange> ok so thanks for your participation, have a good week
09:02:35 <morgan_orange> #endmeeting